Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Sony Reader


Thread Tools Search this Thread
Old 02-18-2013, 07:42 AM   #1
Junior Member
wangyijie began at the beginning.
Posts: 1
Karma: 10
Join Date: Feb 2013
Device: Sony PRS-T2
An unsupported model by this updater is connected.

Hi there, I've got a problem with my Sony Reader PRS-T2 recently when I wanted to update its firmware. My PRS-T2 works normally and when I connect it to the computer after I run the updater, it says: An unsupported model by this updater is connected.

I'm 100% sure that I'm using a PRS-T2 and a PRS-T2 updater. I've tried to restart the updater several times but nothing changed. I am currently using Windows 8 on my computer but I've also tried it on a computer with Windows 7 with no result. I tried to initialise the reader by choosing the Format option in its preferences, and I connected it again, still unsupported. Last time I succeeded to update it but I was using a Mac and an updater for Mac to do this.

Thanks for any help!
wangyijie is offline   Reply With Quote
Old 05-06-2013, 01:35 PM   #2
Junior Member
philby began at the beginning.
Posts: 1
Karma: 10
Join Date: Apr 2013
Device: Sony PRS-T2
I just had the same problem. The firmware update is for EU models only. I thought that I had a PRS-T2/EU but it turns out that it's a US one.

Look in Settings, Application Preferences, Dictionary. If you only have English, Spanish & French dictionaries you are probably running with US firmware. You could also check in Settings, General Settings, Country/Region. If the choice is only United States or Canada this is a US reader.

The US & EU types are hard-coded and you can tell by using this procedure from Shark69's rooting instructions which one you have.

Connect the Reader to your PC and run these from a command prompt:
. \ Ebook_msc.exe name PRS-T2/2001 getdrv

. \ Ebook_msc.exe name PRS-T2/2044 getdrv

When your command responds with a letter, this is yours. If the response is NONE, that is not your model.

My guess is, the first command will give you a letter, meaning your device is US and so the latest firmware update cannot be applied.
philby is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PRS-T1 Japanese PRS-T1/G1 2.0 updater available Snorkledorf Sony Reader 16 04-19-2012 06:13 AM
problem with updater fubarsnafu Calibre 10 06-20-2011 11:51 PM
Firmware Update Late Updater oddeyed Amazon Kindle 1 11-16-2010 05:10 PM

All times are GMT -4. The time now is 01:44 PM. is a privately owned, operated and funded community.