Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Sony Reader


Thread Tools Search this Thread
Old 11-21-2009, 02:08 AM   #1
Junior Member
tyutchev began at the beginning.
Posts: 1
Karma: 10
Join Date: Nov 2009
Device: sony prs-600
[SOLVED] problem ejecting reader and sending files to it

Hi all.

I'm new to this reader stuff, and been having some problems with the prs-600 I just got.

First question: I looked all over and that behaviour wasn't supposed to happen. When I disconnect the device (either with Calibre or the usb icon on the tray bar), following everything I should, I get the default message "USB connect" (as if it meant "it is connect to your pc and I'm not accessing anything right now"). However, by pulling the cable out and, say, after a few minutes plugging it back in, I receive a message in windows (in my case windows vista ultimate x64) telling me that the device's file system might be damaged and that I should scan it for errors (the typical msg when one disconnects the usb cable while it's being accessed by some process). If I reformat the memory and plug the cable, there's no problem at all, only after I've connected the reader one or two times after that.

As it shouldn't be like that (I guess), I was wondering if anyone might have heard of an issue like this one. At first I thought it could be the AV (in this case, kaspersky) not letting the device go (even though the drives aren't showing in windows explorer), but it wasn't the case, since it happens anyway with the AV turned off. Thought it could be some unidentified garbage with my pc, but I just reformated and still no deal.

The second issue is with copying speed: I don't know if that's also normal (I haven't seen any complaint about it on the forums), but while copying books to the reader's internal memory, it sometimes takes a looong time to get the job done (it at all). I'm using the latest calibre (but I don't think calibre has anything to do with it, since it is the same using sony's connect software or with direct copy with windows explorer). I do hope it's not some kind of hardware problem (even it seems unlikely, since the books that get sent work perfectly: pages turning, zooming, changing sizes, annotations and highlights, etc.). The CONNECT software is the worst (always hanging, getting to a state of "not responding") In any case and with either calibre or sony ebook library it might take minutes to send a small pdf file to the reader (I mean an small essay with less than 30 pages and a little bit more than 200kb of file size). If that's normal, well, I'll just have to get used to it =p.

I've tried looking all over the forums, but found nothing like it, although I found many other infos that helped quite a lot with other stuff.

I don't know if I could provide any other info that might give any insight into that, but here goes the pc specs:

intel core 2 quad Q9300 2.5 ghz
2 gb ddr3 mem
geforce 8800 gs 384mb video mem
OS: windows vista ultimate x64

Any help would be appreciated.


sry, should have updated this earlier. Found the problem (both were from the same source) and I guess lots of people might have experienced it without knowing, so, that's the reason I thought a feedback might help some.

FIRST: how to know if that's the problem I faced. The main "symptom" is difficulty to access the data inside the reader's memory. It gets unstable: a file might be copied (or it might result in error) after a looong time and the programs accessing the data stop responding quite often.

SOLUTION (in my case): it was a problem with energy demand. I was plugging the reader into the usb at the front panel (which sometimes might provide a little bit less than the usb ports directly into the motherboard). Since I nerver had such a problem with any device, that was quite new. The solution was just to start using the usb ports at the back of the computer (direct from the motherboard). Now everything works as a charm.

Hope it helps.

Last edited by tyutchev; 11-23-2009 at 10:01 PM.
tyutchev is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Slight problem sending lrf files to Sony PRS-600 speakingtohe Calibre 2 04-14-2010 01:50 AM
Calibre: Issue Sending to Reader Draccy Calibre 5 03-07-2010 04:50 PM
Sending files directly to PRS500 without Calibre quicksilver Calibre 6 12-23-2009 04:58 PM
Astak EZ Reader Pocket Pro Problem with .prc Files cdfick Astak EZReader 24 10-08-2009 01:07 PM
calibre - prs-505 - sending to sd corrupts files ykmm Sony Reader 5 07-31-2009 06:47 PM

All times are GMT -4. The time now is 01:14 PM. is a privately owned, operated and funded community.