Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre


Thread Tools Search this Thread
Old 10-14-2011, 03:38 PM   #1
Junior Member
GMRabelink began at the beginning.
GMRabelink's Avatar
Posts: 8
Karma: 10
Join Date: Oct 2011
Device: Nook Simple Touch Glowlight
Exclamation Problems with 'search-and-replace' conversion in versions 0.8.21 and/or 0.8.22?


Is anybody having problems with 'search-and-replace' conversions in the Calibre versions 0.8.21 and/or 0.8.22?

I've been using regexs in conversions for some time now and usually I get the job done pretty well.
Yesterday I updated to Calibre version 0.8.21; everything seemed OK. But then I tried a LIT to EPUB conversion, using 'search-and-replace'. I ended up with an EPUB file, but no replaced statements...
The regex I used was really very simple and worked perfectly when I tested it; all the desired expressions were highlighted.

I made several attempts; conversion works, the replace-function doesn't.
Today I saw the announcement of version 0.8.22 and decided to update again. Maybe then 'search-and-replace' would work again...? It didn't.

In the job details, I can see the regexs I used (bold):

'sr1_replace': u'<p>FOXMASK DIT IS EEN TEST</p>',
'sr1_search': u'<p>F O X M A S K</p>',

'sr2_replace': None,
'sr2_search': None,
'sr3_replace': None,
'sr3_search': None,

Looks like the conversion detects the 'search-and-replace' commands, but I can't find anything that looks related to it in the rest of the job details.

Also, the Calibre version 0.8.22 is very, very slow...
It takes up to a minute to open a regular expression Wizard. This used to take a few seconds.

Is anybody having similar problems?

Last edited by GMRabelink; 10-14-2011 at 03:41 PM.
GMRabelink is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
search and replace - drops blanks in replace ? cybmole Conversion 10 03-13-2011 03:07 AM
macro - Search and Replace oldbwl Workshop 17 03-05-2011 01:39 PM
Search and Replace problem naro_c Conversion 5 02-25-2011 12:59 AM
Search and replace in 0.2.0 paulpeer Sigil 7 03-13-2010 11:59 AM
Why no search and replace? charleski Sigil 10 11-24-2009 04:13 PM

All times are GMT -4. The time now is 05:06 PM. is a privately owned, operated and funded community.