Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > PocketBook


Thread Tools Search this Thread
Old 07-02-2011, 02:42 PM   #1
darkforce began at the beginning.
Posts: 32
Karma: 10
Join Date: May 2010
Location: Bangkok, Thailand
Device: Pocketbook 360
Question Stuck at startup logo with endless loading

It happened when I open a book via shortcut menu. Rebooting with factory-default logo and stucking on this screen. Nothing response but power button. All I can do is just turn it off.

These are what I tried...

- press reset button
- plug to power line.
- plug to power line then press reset button.
- plug to PC
- put off battery and put it in again. (either with or without power line)
- update firmware in the same version (15.3) (completely)

It's still not work. Do anyone have an idea what's going on?

Thank you for advance

UPDATE: I've already solved it by hard reset. But still wonder why it happened.

Last edited by darkforce; 07-02-2011 at 03:01 PM.
darkforce is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to create your own Startup/Off-Logo Ulli PocketBook 19 10-26-2013 09:33 PM
Startup logo BMP (tree of characters) robberthof PocketBook 2 04-15-2011 10:38 AM
PRS-505 Sony stuck at startup dude101 Sony Reader 7 01-11-2011 12:33 AM
Please help! Stuck at startup Orochi Kobo Reader 5 12-24-2010 08:57 AM
Troubleshooting Kindle 2 stuck in endless reboot cycle mowog74 Amazon Kindle 5 12-13-2010 02:35 PM

All times are GMT -4. The time now is 07:55 AM. is a privately owned, operated and funded community.