Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Android Devices > enTourage eDGe > enTourage Archive


Thread Tools Search this Thread
Old 04-07-2010, 04:59 AM   #1
Edge User
Unhappy Touch Screen No Longer Responds After Coming Out Of Locked Mode


I have had a problem where I put the device into locked mode and don't touch anything for a while ~15 minutes or longer. Then, when I go to unlock the device it will unlock and display the home screen (like normal), however after this point the touch screen does not work and will not register any clicks (the side-buttons still work, but appear sluggish to the screen takes a long time to rotate, or it takes a long time for the settings menu to appear).
Also, when I power it off at this point the device does not go through the normal shutdown procedure, it just hard-shuts off and the last page I was reading on the 2nd pane remains visible when it is in the powered off state.

Repowering the device causes it to behave normally again. (annoying, but a workaround at least in the meantime).

Anyone else have this problem?
Any suggestions?
Old 04-07-2010, 08:19 AM   #2
Edge User
How do you have your eDGe oriented - is it folded back on itself, or laying flat and open, etc? If you move the eDGe into different positions (folded back on itself, or laying flat and open, etc), does touch screen start to work?

See this link for what I mean by the different positions:
Old 04-08-2010, 12:03 PM   #3
Edge User

I had the same thing happen yesterday. After unlocking the display the LCD was on, but it wasn't registering screen clicks. I had put the Settings icon on the home desktop and was able to get into the configuration to start LCD calibration using the trackball. The calibration program accepted my first screen click for the first target, and then after that nothing. Eventually, I just shut it down and restarted and then it worked fine.

Maybe this is (oddly) wifi related? The experience above happened the first time I started the edge at home with the wifi switched on after it had spent the day at work where wifi was not available and the wifi interface turned off.

I've noticed another odd happening with the LCD screen today. The screen is set to turn off/lock after two minutes and it is doing this. But, today, at a longer interval -- seems to be about 5 minutes -- the screen keeps turning itself back on. Two theories for this: 1) I left the edge's wi-fi turned on this morning here at work where there is no wifi. Yesterday, when the wifi switch was turned off this was not occurring. 2) Something is being routinely updated on the home desktop causing it to think it needs to turn on the lcd backlight.

Update: I think this second behavior is somehow related to battery charging or to the process that monitors the battery charging. I went to view the battery use and instead of seeing a list of processes/apps and the percentage of battery used the screen is blank with just a title message "While last unplugged for 1s". It was previously unplugged and in use for several hours last night. It has been plugged in the entire time in the office and the battery has reached fully charged status, so it appears to me that it is confused about the time it spent on battery power last night.

I disconnected the power cable for a few minutes and then after putting it back on the power adapter the Battery Status display now reports some processes and a reasonable time spent on battery, AND the screen has stopped turning itself back on every few minutes.

So, at least as far as this second behavior goes it appears there's something in the edge that gets confused when the system is operated and shut down on battery, and then later restarted on the power adapter.

Last edited by kenjennings; 04-08-2010 at 12:51 PM.
Old 04-08-2010, 11:21 PM   #4
Edge User
I had this same issue twice so far. Both times I let the system sit for multiple minutes. No response. My only recourse was a hard boot. On the next boot everything worked as it should.
Old 04-09-2010, 02:02 AM   #5
Edge User
My system was in the default orientation (so you can read it side-by-side with the e-ink display).

I waited for some time and it did not begin to respond again. (though the side buttons worked, but produced very sluggish response.)
Old 04-12-2010, 03:30 AM   #6
Edge User
I have had the same experience as noted above.... use the icon to lock the screen.... then some time later come back and the screen is unresponsive to taps. Power down is different in that it suddenly powers down, without the dialog box, as noted above by casualt (4-7-2010).

I have also found, that if I do not use the icon to lock the screen, but simply close the eDGe, which also puts it in lock mode and turns off the backlight, that it wakes up fine every time.

So, I no longer use the lock icon....just close the device.
Old 04-12-2010, 10:50 PM   #7
Edge User
Thanks for the question.... yes...I am pushing the "menu" bezel button to wake up the eDGe. After doing so, it commonly (though not 100% of the time) is "frozen" requiring power down and re-boot, which results in a normally operating system
Old 04-12-2010, 11:16 PM   #8
Edge User
And, I'm assuming you're pressing "menu" twice. That's what I have to do to wake it up. The documentation makes it look like you should only need to hit menu once, then a touch will unlock it. But I found I have to hit menu twice then I'm good to go.
Old 04-13-2010, 01:11 AM   #9
Edge User
Yes, I am pushing it twice. I will try again a few times just to see what happens, being sure to push twice. Thanks.
Old 04-13-2010, 11:33 AM   #10
Edge User
I have experienced this multiple times, and it seems to always be worse if I have locked the screen. Yesterday I was going to walk away for awhile, so I turned off the wireless card, locked the screen, then closed the unit up. When I came back, it was totally unresponsive on the LCD side. The power button was still lit up, the trackball was lit up, and interestingly, the ereader side was still totally functional. I just could NOT get the LCD to reactivate. Here's what I tried: I closed and reopened the unit. I pressed, re-pressed, and held the Menu button. I pressed all of the other buttons too. I folded the screens back-to-back. I plugged in and unplugged the power cord. Finally, I held the power button in to force it to turn off. That did not would not shut down. Through all of this the e-reader was happily chugging along. Finally, there was no other option but to remove the battery.
This has happened to me multiple times. Sometimes I can shut it down with the button, but usually it requires pulling the battery. And this leads me to a major gripe. The battery is INSANE to try to get out! Whoever came up with this design gets an award for "End User Frustration". Once or twice I've been able to turn it up on edge to let gravity assist in removing it. But that doesn't seem to work well anymore. I have to exert inward pressure on the release buttons, which holds the battery into the unit. The last couple times I have had to resort to releasing the catch on one end while using a thin knife blade to pull that end outward as far as possible. Then release the catch on the other end and it finally pops out. It would help to be an octopus during this operation though.
Obviously, no thought was given to the possibility of having to do this routinely.

This lock-out problem NEEDS TO BE FIXED, and FAST. This is more critical than adding functionality at this point.
Old 04-13-2010, 07:52 PM   #11
Edge User
I experienced this error once the first week I started using my eDGe. I attributed it to using the EsiScreenLock "app" from the recent app menu (press and hold Home key). My eDGe has never not unlocked from LCD timeout or using the System Menu>Lock Icon.

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
night mode for ipod touch? wyndslash Apple Devices 1 02-27-2011 10:52 AM
EBW locked in "theater demo" mode joshbutcher Fictionwise eBookwise 2 11-09-2010 02:43 PM
Need help with my PP.The screen is freeze at locked and has white lines. attapol Astak EZReader 13 06-20-2010 10:19 PM
the screen just freezes at locked Riiyachan Astak EZReader 5 04-14-2010 06:34 PM
Amazon Kindle and Sony Reader Locked Up: Why Your Books Are No Longer Yours AdamGott News 217 03-30-2008 10:36 AM

All times are GMT -4. The time now is 08:14 PM. is a privately owned, operated and funded community.