Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Android Devices > enTourage eDGe > enTourage Archive


Thread Tools Search this Thread
Old 04-06-2010, 12:43 AM   #1
Edge User
"USB Memory Stick Blank or using unsupported filesystem"

Is anybody else is having this problem? I can't get a USB memory flash stick to mount on the Edge. I've formatted several different sticks with NFTS, FAT, FAT32, and MacOS with no luck. I've even tried getting the Edge to format the flash disk but nothing seems to happen.

Pretty frustrating!

What gives?

Old 04-06-2010, 01:17 PM   #2
Edge User
Are the sticks you're trying of different brands/capacities or are they the same product? I had the same problem with an SD card, but it was only 1 card. When I tried a different card, it worked fine. The two were very different in size (2GB vs. 8 or 16GB) and I think someone has started a thread where people can list which cards do/don't seem to be recognized.

Maybe we need a similar thread for USB flash drives.
Old 04-06-2010, 01:21 PM   #3
Edge User
haven't run into this myself (knock on wood), but is there a way to format the USB drive directly from the eDGe? (I'm going to assume no, since the Android OS is a mobile platform, and before now, wouldn't need to really accomplish such a task - but it might be a useful little 3rd party utility for someone who can write Android apps)
Old 04-06-2010, 01:34 PM   #4
Edge User
No, I used a USB drive with no problems at all. I stuck it into the computer - it formatted it in whatever Vista 64 is using (NTFS or Fat 32) and the eDGe read it without a problem. It's a Kingston 8GB drive.
Old 04-06-2010, 01:58 PM   #5
Edge User
I know the default setting in Windows is for quick format, so when you were formatting the drive on your computer did you only try doing quick formats? If so, please try doing a full format and let us know if it works after that.
Old 04-06-2010, 06:42 PM   #6
Edge User
Hello. I finally got it to work with ALL of my USB pen drives. I used a mac (Snow Leopard) so I'm not sure how this would work with Windows.

1. Insert your USB drive into your Mac
2. Open up Disk Utility
3. Highlight the USB drive the left column
4. Click PARTITION (not ERASE).
5. On the Volume Scheme, choice 1 partition
6. Click the OPTIONS Button and chose MASTER BOOT RECORD
7. Click OK
8. Name the drive what your like
9. Choose FAT as your FORMAT
10. Click APPLY

And voila! Every disk of mine now works flawlessly with the EDGE. One might try this on a malfunctioning SDHC card, though I haven't yet as mine worked out of the box.

Good Luck...

Old 04-07-2010, 11:28 AM   #7
Edge User
Moving this thread to the General Help Forum.

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kindle international "unsupported country" avinatbezeq Amazon Kindle 6 07-21-2010 10:05 AM
Sending to USB memory stick on Iliad klikklak Calibre 2 03-23-2010 07:53 AM
"book unsupported" after adding new? schnerd Amazon Kindle 3 01-02-2010 01:23 PM
TrustedReviews - USB Memory Stick Test Colin Dunstan Lounge 1 10-11-2004 10:35 AM

All times are GMT -4. The time now is 12:55 AM. is a privately owned, operated and funded community.