Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 08-12-2011, 06:21 AM   #1
iomari
Zealot
iomari doesn't litteriomari doesn't litter
 
iomari's Avatar
 
Posts: 134
Karma: 100
Join Date: Aug 2003
Location: Nigeria
Device: galaxy tab
upgrading from 8.13 to 8.14

Greetings,
I have been happily using 8.13 for some time now on opensuse 11.4. I just saw that 8.14 is out and when I try to install I now get:
Spoiler:



-> python setup.py install

*
* Running build
*


####### Building extension speedup #######

####### Building extension icu #######

####### Building extension sqlite_custom #######

####### Building extension chmlib #######

####### Building extension chm_extra #######

####### Building extension magick #######

####### Building extension pdfreflow #######

####### Building extension lzx #######

####### Building extension fontconfig #######

####### Building extension msdes #######

####### Building extension cPalmdoc #######

####### Building extension podofo #######
g++ -O3 -Wall -DNDEBUG -fno-strict-aliasing -pipe -fPIC -pthread -I/usr/include/python2.7 -I/usr/include/podofo -c /mnt/installs/iomari/Downloads/20110812/calibre/src/calibre/utils/podofo/podofo.cpp -o /mnt/installs/iomari/Downloads/20110812/calibre/build/objects/podofo/podofo.o
Linking podofo


g++ /mnt/installs/iomari/Downloads/20110812/calibre/build/objects/podofo/podofo.o -o /mnt/installs/iomari/Downloads/20110812/calibre/src/calibre/plugins/podofo.so -Wall -shared -lpython2.7 -L/usr/lib -lpodofo



####### Building extension pictureflow #######

####### Building extension progress_indicator #######

*
* Running gui
*


*
* Running install
*

INSTALL paths:
LIB: /usr/lib/calibre
SHARE: /usr/share/calibre
Installing binary: /usr/bin/ebook-device
Installing binary: /usr/bin/ebook-meta
Installing binary: /usr/bin/ebook-convert
Installing binary: /usr/bin/markdown-calibre
Installing binary: /usr/bin/web2disk
Installing binary: /usr/bin/calibre-server
Installing binary: /usr/bin/lrf2lrs
Installing binary: /usr/bin/lrs2lrf
Installing binary: /usr/bin/calibre-debug
Installing binary: /usr/bin/calibredb
Installing binary: /usr/bin/calibre-parallel
Installing binary: /usr/bin/calibre-customize
Installing binary: /usr/bin/calibre-complete
Installing binary: /usr/bin/pdfmanipulate
Installing binary: /usr/bin/fetch-ebook-metadata
Installing binary: /usr/bin/epub-fix
Installing binary: /usr/bin/calibre-smtp
Installing binary: /usr/bin/calibre
Installing binary: /usr/bin/lrfviewer
Installing binary: /usr/bin/ebook-viewer
Installing mount helper to /usr/bin/calibre-mount-helper
Installing code to /usr/lib/calibre
Installing resources to /usr/share/calibre
Setting up bash completion...
Installing bash completion to /etc/bash_completion.d/calibre
Traceback (most recent call last):
File "setup.py", line 99, in <module>
sys.exit(main())
File "setup.py", line 85, in main
command.run_all(opts)
File "/mnt/installs/iomari/Downloads/20110812/calibre/setup/__init__.py", line 163, in run_all
self.run_cmd(self, opts)
File "/mnt/installs/iomari/Downloads/20110812/calibre/setup/__init__.py", line 159, in run_cmd
cmd.run(opts)
File "/mnt/installs/iomari/Downloads/20110812/calibre/setup/install.py", line 139, in run
self.run_postinstall()
File "/mnt/installs/iomari/Downloads/20110812/calibre/setup/install.py", line 185, in run_postinstall
manifest=self.manifest)
File "/mnt/installs/iomari/Downloads/20110812/calibre/src/calibre/linux.py", line 139, in __init__
self.setup_completion()
File "/mnt/installs/iomari/Downloads/20110812/calibre/src/calibre/linux.py", line 213, in setup_completion
f.write(opts_and_words('fetch-ebook-metadata', fem_op, []))
File "/mnt/installs/iomari/Downloads/20110812/calibre/src/calibre/linux.py", line 421, in opts_and_words
opts = '|'.join(options(op))
File "/mnt/installs/iomari/Downloads/20110812/calibre/src/calibre/linux.py", line 410, in options
parser = option_parser()
File "/mnt/installs/iomari/Downloads/20110812/calibre/src/calibre/ebooks/metadata/sources/cli.py", line 32, in option_parser
parser.add_option('-t', '--title', help='Book title')
File "/usr/lib/python2.7/optparse.py", line 1018, in add_option
raise TypeError, "invalid arguments"
TypeError: invalid arguments


Any suggestions?

Moderator Notice
Please use the spoiler tag (eye with red slash)around long error log messages

Last edited by theducks; 08-12-2011 at 11:07 AM.
iomari is offline   Reply With Quote
Old 08-12-2011, 06:37 AM   #2
aceflor
Constant Angel
aceflor ought to be getting tired of karma fortunes by now.aceflor ought to be getting tired of karma fortunes by now.aceflor ought to be getting tired of karma fortunes by now.aceflor ought to be getting tired of karma fortunes by now.aceflor ought to be getting tired of karma fortunes by now.aceflor ought to be getting tired of karma fortunes by now.aceflor ought to be getting tired of karma fortunes by now.aceflor ought to be getting tired of karma fortunes by now.aceflor ought to be getting tired of karma fortunes by now.aceflor ought to be getting tired of karma fortunes by now.aceflor ought to be getting tired of karma fortunes by now.
 
aceflor's Avatar
 
Posts: 3,037
Karma: 42000000
Join Date: Aug 2009
Location: where the sun lives, or so they say
Device: This one, and that one too
8.14 is not out, at least not yet.... !!??!! Where did you get this update ?
aceflor is offline   Reply With Quote
 
Advertisement
Old 08-12-2011, 06:41 AM   #3
itimpi
Wizard
itimpi ought to be getting tired of karma fortunes by now.itimpi ought to be getting tired of karma fortunes by now.itimpi ought to be getting tired of karma fortunes by now.itimpi ought to be getting tired of karma fortunes by now.itimpi ought to be getting tired of karma fortunes by now.itimpi ought to be getting tired of karma fortunes by now.itimpi ought to be getting tired of karma fortunes by now.itimpi ought to be getting tired of karma fortunes by now.itimpi ought to be getting tired of karma fortunes by now.itimpi ought to be getting tired of karma fortunes by now.itimpi ought to be getting tired of karma fortunes by now.
 
Posts: 4,106
Karma: 780247
Join Date: Nov 2008
Device: Sony PRS-950, iphone/ipad (Marvin/iBooks/QuickReader)
I cannot help you with the above error, but just in case you are not aware of it I thought it worth mentioning that you are trying the source install rather than the binary install? The source install is much more likely to hit issues than the binary install.
itimpi is offline   Reply With Quote
Old 08-12-2011, 06:55 AM   #4
iomari
Zealot
iomari doesn't litteriomari doesn't litter
 
iomari's Avatar
 
Posts: 134
Karma: 100
Join Date: Aug 2003
Location: Nigeria
Device: galaxy tab
Ok now I'm confused. i get this from their site a few days ago and now the same site shows 8.13. I found about about 8.14 from their site. But today it says 8.13 again. I actually have the 8.14 download but I get the errors already mentioned. I also did the install straight from http://calibre-ebook.com/download_linux" which was 8.14 a few days ago but now it says 8.13. maybe I'm losing my mind.
iomari is offline   Reply With Quote
Old 08-12-2011, 07:31 AM   #5
DoctorOhh
US Navy, Retired
DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.DoctorOhh ought to be getting tired of karma fortunes by now.
 
DoctorOhh's Avatar
 
Posts: 8,908
Karma: 12755553
Join Date: Feb 2009
Location: North Carolina
Device: Nexus 7
Quote:
Originally Posted by iomari View Post
Ok now I'm confused. i get this from their site a few days ago and now the same site shows 8.13. I found about about 8.14 from their site. But today it says 8.13 again. I actually have the 8.14 download but I get the errors already mentioned. I also did the install straight from http://calibre-ebook.com/download_linux" which was 8.14 a few days ago but now it says 8.13. maybe I'm losing my mind.
Delete the download you have of 0.8.14. Later today after the new binary of 0.8.14 is released do a binary install as stated here.
DoctorOhh is offline   Reply With Quote
Old 08-12-2011, 07:41 AM   #6
iomari
Zealot
iomari doesn't litteriomari doesn't litter
 
iomari's Avatar
 
Posts: 134
Karma: 100
Join Date: Aug 2003
Location: Nigeria
Device: galaxy tab
Thanks. I'm waiting ........ :-)
iomari is offline   Reply With Quote
Old 08-12-2011, 08:24 AM   #7
Manichean
Wizard
Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!Manichean My eyes! My eyes! The light is just too bright!
 
Manichean's Avatar
 
Posts: 3,130
Karma: 80520
Join Date: Feb 2008
Location: Germany
Device: Cybook Gen3
Quote:
Originally Posted by iomari View Post
Ok now I'm confused. i get this from their site a few days ago and now the same site shows 8.13.
If "their site" is not http://www.calibre-ebook.com or the mirrors listed there, I'd seriously advise against downloading. You should only get your Calibre from the official mirrors.
Manichean is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PRS-650 I'm upgrading!!! jenieliser Sony Reader 13 05-19-2011 06:22 AM
Need help with upgrading jrollins Calibre 9 04-19-2011 09:35 PM
Upgrading MAC - Help! tonyt Calibre 6 11-07-2009 01:42 PM
Upgrading Calibre p3aul Calibre 2 04-14-2009 02:10 AM
Error Upgrading PieOPah Calibre 2 03-08-2009 02:31 PM


All times are GMT -4. The time now is 06:03 PM.


MobileRead.com is a privately owned, operated and funded community.