Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Sony Reader > Sony Reader Dev Corner


Thread Tools Search this Thread
Old 06-27-2009, 04:40 PM   #1
Junior Member
StanleyPhang began at the beginning.
Posts: 1
Karma: 10
Join Date: Apr 2009
Device: 505
[solved] Help unbricking my 505!!!

10 times resetting method works like a charm!

I was using PRS Customizer to flash my 505, and my major purpose was to substitute the default fonts with Unicode fonts (which maybe a cause for the problem, but I remember these fonts can be used without flashing when using methods mentioned here in one of the sticky posts) I found in Hi-PDA forum.

But the process turned my 505 into a brick and I tried unbricking it several times and none succeeded (Obviously, I forgot to flash my 505 back before I going on with this reflash, this maybe one cause). Right now, my winxp system recognize there is usb drives connected but cannot access them. sony updater also says "connect a 505 to update" though the 505 IS connected by a usb cable. I reset several times and each time it all stuck at starting up screen.

Last edited by StanleyPhang; 06-27-2009 at 05:43 PM. Reason: solved
StanleyPhang is offline   Reply With Quote
Old 07-07-2009, 04:05 PM   #2
siulayhumga began at the beginning.
Posts: 55
Karma: 12
Join Date: Jun 2009
Device: Sony PRS 505
Have you try the instruction listed in the "*VERY* detailed guide on changing default Reader fonts" thread?
siulayhumga is offline   Reply With Quote

brick 505

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hacks unbricking a Kindle (framework won't start) marchello2000 Amazon Kindle 7 04-19-2012 11:11 AM
Hacks Any advice on unbricking the Kindle 2? synapse Amazon Kindle 5 01-20-2010 08:45 PM
Even unbricking reset is not working !!! alaya129 Sony Reader 25 09-14-2008 11:11 AM
Frozen, unbricking reset won't even work taz0k Sony Reader 13 06-04-2007 08:34 AM
Donations for unbricking dev. Iliads? CommanderROR iRex 23 11-21-2006 03:56 PM

All times are GMT -4. The time now is 10:55 AM. is a privately owned, operated and funded community.