Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre Companion

Notices

Reply
 
Thread Tools Search this Thread
Old 04-19-2017, 04:30 PM   #16
kdsksg
Member
kdsksg began at the beginning.
 
Posts: 11
Karma: 10
Join Date: Apr 2015
Device: iphone 6 Marvin
Oops! I forgot to attach the files. I've sent them again.

As to the other connection methods, I started a content server on calibre, but could not connect to it from the web browser on my device ("took too long to respond"). I also tried reaching it from another computer, which could not connect with the same error.
Just for completeness, I tried to connect to the content server from CC, which came up with the error that the content server was not running. And, of course, wireless device connection simply failed, as it has been.

So this would seem to indicate that the issue is on my home Wi-Fi network, instead?
Should I still try upgrading my calibre version, or is that no longer necessary?
kdsksg is offline   Reply With Quote
Advert
Old 04-19-2017, 05:04 PM   #17
chaley
CC Android & calibre dev
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 8,526
Karma: 2569714
Join Date: Jan 2010
Location: France
Device: Many android devices
Quote:
Originally Posted by kdsksg View Post
Oops! I forgot to attach the files. I've sent them again.
This log is clearly not complete. Putting aside the WD debug messages, calibre prints something like the following once it is fully initialized.
Code:
Started up in 4.05 seconds with 77 books
I don't see that line in your log. Are you saving the entire log, or are you copying the part that you can see in the window?

Grasping at straws, it could be that there was a logging problem in older versions of calibre.
Quote:
As to the other connection methods, I started a content server on calibre, but could not connect to it from the web browser on my device ("took too long to respond"). I also tried reaching it from another computer, which could not connect with the same error.
Just for completeness, I tried to connect to the content server from CC, which came up with the error that the content server was not running. And, of course, wireless device connection simply failed, as it has been.

So this would seem to indicate that the issue is on my home Wi-Fi network, instead?
Should I still try upgrading my calibre version, or is that no longer necessary?
Unfortunately the experiment doesn't provide definitive answers, but the implication is that the problem is in the hub or in the computer running calibre. If you were running Windows then I would be very confident that the problem is the firewall or the AV. Unfortunately I am ignorant about Macs, but as they must have some network security the problem could easily be there.

If the problem is with the hub then things become more complicated because it sometimes works. That implies transient problems instead of configuration problems. One transient problem is load from nearby hubs, which a wifi channel scan might help diagnose. See http://osxdaily.com/2013/12/11/find-...less-tool-mac/. Another might be that the router has "degraded" to the point where its program memory is no longer correct. This can often be fixed by "re-flashing" the router's firmware. It could also be that the router is broken, but this is far enough down the list that we can ignore it.

Finally, it could be that the entire network is no longer stable, where IP addresses aren't unique. This can happen if the router is rebooted or otherwise disappears for a time. The fix is to shutdown every device, reboot the router, then restart the devices one by one. This happens to me every 18 months or so.

I really wish I could tell you to "do this and it will work". Unfortunately, networking problems are hard. We have had cases where we never found the problem.
chaley is offline   Reply With Quote
Old 04-19-2017, 05:42 PM   #18
kdsksg
Member
kdsksg began at the beginning.
 
Posts: 11
Karma: 10
Join Date: Apr 2015
Device: iphone 6 Marvin
I've been taking the file that opens, and using Save As to save a copy to the desktop, from where I attach it to the emails. As far as I'm aware, that should copy it in its entirety, but even scrolling through the original file that opens, there was no further details to be had.

I'll work through those router suggestions tonight - other than those, is there anything else I should be trying? It sounds like there may still be issues with calibre itself, if it's not producing proper debug logs, or if the WC driver isn't starting up properly.

In any case, thank you very much for your help, you've been incredibly helpful in working through this!!
kdsksg is offline   Reply With Quote
Old 04-19-2017, 10:08 PM   #19
kdsksg
Member
kdsksg began at the beginning.
 
Posts: 11
Karma: 10
Join Date: Apr 2015
Device: iphone 6 Marvin
I followed the directions that you provided to do a Wi-Fi channel scan, and adjusted the channels on my router accordingly. As of right now, calibre and CC are connecting reliably. I'm not sure if this is due to adjusting the router channels or simply because I had to reboot the router in the process. I will check again in the morning.

However, while it's working, I ran another debug session, in which I opened calibre, connected with CC, transferred a book, and closed the session. The logs are attached in another email. Notably, these logs do contain the SMART_DEV lines.
kdsksg is offline   Reply With Quote
Old 04-20-2017, 06:57 AM   #20
chaley
CC Android & calibre dev
chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.chaley ought to be getting tired of karma fortunes by now.
 
Posts: 8,526
Karma: 2569714
Join Date: Jan 2010
Location: France
Device: Many android devices
Quote:
Originally Posted by kdsksg View Post
I followed the directions that you provided to do a Wi-Fi channel scan, and adjusted the channels on my router accordingly. As of right now, calibre and CC are connecting reliably. I'm not sure if this is due to adjusting the router channels or simply because I had to reboot the router in the process. I will check again in the morning.

However, while it's working, I ran another debug session, in which I opened calibre, connected with CC, transferred a book, and closed the session. The logs are attached in another email. Notably, these logs do contain the SMART_DEV lines.
Glad to hear it, and I hope it continues to work.

And yes, that log looks exactly like it should. I wish I understood why the others did not.
chaley is offline   Reply With Quote
Advert
Reply

Tags
android, connection issues, osx, samsung

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Calibre 2 & OSX 10.8 pthwaite Calibre 2 08-23-2014 08:54 AM
Testing ePub publications with an Android emulator for OSX Giordano Galli Android Developer's Corner 0 09-08-2011 03:49 PM
Touchscreen Page Turns RARELY Work fascha Barnes & Noble NOOK 4 01-14-2011 04:25 PM
OSX Support & DRM Nonsence hudsong Bookeen 56 10-04-2007 10:14 PM
Help with HandStory & Mac OSX! daught Reading and Management 7 01-22-2004 01:44 PM


All times are GMT -4. The time now is 08:03 AM.


MobileRead.com is a privately owned, operated and funded community.