Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Sony Reader


Thread Tools Search this Thread
Old 12-30-2011, 01:30 PM   #1
Junior Member
toad1960 began at the beginning.
Posts: 1
Karma: 10
Join Date: Dec 2011
Device: prs-505
In middle of screen is a triangle with ! in middle

I am hoping someone may have come across this before , I have changed to new a new PC with Windows 7 and when going to put a new book on my wife's 505 I could not drag and drop from explorer as usual.
When we turned the e reader back on it was at the main menu but with a triangle with ! in the middle of the screen in a darker font than the menu.
I have tried a soft boot , hard boot which takes me to reformat but will not , charged it for hours on end before both , tried the sony updater which just told me had the most up to date software but running out of ideas.
As a newbie here I did search the forums for similar problems so sorry if this is covered elsewhere.
toad1960 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
A black cross in the middle of the screen! mauperio Fictionwise eBookwise 7 12-16-2011 09:47 PM
Liz In The Middle Elizabeth Lane Introduce Yourself 5 12-14-2011 05:32 PM
Middle of France mikethemadmonk Introduce Yourself 6 02-12-2011 05:09 AM
Clumsy is my middle name! rgtrys Which one should I buy? 7 12-17-2010 09:49 AM
Hello from the middle of France cazeault Introduce Yourself 6 01-15-2010 12:56 AM

All times are GMT -4. The time now is 08:23 PM. is a privately owned, operated and funded community.