Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Android Devices > enTourage eDGe > enTourage Archive


Thread Tools Search this Thread
Old 08-30-2010, 08:49 AM   #1
Edge User
Unhappy Dead battery?

Yesterday I was using my edge to read, and all of the sudden it powered off and the battery appeared dead. I thought maybe I didn't have it properly plugged in overnight and began recharging it. It has been well over 12 hours and it is still at 0%. The green light is blinking steady, however the little battery indicator on the lcd screen does not show anything going on. Any ideas?
Old 08-30-2010, 09:11 AM   #2
Edge User
Your battery may have a good connection? Have you tried removing it and then putting it back?
Old 08-30-2010, 09:26 AM   #3
Edge User
Yes, I tried that a couple of times. I also jiggled the connections to see if that changed anything, and I switched outlets just in case there was an issue with that. When it first happened, the indicator on the lcd did show that it was charging, but now it just shows a small bit of orange, with no movement. Does that sound like a problem with the battery, or the unit?
Old 08-30-2010, 09:37 AM   #4
Edge User
It sounds like what first happened to me, and the problem was a bit of both actually. I had received the wrong AC adaptor (as did some of the pre-orderers who received the first shipment) so the charging pin was technically the wrong size and it was hit or miss whether it would actually charge the battery. I also happened to have (either as a coincidence, or as a result of running it for a couple of weeks with the wrong AC adaptor) a defective battery that wouldn't fully charge. When I received the replacement battery and AC adaptor, things were fine.

So if it's the problem I had, it's that you might have the wrong size charging connection. If you search earlier threads, you'll probably see people talk about the different millimeter measurements of the connector (check around the first couple of weeks of April). Then, try measuring the length of your AC tip to see whether maybe you just got one of the old chargers by mistake.

Is your machine relatively new? I think it took a week or maybe even two for me to notice the problem. The good news is, if that's the problem, it's a quick fix, and the unit would be fine. I know it was a relief to me knowing the unit itself was OK.
Old 08-30-2010, 09:43 AM   #5
Edge User
I was in the second batch to receive them, I think it was in April. I haven't had any charging problems in the past. It just suddenly happened.
Old 08-30-2010, 10:18 AM   #6
Edge User
The small pin length was 7.5mm. I had one of those, and the eDGe would charge fine most of the time, all though I had to jiggle it just a bit to be sure. The proper pin length is 9mm, which fits fully.

The "bit of orange" you're seeing means the battery's below 15%.

It does sound like your battery may be defective (it happens ), or it simply may have "died" early, so if you contact enTourage tech support directly, I'm sure they'll help you out.
Old 08-30-2010, 10:23 AM   #7
Edge User
Sarah, looks like you may be right. I just got off of the phone with customer support and they think it is the battery and I should have a new one shortly. I have to say, whenever I have had questions or problems (all of which, up to this point were problems with me not doing something right, not the edge), they have been very helpful and courteous.

Thank you for your help and time, Jen.
Old 08-30-2010, 10:24 AM   #8
Edge User
And thank you Done and Borisb as well. :-)

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead Battery wzambotti Kobo Reader 1 04-09-2011 06:38 AM
Dead Battery?? novels.books Astak EZReader 9 09-12-2010 08:40 AM
The EE Battery dead keng2000 enTourage Archive 16 07-10-2010 04:37 PM
Do I Have a Dead Battery? Acreo Aeneas Astak EZReader 36 06-14-2010 07:29 PM
Very dead battery nesagwa Sony Reader 4 05-14-2009 10:32 AM

All times are GMT -4. The time now is 12:03 AM. is a privately owned, operated and funded community.