Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Recipes


Thread Tools Search this Thread
Old 10-05-2012, 01:54 PM   #1
jpassarella doesn't litterjpassarella doesn't litter
Posts: 18
Karma: 152
Join Date: Mar 2009
Location: NJ
Device: none
Running recipe error: Python function terminated unexpectedly (Error Code: 1)

This morning, one of my two custom recipes started generating an error. I'm using Calibre 0.9.1 after using 0.9.0 produced th error. The other recipe worked. This one continues to fail. The copy-to-clipboard message is below. I google-searched for the error and most of the results are from 2010 and a few 2011. I tried recreating the recipe, then removing the line I added yesterday: timefmt = '' (to try to get older issues to go into a folder on my Kindle). I added that to the other recipe and it didn't create a problem. Usually if there's an error in the feed's recipe it won't let you save it w/o noting the error. So I'm a little lost here. Any ideas?

_John Passarella

calibre, version 0.9.0 (win32, isfrozen: True)
Conversion Error: Failed: Fetch news from Courier Post

Fetch news from Courier Post
Resolved conversion options
calibre version: 0.9.0
{'asciiize': False,
'author_sort': None,
'authors': None,
'base_font_size': 0,
'book_producer': None,
'change_justification': 'original',
'chapter': None,
'chapter_mark': 'pagebreak',
'comments': None,
'cover': None,
'debug_pipeline': None,
'dehyphenate': True,
'delete_blank_paragraphs': True,
'disable_font_rescaling': False,
'dont_compress': False,
'dont_download_recipe': False,
'duplicate_links_in_toc': False,
'enable_heuristics': False,
'extra_css': None,
'extract_to': None,
'filter_css': None,
'fix_indents': True,
'font_size_mapping': None,
'format_scene_breaks': True,
'html_unwrap_factor': 0.4,
'input_encoding': None,
'input_profile': <calibre.customize.profiles.InputProfile object at 0x03EE6F10>,
'insert_blank_line': False,
'insert_blank_line_size': 0.5,
'insert_metadata': False,
'isbn': None,
'italicize_common_cases': True,
'keep_ligatures': False,
'language': None,
'level1_toc': None,
'level2_toc': None,
'level3_toc': None,
'line_height': 0,
'linearize_tables': False,
'lrf': False,
'margin_bottom': 5.0,
'margin_left': 5.0,
'margin_right': 5.0,
'margin_top': 5.0,
'markup_chapter_headings': True,
'max_toc_links': 50,
'minimum_line_height': 120.0,
'mobi_file_type': 'old',
'mobi_ignore_margins': False,
'mobi_keep_original_images': False,
'mobi_toc_at_start': False,
'no_chapters_in_toc': False,
'no_inline_navbars': True,
'no_inline_toc': False,
'output_profile': <calibre.customize.profiles.KindleOutput object at 0x03EF1270>,
'page_breaks_before': None,
'personal_doc': '[PDOC]',
'prefer_author_sort': False,
'prefer_metadata_cover': False,
'pretty_print': False,
'pubdate': None,
'publisher': None,
'rating': None,
'read_metadata_from_opf': None,
'remove_fake_margins': True,
'remove_first_image': False,
'remove_paragraph_spacing': False,
'remove_paragraph_spacing_indent_size': 1.5,
'renumber_headings': True,
'replace_scene_breaks': '',
'search_replace': None,
'series': None,
'series_index': None,
'share_not_sync': False,
'smarten_punctuation': False,
'sr1_replace': '',
'sr1_search': '',
'sr2_replace': '',
'sr2_search': '',
'sr3_replace': '',
'sr3_search': '',
'start_reading_at': None,
'tags': None,
'test': False,
'timestamp': None,
'title': None,
'title_sort': None,
'toc_filter': None,
'toc_threshold': 6,
'toc_title': None,
'unsmarten_punctuation': False,
'unwrap_lines': True,
'use_auto_toc': False,
'verbose': 2}
InputFormatPlugin: Recipe Input running
Using custom recipe
Python function terminated unexpectedly
(Error Code: 1)
Traceback (most recent call last):
File "", line 132, in main
File "", line 109, in run_entry_point
File "site-packages\calibre\utils\ipc\", line 186, in main
File "site-packages\calibre\gui2\convert\", line 25, in gui_convert
File "site-packages\calibre\ebooks\conversion\", line 989, in run
File "site-packages\calibre\customize\", line 239, in __call__
File "site-packages\calibre\ebooks\conversion\plugins\recipe_", line 109, in convert
File "site-packages\calibre\web\feeds\", line 881, in download
File "site-packages\calibre\web\feeds\", line 1031, in build_index
File "site-packages\calibre\web\feeds\", line 1445, in parse_feeds
File "site-packages\calibre\web\feeds\", line 371, in get_feeds
jpassarella is offline   Reply With Quote

error code: 1, python function, recipe, running scheduled recipe, terminated unexpectedly

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Calibre produces Python function terminated unexpectedly roelvdh Calibre 6 09-09-2013 08:50 PM
"Error importing EPUB. EOCD not found. Not a ZIP archive? (Error Code 1068)" oren Android Devices 1 02-20-2012 05:10 AM
python function terminated... mac os x smaziz Conversion 3 12-22-2011 04:04 AM
Python Function Error LoveMissBubbly Calibre 5 09-21-2011 05:52 PM
Error: Python function terminated unexpectedly LastMile Calibre 11 01-14-2011 07:07 PM

All times are GMT -4. The time now is 03:15 PM. is a privately owned, operated and funded community.