Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre


Thread Tools Search this Thread
Old 07-21-2011, 08:18 PM   #16
Junior Member
jbmia began at the beginning.
Posts: 5
Karma: 10
Join Date: Jul 2011
Device: Kindle 3
I'm no expert, but...

That init script didn't work till I removed the "-p 80" in the INI section...

Just a heads up... I researched the start-stop-daemon rules and found the -p and -m and --pid-file options... tried adding a -m.. then adding -m and removing -p.. no dice... then just removed "-p 80" and it worked fine...

As it was the script didn't seem to be writing a pid file in /var/run

I'm no coder and have to look up every cli command I need, so I'm not an authority.. YMMV... I'm on Fedora 14.

With all of the above said, HUGE THANKS to the Tedderouni for making the script available!! Gracias!!

edit: I think I realize what might have been going on... Tedderouni was probably setting the port to 80 with that "-p 80", but I'm thinking that daemon start-stop also has a -p, which is used to check for a pid file... per my points above the results are the same, but this may be the reason the daemon wasn't starting and a pid file wasn't being written.. just a thought..


Last edited by jbmia; 07-21-2011 at 08:53 PM. Reason: update...
jbmia is offline   Reply With Quote
Old 07-22-2011, 04:38 PM   #17
Junior Member
Tedderouni began at the beginning.
Posts: 3
Karma: 10
Join Date: Mar 2011
Device: Kindle 3
Glad it was helpful!

The -p 80 does indeed set the port to 80. Calibre server defaults to 8080. I set up a virtual machine specifically for Calibre, so I don't have any other web server running on it. Setting it to use port 80 allows me to type the URL in my address bar without having to specify the port. Any other port has to be specified. If you already have another web server running, for instance Apache, it defaults to port 80, so calibre won't be able to bind to port 80. So if you remove the "-p 80" you'll need to use http://your.calibre.address:8080/

I'll update my previous post with a bit of clarification about this.
Tedderouni is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
UPDATING Calibre ginette Calibre 8 11-15-2014 11:21 PM
updating calibre wrenn1 Kobo Reader 2 06-29-2010 12:22 AM
Problem since updating to Calibre 6.45 garybob Calibre 8 03-19-2010 01:23 PM
Updating Calibre drcjsnider Calibre 3 01-08-2010 12:17 PM
Calibre won't open since updating bobsi18 Calibre 14 11-14-2009 05:03 PM

All times are GMT -4. The time now is 01:29 AM. is a privately owned, operated and funded community.