Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Kobo Reader

Notices

Reply
 
Thread Tools Search this Thread
Old 05-20-2020, 11:51 AM   #1
TheRealJohnAdams
Member
TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.
 
Posts: 20
Karma: 44760
Join Date: May 2020
Device: Kindle Oasis, Kobo Forma
How do I put a non-breaking space in an author's name?

Hi all,

A few people have commented on the difficulty of getting multi-word last names to sort correctly on Kobo. One person said that he had had success using non-breaking spaces, and I believe @davidfor has suggested that solution on several occasions. My problem is that I can't figure out how to do that.

If I enter a non-breaking space directly into the Author field, calibre treats it as a regular space. If I use U+000A0 or \xA0, Calibre (and Kobo) treat those as string literals rather than interpreting them as the non-breaking space character.

If I use  , Kobo does not process the space or anything after it. So, "St. John of the Cross," which should sort as "St. John_of_the_Cross," becomes "St. John of the Cross" in Calibre, which Kobo displays as "St."

I would appreciate any advice.
TheRealJohnAdams is offline   Reply With Quote
Old 05-20-2020, 04:32 PM   #2
TheRealJohnAdams
Member
TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.
 
Posts: 20
Karma: 44760
Join Date: May 2020
Device: Kindle Oasis, Kobo Forma
I am slightly closer to identifying the problem. "Edwin A. Abbott Zeta" yields the following content.opf entry on the Kobo:

Code:
    <dc:creator opf:role="aut" opf:file-as="Abbott Zeta, Edwin A.">Edwin A. Abbott</dc:creator>
    <dc:creator opf:role="aut">nbsp;Zeta</dc:creator>
This results in the book displaying and sorting with the author "Edwin A. Abbott." Changing the content.opf as follows yields "Edwin A. Abbott Zeta," sorted as "Abbott_Zeta"—the desired result.

Code:
    <dc:creator opf:role="aut" opf:file-as="Abbott Zeta, Edwin A.">Edwin A. Abbott&nbsp;Zeta</dc:creator>
Now the only question is how to accomplish this automatically.
TheRealJohnAdams is offline   Reply With Quote
Old 05-20-2020, 09:00 PM   #3
davidfor
Grand Sorcerer
davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.
 
Posts: 19,027
Karma: 32527535
Join Date: Jul 2011
Location: Sydney, Australia
Device: Kobo:Touch,Glo, AuraH2O, GloHD,AuraONE, ClaraHD, Libra H2O; tolinoepos
There has been a lot of discussion on sorting on the device over the years. Replacing the space with a non-breaking space should work. But, how to enter it will probably be the problem. Using the HTML entity isn't going to work, because the text isn't being parsed as HTML when the sorting is being done. There is a similar issue with the other methods mentioned.

I knew something like this had been discussed, so I search the forum. I think https://www.mobileread.com/forums/sh...d.php?t=244593 has the best details. The suggestion there is to use a plugboard to do the changes. The problem with that is it will be an all-or-nothing change.

If you have just a few like this, you can enter the non-breaking space in the author in calibre. I just tested one of these, and it worked in both calibre and on the device. In that case, I entered the non-breaking space using keyboard. Other times, I have used the clipboard to copy from an editor.

I'd suggest trying the ideas mentioned in the thread above and seeing how well they work for you. At least, they should give some more ideas and we can work out what is needed.
davidfor is online now   Reply With Quote
Old 05-20-2020, 09:47 PM   #4
TheRealJohnAdams
Member
TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.
 
Posts: 20
Karma: 44760
Join Date: May 2020
Device: Kindle Oasis, Kobo Forma
Davidfor,

Thanks for the reply. I was hoping you'd see this.

I actually have a custom column that runs in Program mode and should insert non-breaking spaces automatically when the author_sort has more than one word before the comma. (E.g. "John of the Cross, St." would automatically become "John_of_the_Cross, St.") The replacement part works beautifully. But for whatever reason, I can't get it to actually treat the non-breaking space I type into the program as a non-breaking space. If I paste a non-breaking space into the program box, then copy it from the box into a unicode decoder, it somehow turns into an ordinary space.

Just to be totally sure we're on the same page: you have copy-pasted a non-breaking space, while it looks like a space, into a Calibre field, and Calibre has treated it appropriately? If so, is there any reason that this would work when you do it manually, and would work in plugboards, but would fail in the "Program" mode of a custom column?

Thanks again.
TheRealJohnAdams is offline   Reply With Quote
Old 05-20-2020, 11:58 PM   #5
davidfor
Grand Sorcerer
davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.
 
Posts: 19,027
Karma: 32527535
Join Date: Jul 2011
Location: Sydney, Australia
Device: Kobo:Touch,Glo, AuraH2O, GloHD,AuraONE, ClaraHD, Libra H2O; tolinoepos
I entered the non-breaking space for the author in the Manage Authors dailog. That was kept and I can see it is correctly handled on the device. In this case I used the keyboard to type it in (on the numeric keypad, hold ALT down an type 0160).

I just tested this in a plugboard. As I didn't want to mess up my authors, I put the following in and had it go to the Publishers field:

Code:
program: raw_list('tags', ',*')
That is a non-breaking space after the comma in second parameter. The forum software might change it.

When I sent a book with multiple tags, I could see the non-breaking space in the OPF of the book on the device.
davidfor is online now   Reply With Quote
Old 05-21-2020, 07:43 AM   #6
JSWolf
Resident Curmudgeon
JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.
 
JSWolf's Avatar
 
Posts: 56,916
Karma: 52002826
Join Date: Nov 2006
Location: Roslindale, Massachusetts
Device: Kobo Aura H2O, PRS-650, PRS-T1, nook STR, iPad 4, iPhone SE 2020, PW3
With Windows, the simplest solution is to type a non-breaking space from the keyboard using alt-0160 (keypad for the numbers). So when entering an author name you also put in a non-breaking space.
JSWolf is offline   Reply With Quote
Old 05-21-2020, 08:59 AM   #7
Quoth
the rook, bossing Never.
Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.
 
Quoth's Avatar
 
Posts: 1,846
Karma: 8530352
Join Date: Jun 2017
Location: Ireland
Device: Both Kinds: epub based makes and Kindle
Linux:
Compose key then space twice.
I have CapsLock as compose, but the default might be Shift + AltGr (so both shifts together is Caps Lock, hardly ever used, either one shift cancels)

OR

Ctrl Shift Space

Shows as a grey rectangle in LO Writer on Windows, Mac and Linux. The first time you import a docx to Calibre, when there is no existing record, Calibre does create metadata from some of the document properties.

My Lenovo has no numeric pad, nor numlock overlaying the character keys.
Quoth is offline   Reply With Quote
Old 05-21-2020, 09:05 AM   #8
JSWolf
Resident Curmudgeon
JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.
 
JSWolf's Avatar
 
Posts: 56,916
Karma: 52002826
Join Date: Nov 2006
Location: Roslindale, Massachusetts
Device: Kobo Aura H2O, PRS-650, PRS-T1, nook STR, iPad 4, iPhone SE 2020, PW3
Quote:
Originally Posted by Quoth View Post
Linux:
Compose key then space twice.
I have CapsLock as compose, but the default might be Shift + AltGr (so both shifts together is Caps Lock, hardly ever used, either one shift cancels)

OR

Ctrl Shift Space

Shows as a grey rectangle in LO Writer on Windows, Mac and Linux. The first time you import a docx to Calibre, when there is no existing record, Calibre does create metadata from some of the document properties.

My Lenovo has no numeric pad, nor numlock overlaying the character keys.
There is no AltGr on an American keyboard layout. So how would you type a non-breaking space in Linux using an American keyboard?
JSWolf is offline   Reply With Quote
Old 05-21-2020, 09:49 AM   #9
TheRealJohnAdams
Member
TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.TheRealJohnAdams has never been to obedience school.
 
Posts: 20
Karma: 44760
Join Date: May 2020
Device: Kindle Oasis, Kobo Forma
Solution

It's fixed. Thanks, all—and especially @davidfor—for the help. For anyone who finds this thread in the future, the problem and solution were as follows:

When I attempted to manually type a hard space into the author field, it would turn into an ordinary space as soon as I pressed return. I thought this meant that Calibre did not support hard spaces in metadata (which is why I tried to use markup codes), but that is not correct. The solution, which works perfectly, is to go to the Manage Authors window (right click -> Edit Metadata -> click the button to the left of the author field) and edit the relevant author entry to use hard spaces as appropriate. When you do that, all book entries that share that author will have hard spaces.

My guess is that when the author field for a book record is updated, Calibre compares the new author with the existing Authors table. This comparison treats all whitespace the same and is probably case-insensitive too. If a matching author exists, the new author entry is modified to conform to the matching record in the Authors table. In other words, say you have a book with author "John Q. LastName1 space LastName2." The Authors table will contain an entry for "John Q. LastName1 space LastName2." If you edit the book's author to be "John Q. LastName1 nbsp LastName2," Calibre compares that to the Authors table, matches it with "John Q. LastName1 space LastName2," and modifies what you just entered to conform to the entry in the Authors table—destroying your non-breaking space.
TheRealJohnAdams is offline   Reply With Quote
Old 05-21-2020, 12:38 PM   #10
Quoth
the rook, bossing Never.
Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.
 
Quoth's Avatar
 
Posts: 1,846
Karma: 8530352
Join Date: Jun 2017
Location: Ireland
Device: Both Kinds: epub based makes and Kindle
Quote:
Originally Posted by JSWolf View Post
There is no AltGr on an American keyboard layout. So how would you type a non-breaking space in Linux using an American keyboard?
Same way as on mine.
Ctrl Shift Space

OR
<whatever compose key is> Space Space

I'd think Shift AltGr wouldn't be Compose on a US keyboard layout.
A click in the Control Panel Keyboard settings sets CapsLock as Compose, which is handy.

The USA Keyboard layout is more stupid than mobi. Bad for Spanish and missing one ASCII key. Non USA keyboards have an extra letter key to the left side of Z or below the Backspace key (left of Enter). This gives the traditional 96 characters on a daisywheel, with only shift. The true USA layout has only 94.
Also Altgr (or the special key on Apple) allows up to another 96 characters though the UK Windows only adds seven.
AltGr is actually Ctrl-RightAlt, it's not really an extra code. If your keyboard does AltGr (and many US Keyboard do even if not labelle) then it will add accented characters if you change to the US International layout in windows. It makes some keys be dead keys, you press them twice, or else they accent the next letter,
` is the only dead key on my layout. Allows à etc easily. The " is recognised by the Compose key: thus Compose " e is ë
Because I'm not using the Windows US International layout which is the same physical keys, lettering and codes as dumb US English only layout, but enables AltGr and "dead keys" (press twice for key, once plus letter to accent).
Also the US layout gratuitously swaps " @ ' #~ on the keys.
Insanely some USB and BT keyboards for tablets and phones are really UK layouts printed as US! The clue is |\ to the left of the Z and a SECOND key labelled |\ near the Enter key. If you change on Android or iOS to UK layout that key becomes ~#, the 3# becomes 3£, 2@ becomes 2" and "' becomes @'. I think the key with ~` changes to ¬` (Means Not) and altgr of it is ¦.
Some layouts swap the ¦ and | on the printed keys. They are not the same thing even in DOS and Windows scripts!

The right Alt, if there is one, becomes AltGr. Sometimes that's a Menu (or context menu, like right mouse click). On Android the Esc key is "Back".

The Apple US Keyboards do seem to have all the letters and the four leaf clover seems to be AltGr.

IBM really messed up on the USA Keyboard layout. The Apple Mac and UK layout are better. MS DOES have a keyboard layout Editor, the produced file works on Windows 10, but I only have the correct .Net packages to install it on XP and Win7. It lets you have all 48 marking keys (or 47 on USA layout) have AltGr and Shift AltGr, to increase 96 (or 94) to 192 (or 188) characters without a compose key and optionally define which punctuations are "dead keys" for û, ù, ü, ǔ, ú etc.

So even on Windows, it's about 10 years since I needed to use numeric + code. On Windows I either used the Character Map tool (same is on Linux) or used the extended custom layout I created using the MS Windows Keyboard definition tool, free download extending AltGr from about 7 keys to all marking keys.

Last edited by Quoth; 05-21-2020 at 12:43 PM.
Quoth is offline   Reply With Quote
Old 05-21-2020, 03:36 PM   #11
JSWolf
Resident Curmudgeon
JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.
 
JSWolf's Avatar
 
Posts: 56,916
Karma: 52002826
Join Date: Nov 2006
Location: Roslindale, Massachusetts
Device: Kobo Aura H2O, PRS-650, PRS-T1, nook STR, iPad 4, iPhone SE 2020, PW3
Quote:
Originally Posted by Quoth View Post
Same way as on mine.
Ctrl Shift Space

OR
<whatever compose key is> Space Space

I'd think Shift AltGr wouldn't be Compose on a US keyboard layout.
A click in the Control Panel Keyboard settings sets CapsLock as Compose, which is handy.

The USA Keyboard layout is more stupid than mobi. Bad for Spanish and missing one ASCII key. Non USA keyboards have an extra letter key to the left side of Z or below the Backspace key (left of Enter). This gives the traditional 96 characters on a daisywheel, with only shift. The true USA layout has only 94.
Also Altgr (or the special key on Apple) allows up to another 96 characters though the UK Windows only adds seven.
AltGr is actually Ctrl-RightAlt, it's not really an extra code. If your keyboard does AltGr (and many US Keyboard do even if not labelle) then it will add accented characters if you change to the US International layout in windows. It makes some keys be dead keys, you press them twice, or else they accent the next letter,
` is the only dead key on my layout. Allows à etc easily. The " is recognised by the Compose key: thus Compose " e is ë
Because I'm not using the Windows US International layout which is the same physical keys, lettering and codes as dumb US English only layout, but enables AltGr and "dead keys" (press twice for key, once plus letter to accent).
Also the US layout gratuitously swaps " @ ' #~ on the keys.
Insanely some USB and BT keyboards for tablets and phones are really UK layouts printed as US! The clue is |\ to the left of the Z and a SECOND key labelled |\ near the Enter key. If you change on Android or iOS to UK layout that key becomes ~#, the 3# becomes 3£, 2@ becomes 2" and "' becomes @'. I think the key with ~` changes to ¬` (Means Not) and altgr of it is ¦.
Some layouts swap the ¦ and | on the printed keys. They are not the same thing even in DOS and Windows scripts!

The right Alt, if there is one, becomes AltGr. Sometimes that's a Menu (or context menu, like right mouse click). On Android the Esc key is "Back".

The Apple US Keyboards do seem to have all the letters and the four leaf clover seems to be AltGr.

IBM really messed up on the USA Keyboard layout. The Apple Mac and UK layout are better. MS DOES have a keyboard layout Editor, the produced file works on Windows 10, but I only have the correct .Net packages to install it on XP and Win7. It lets you have all 48 marking keys (or 47 on USA layout) have AltGr and Shift AltGr, to increase 96 (or 94) to 192 (or 188) characters without a compose key and optionally define which punctuations are "dead keys" for û, ù, ü, ǔ, ú etc.

So even on Windows, it's about 10 years since I needed to use numeric + code. On Windows I either used the Character Map tool (same is on Linux) or used the extended custom layout I created using the MS Windows Keyboard definition tool, free download extending AltGr from about 7 keys to all marking keys.
US keyboards have no AltGr. I've found little to no use for AltGr. It's a useless key. Better to be a regular ALT like on US keyboards.

What is this extra key? I've not seen an extra key on a UK keyboard other then ¬` and £.
JSWolf is offline   Reply With Quote
Old 05-21-2020, 04:00 PM   #12
Quoth
the rook, bossing Never.
Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.Quoth ought to be getting tired of karma fortunes by now.
 
Quoth's Avatar
 
Posts: 1,846
Karma: 8530352
Join Date: Jun 2017
Location: Ireland
Device: Both Kinds: epub based makes and Kindle
Re-read carefully.
If you have a real USA keyboard it's got one letter/punctuation key less (marking keys). I certainly have had US keyboards (laptops and separate with AltGr, though it's not always marked and may be just Alt if you have the default US Layout installed by default in Windows. Without having at least the US International Setting even using Ctrl -RghtAlt may do nothing instead of accented letters.

There are two Alt keys. Control-RightAlt = AltGr. It gives alternate (mostly accented letters).
Switch your keyboard to US International. It's 100% the same markings on the keys as a regular IBM style USA Keyboard.
Try rightAlt a, i, e, o, u, If that does nothing you have a substandard old style USA keyboard, so then try Ctrl-RightAlt a, i, e, o, u,
Should be á í é ó ú
The ` and some other punctuation keys need pressed twice, or the next letter (perhaps only vowels) get accented à ì è ò ù
Less than 12 of the world lives in the USA. A lot of USA people speak Spanish, maybe some French.

What do you need TWO Alt keys for (or even one?)? Apple's AltGr is the four leaf Clover symbol key.

You know you can trim replies too?

Windows and some other things default to the dumbest US Keyboard layout, the USA Date Format, Letter of A4, and US Currency when a currency symbol is to be automatically inserted. It's been wasting the time of the rest of the world for 30 years on setting up PCs and Printers.
SOME OSes at install time first use ask:
Keyboard physical layout and optional sub layout
Language & Country: Canadians might use British English, US English, Canadian French. Irish people usually use British English. Switzerland has four main languages, but developers might use English. Belgium might have three languages, certainly French and German, some might even prefer Dutch.

As well as Time Zone. At least MS has been asking the Time Zone for over 20 years.

See Regional and Language Settings in Windows. In some OSes, the keyboard layout is in Keyboard Settings, I think in Windows it's in Language, but Dates, Currency, default paper etc is in or affected by Regional settings.

Last edited by Quoth; 05-21-2020 at 04:03 PM.
Quoth is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
KEPUB and non-breaking space Vetchy Kobo Developer's Corner 32 09-28-2019 02:42 AM
non-breaking space cramoisi KOReader 22 04-25-2017 03:47 AM
Non-Breaking space drago87 Conversion 0 01-20-2016 05:52 AM
Why the non-breaking space? Notjohn Sigil 2 06-08-2015 05:24 AM
Non-breaking space JSWolf ePub 31 07-29-2014 08:40 AM


All times are GMT -4. The time now is 09:13 PM.


MobileRead.com is a privately owned, operated and funded community.