Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book General > News

Notices

Reply
 
Thread Tools Search this Thread
Old 06-26-2019, 04:07 PM   #16
DiapDealer
Grand Sorcerer
DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.
 
DiapDealer's Avatar
 
Posts: 20,698
Karma: 110971226
Join Date: Jan 2010
Device: Nexus 7, Kindle Fire HD
Quote:
Originally Posted by Ladyrixx View Post
That's all very odd. For well over a year the latest Ubuntu that will run on a 32-bit system is 16.02 LTS.
Yes. they stopped making 32-bit releases of their OS back in 2017, but this was about supporting 32-bit applications on their 64-bit OSes. You can install the multi-lib packages to support 32-bit binaries on 64-bit machines and THAT is what they were talking about eliminating (or "freezing").
DiapDealer is online now   Reply With Quote
Old 06-27-2019, 04:48 PM   #17
Sirtel
Wizard
Sirtel ought to be getting tired of karma fortunes by now.Sirtel ought to be getting tired of karma fortunes by now.Sirtel ought to be getting tired of karma fortunes by now.Sirtel ought to be getting tired of karma fortunes by now.Sirtel ought to be getting tired of karma fortunes by now.Sirtel ought to be getting tired of karma fortunes by now.Sirtel ought to be getting tired of karma fortunes by now.Sirtel ought to be getting tired of karma fortunes by now.Sirtel ought to be getting tired of karma fortunes by now.Sirtel ought to be getting tired of karma fortunes by now.Sirtel ought to be getting tired of karma fortunes by now.
 
Sirtel's Avatar
 
Posts: 1,599
Karma: 12066931
Join Date: Jan 2014
Location: Estonia
Device: Kindle Voyage, Kindle Oasis 2 & 3, Nook Glowlight Plus (7.8'')
Quote:
Originally Posted by latepaul View Post
I got a new work laptop last week and the version of Windows 10 on it won't install ADE 2.0.1 by default because it requires a really old version of .Net framework which you have to go into the settings to allow it to be installed. I didn't want to do that on my work PC. How long before that setting goes away and you can't install that version of .Net?
That's weird. I bought a new laptop a year ago, with Windows 10, and had no problems installing ADE 2.0.1 (and didn't have to specially allow anything).
Sirtel is online now   Reply With Quote
Advert
Old 06-27-2019, 05:02 PM   #18
lumpynose
Guru
lumpynose ought to be getting tired of karma fortunes by now.lumpynose ought to be getting tired of karma fortunes by now.lumpynose ought to be getting tired of karma fortunes by now.lumpynose ought to be getting tired of karma fortunes by now.lumpynose ought to be getting tired of karma fortunes by now.lumpynose ought to be getting tired of karma fortunes by now.lumpynose ought to be getting tired of karma fortunes by now.lumpynose ought to be getting tired of karma fortunes by now.lumpynose ought to be getting tired of karma fortunes by now.lumpynose ought to be getting tired of karma fortunes by now.lumpynose ought to be getting tired of karma fortunes by now.
 
Posts: 937
Karma: 4444444
Join Date: Jul 2012
Device: Palm Pilot M105
Quote:
Originally Posted by Sirtel View Post
That's weird. I bought a new laptop a year ago, with Windows 10, and had no problems installing ADE 2.0.1 (and didn't have to specially allow anything).
I installed ADE 2.0.1 a day or two ago. I'm running Windows 10 Home version 1809. I used a Windows install that I downloaded from Microsoft's site. Maybe his company has sysadmins who fiddled with his laptop before he got it and changed some security setting?
lumpynose is offline   Reply With Quote
Old 06-27-2019, 07:33 PM   #19
latepaul
Wizard
latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.
 
latepaul's Avatar
 
Posts: 1,185
Karma: 9825742
Join Date: Dec 2011
Device: a variety (mostly kindles and kobos)
No one "fiddled with" my laptop. What they did do is install a standard image on it.

Anyway if you look here you'll see that all versions of Windows 10 come with .net 3.5 (the version ADE wanted) "not installed by default". However it could have been enabled in the OEM image installed by the PC manufacturer, which would explain why it works out of the box for you guys.
latepaul is offline   Reply With Quote
Old 06-27-2019, 09:39 PM   #20
lumpynose
Guru
lumpynose ought to be getting tired of karma fortunes by now.lumpynose ought to be getting tired of karma fortunes by now.lumpynose ought to be getting tired of karma fortunes by now.lumpynose ought to be getting tired of karma fortunes by now.lumpynose ought to be getting tired of karma fortunes by now.lumpynose ought to be getting tired of karma fortunes by now.lumpynose ought to be getting tired of karma fortunes by now.lumpynose ought to be getting tired of karma fortunes by now.lumpynose ought to be getting tired of karma fortunes by now.lumpynose ought to be getting tired of karma fortunes by now.lumpynose ought to be getting tired of karma fortunes by now.
 
Posts: 937
Karma: 4444444
Join Date: Jul 2012
Device: Palm Pilot M105
Quote:
Originally Posted by latepaul View Post
No one "fiddled with" my laptop. What they did do is install a standard image on it.
You're lucky. At my last job the sysadmins were required to install a very locked down version of Windows and you couldn't install apps and had to submit a request for them to install it.
lumpynose is offline   Reply With Quote
Advert
Old 06-28-2019, 01:16 AM   #21
HarryT
eBook Enthusiast
HarryT ought to be getting tired of karma fortunes by now.HarryT ought to be getting tired of karma fortunes by now.HarryT ought to be getting tired of karma fortunes by now.HarryT ought to be getting tired of karma fortunes by now.HarryT ought to be getting tired of karma fortunes by now.HarryT ought to be getting tired of karma fortunes by now.HarryT ought to be getting tired of karma fortunes by now.HarryT ought to be getting tired of karma fortunes by now.HarryT ought to be getting tired of karma fortunes by now.HarryT ought to be getting tired of karma fortunes by now.HarryT ought to be getting tired of karma fortunes by now.
 
HarryT's Avatar
 
Posts: 85,536
Karma: 82356808
Join Date: Nov 2006
Location: UK
Device: Kindle Oasis 2, iPad Pro 10.5", iPhone 6
Quote:
Originally Posted by latepaul View Post
No one "fiddled with" my laptop. What they did do is install a standard image on it.

Anyway if you look here you'll see that all versions of Windows 10 come with .net 3.5 (the version ADE wanted) "not installed by default". However it could have been enabled in the OEM image installed by the PC manufacturer, which would explain why it works out of the box for you guys.
If ADE uses .NET 3.5, its installer should check whether or not it's present on the system and install it if not. Relying on the end user to know how to install runtime support files is very poor practice.
HarryT is offline   Reply With Quote
Old 06-28-2019, 01:47 AM   #22
AnotherCat
Me
AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.
 
Posts: 1,275
Karma: 13726920
Join Date: May 2012
Device: Anything
Quote:
Originally Posted by latepaul View Post
...I got a new work laptop last week and the version of Windows 10 on it won't install ADE 2.0.1 by default because it requires a really old version of .Net framework which you have to go into the settings to allow it to be installed...
Quote:
Originally Posted by latepaul View Post
No one "fiddled with" my laptop. What they did do is install a standard image on it.

Anyway if you look here you'll see that all versions of Windows 10 come with .net 3.5 (the version ADE wanted) "not installed by default". However it could have been enabled in the OEM image installed by the PC manufacturer, which would explain why it works out of the box for you guys.
ADE as far back as at least ver1.7.2 does not need NET 3.5 in order to be installed or run with Windows 10 OS. NET 3.5 does not exist on the PCs I use ADE on.

Furthermore, as Harry said, if it did it require 3.5 it would be installed by the ADE installation.

Last edited by AnotherCat; 06-28-2019 at 01:50 AM.
AnotherCat is offline   Reply With Quote
Old 06-28-2019, 02:04 AM   #23
latepaul
Wizard
latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.
 
latepaul's Avatar
 
Posts: 1,185
Karma: 9825742
Join Date: Dec 2011
Device: a variety (mostly kindles and kobos)
Quote:
Originally Posted by lumpynose View Post
You're lucky. At my last job the sysadmins were required to install a very locked down version of Windows and you couldn't install apps and had to submit a request for them to install it.
Yeah I know. I've never worked somewhere that restrictive myself but colleagues have and I've been on site with customers who have.

We're given a lot of free reign on the basis that we're software engineers but honestly we don't need to do stuff on our own machines except for convenience. I have a separate Windows VM I use for any Windows development though one of my colleagues has dev environments on his laptop.

A previous local IT manager was always trying to get the policy changed. To be honest from a general point of view I agree, from a personal point of view it's nice to have more freedom.

Quote:
Originally Posted by HarryT View Post
If ADE uses .NET 3.5, its installer should check whether or not it's present on the system and install it if not. Relying on the end user to know how to install runtime support files is very poor practice.
That's exactly what it tries to do. It fails because the download link no longer works. The way to install it now is to go into the "add windows features" control panel. And before you say it, I don't think they hard-coded a particular link into their installer. It has the look and feel of a standard install component that was provided at the time - pretty sure I've seen the same dialogs pop up on other installers - which Microsoft have now changed at their end.

Remember 2.0.1 is about 6 years old. A lot has changed in that time.

Quote:
Originally Posted by AnotherCat View Post
ADE as far back as at least ver1.7.2 does not need NET 3.5 in order to be installed or run with Windows 10 OS. NET 3.5 does not exist on the PCs I use ADE on.
Versions prior to 2.0.1 did not require .NET at all, 2.0.1 does. That's one reason why I stuck with 1.7.2 for a long time because it was hard/impossible to install 2.0.1 under Wine. Wine improved enough to make it possible.
latepaul is offline   Reply With Quote
Old 06-28-2019, 11:21 AM   #24
leebase
Karma Kameleon
leebase ought to be getting tired of karma fortunes by now.leebase ought to be getting tired of karma fortunes by now.leebase ought to be getting tired of karma fortunes by now.leebase ought to be getting tired of karma fortunes by now.leebase ought to be getting tired of karma fortunes by now.leebase ought to be getting tired of karma fortunes by now.leebase ought to be getting tired of karma fortunes by now.leebase ought to be getting tired of karma fortunes by now.leebase ought to be getting tired of karma fortunes by now.leebase ought to be getting tired of karma fortunes by now.leebase ought to be getting tired of karma fortunes by now.
 
leebase's Avatar
 
Posts: 2,195
Karma: 15475168
Join Date: Aug 2009
Device: iPad Mini, iPhone X, Kindle Fire Tab HD 8, Walmart Onn
Quote:
Originally Posted by latepaul View Post
True but I don't like the idea of not being able to upgrade it I want/need to for some other reason.

Part of the problem is relying on fixed versions of programs. Right now you can't de-DRM with K4PC 1.26+. So I'd need not only a Wine64 compatible version but for Alf to crack the latest DRM. ADE is even worse because their "new" (> 2.0) DRM means you can't go back. I got a new work laptop last week and the version of Windows 10 on it won't install ADE 2.0.1 by default because it requires a really old version of .Net framework which you have to go into the settings to allow it to be installed. I didn't want to do that on my work PC. How long before that setting goes away and you can't install that version of .Net?

But on the other hand, I have enough to read and I've always said that if we ever get to the point where DRM is uncrackable I'll have to respond appropriately. It'd be a shame if I couldn't put any ebook on any device but I'd live I expect.
Sounds like you might want to setup a vm with all the versions you need....and then just "don't change it"
leebase is offline   Reply With Quote
Old 06-28-2019, 06:37 PM   #25
AnotherCat
Me
AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.
 
Posts: 1,275
Karma: 13726920
Join Date: May 2012
Device: Anything
Quote:
Originally Posted by latepaul View Post
...Versions prior to 2.0.1 did not require .NET at all, 2.0.1 does. That's one reason why I stuck with 1.7.2 for a long time because it was hard/impossible to install 2.0.1 under Wine. Wine improved enough to make it possible.
If you want NET 3.5 features in Windows 10 just enable it in Windows Features (if it is not enabled already).

Last edited by AnotherCat; 06-28-2019 at 07:10 PM. Reason: add "features"
AnotherCat is offline   Reply With Quote
Old 06-28-2019, 07:07 PM   #26
DNSB
Bibliophagist
DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.
 
DNSB's Avatar
 
Posts: 6,096
Karma: 27131869
Join Date: Jul 2010
Location: Vancouver
Device: Kobo Aura One, Aura H2O, Aura HD, Nexus 7 HD, iPad Air, Tolino epos
For what it is worth, before arguing about what versions of .NET/CLR are installed, check the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP key in the registry. The earlier versions will show as keys, (v2.0.507277, v3.0, v3.5, etc.) while the later versions will show under the v4 key in Client and/or Full.
DNSB is online now   Reply With Quote
Old 06-28-2019, 07:42 PM   #27
AnotherCat
Me
AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.AnotherCat ought to be getting tired of karma fortunes by now.
 
Posts: 1,275
Karma: 13726920
Join Date: May 2012
Device: Anything
Quote:
Originally Posted by DNSB View Post
For what it is worth, before arguing about what versions of .NET/CLR are installed, check the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP key in the registry. The earlier versions will show as keys, (v2.0.507277, v3.0, v3.5, etc.) while the later versions will show under the v4 key in Client and/or Full.
I agree except to add (working from memory) the keys for 3.5 and earlier actually refer to if the features of those versions have been enabled in the current NET pack on Windows 10 or not, not that the NET Pack for the version is installed. On seeing your post I added "features" after "NET 3.5" in my preceding post to hopefully make that clearer.

When one enables NET 3.5 features in Windows 10 it may or may not download extra software to do a rebuild with (just as it may do if enabling other features in Windows or other Microsoft applications).

So, to round it up and to be clear what I am saying (I hope ). As I understand it when installing any application (I have come across a number) on a Windows 10 machine and it says you have to install NET 3.5 (or earlier) one does not have to install it. One just has to enable it in Windows 10's "Windows Features" (either via "Programs and Features" or by just typing "Windows Features"). The 3.5 and earlier NET Packs will not show as an installed Pack because as far as I am aware the pack is not installed.

Last edited by AnotherCat; 06-28-2019 at 07:48 PM.
AnotherCat is offline   Reply With Quote
Old 06-29-2019, 12:52 PM   #28
DNSB
Bibliophagist
DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.
 
DNSB's Avatar
 
Posts: 6,096
Karma: 27131869
Join Date: Jul 2010
Location: Vancouver
Device: Kobo Aura One, Aura H2O, Aura HD, Nexus 7 HD, iPad Air, Tolino epos
Quote:
Originally Posted by AnotherCat View Post
I agree except to add (working from memory) the keys for 3.5 and earlier actually refer to if the features of those versions have been enabled in the current NET pack on Windows 10 or not, not that the NET Pack for the version is installed. On seeing your post I added "features" after "NET 3.5" in my preceding post to hopefully make that clearer.

When one enables NET 3.5 features in Windows 10 it may or may not download extra software to do a rebuild with (just as it may do if enabling other features in Windows or other Microsoft applications).

So, to round it up and to be clear what I am saying (I hope ). As I understand it when installing any application (I have come across a number) on a Windows 10 machine and it says you have to install NET 3.5 (or earlier) one does not have to install it. One just has to enable it in Windows 10's "Windows Features" (either via "Programs and Features" or by just typing "Windows Features"). The 3.5 and earlier NET Packs will not show as an installed Pack because as far as I am aware the pack is not installed.
I should have been a bit clearer in that those keys show that the .NET/CLR feature set is available. Those registry keys will be created whether you installed a downloaded .Net install or simply enabled it in Windows features. A program that needs .Net 3.5 could check for the appropriate registry key and if it exists, would not request .Net 3.5 be installed.
DNSB is online now   Reply With Quote
Old 06-30-2019, 05:23 AM   #29
latepaul
Wizard
latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.latepaul ought to be getting tired of karma fortunes by now.
 
latepaul's Avatar
 
Posts: 1,185
Karma: 9825742
Join Date: Dec 2011
Device: a variety (mostly kindles and kobos)
This is all a bit moot. I could easily enable 3.5 and then install ADE 2.0.1 but I chose not to. Partly that was wariness due to previous problems (which seem to now be resolved to be fair). Regardless I only brought it up to point out the way software ages over time, especially binary only stuff like ADE. Maybe .Net 3.5 will always remain available in future versions of Windows, maybe not.

Anyway given that Ubuntu have (partially) reversed themselves the issue is moot for now.

Last edited by latepaul; 06-30-2019 at 05:25 AM.
latepaul is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Calibre update problem under Ubuntu / "E-book converter and library management" pinosan Calibre 2 11-19-2017 06:38 AM
Anyone Else Concerned About the "Up to 8 Hours" Battery Spec. for Kindle Fire? Batman Jr. Kindle Fire 45 10-19-2011 07:32 PM
How do I use "URLLink.acsm" file from Borders.com? (ADE in Wine) KenJackson Sony Reader 31 10-07-2011 03:25 AM
Error dropping books into "Genre", calibre, version 0.7.50 meads Library Management 1 03-21-2011 02:14 PM
Wine bug fixed for "Kindle for PC" KenJackson Amazon Kindle 1 11-29-2010 01:00 PM


All times are GMT -4. The time now is 01:53 PM.


MobileRead.com is a privately owned, operated and funded community.