Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Plugins

Notices

Reply
 
Thread Tools Search this Thread
Old 08-29-2014, 09:00 AM   #1
JSWolf
Resident Curmudgeon
JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.
 
JSWolf's Avatar
 
Posts: 53,506
Karma: 49384553
Join Date: Nov 2006
Location: Roslindale, Massachusetts
Device: Kobo Aura H2O, Sony PRS-650, Sony PRS-T1, nook STR, iPad 4, iPhone 5
Plugins, Qt4, Qt5, and Calibre 2.x

Kovid, can you make the next version of Calibre 2.x refuse to install/try to run a plugin if it doesn't have code for Qt5? This way it would stop people from trying to run a plugin that simply will never work with Calibre 2.x. A good example of this is trying to run the iOS Reader Application plugin that's not Qt5 compatible. Thanks.
JSWolf is online now   Reply With Quote
Old 08-29-2014, 09:08 AM   #2
DiapDealer
Grand Sorcerer
DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.
 
DiapDealer's Avatar
 
Posts: 21,055
Karma: 115443362
Join Date: Jan 2010
Device: Nexus 7, Kindle Fire HD
Quote:
Originally Posted by JSWolf View Post
Kovid, can you make the next version of Calibre 2.x refuse to install/try to run a plugin if it doesn't have code for Qt5? This way it would stop people from trying to run a plugin that simply will never work with Calibre 2.x. A good example of this is trying to run the iOS Reader Application plugin that's not Qt5 compatible. Thanks.
It can't "refuse to run" it, without first trying to run it. At which point, it barks.

As far as installing, all it can do is look for an attempt to import PyQt5 modules: which is still no guarantee that the plugin is going to function. Then you have plugins that don't use GUI widgets at all, so you don't want to exclude them by requiring a PyQt5 module import. You also can't deny installation to plugins that try to import PyQt4 since plugins that strive for backward compatibility need to try and import those.

So you'd be left looking for plugins that try to import BOTH PyQt4 AND PyQt5, which would once again foil plugins that don't use GUI widgets (and still not guarantee the plugin will function correctly).

Even checking to see whether a plugin was a GUI Interface plugin wouldn't really help since even onImport plugins can have custom gui configs. Anything trying to automatically determine whether to block/allow the installation of a plugin would need to heuristically parse almost all of a plugin's code in some way.

I think it's just best for the user to check on a plugin's compatibility themselves rather than enter that particular rat's nest.

Last edited by DiapDealer; 08-29-2014 at 09:25 AM.
DiapDealer is online now   Reply With Quote
Advert
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Listing of QT5 versions of Plugins PeterT Plugins 20 07-23-2014 11:22 PM
calibre plugins whizbo Calibre 3 09-20-2013 04:08 PM
QT5 and image height Turtle91 Sigil 23 02-21-2013 01:44 PM
Calibre Portable like the Calibre on PC (espec. settings and plugins)? manawydan Devices 6 01-23-2013 06:45 AM
Calibre as a service in a linux server without QT4 nadid Calibre 4 01-25-2011 12:00 AM


All times are GMT -4. The time now is 09:26 AM.


MobileRead.com is a privately owned, operated and funded community.