Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Sony Reader > Sony Reader Dev Corner

Notices

Reply
 
Thread Tools Search this Thread
Old 12-14-2016, 12:51 PM   #1
Terhi
Junior Member
Terhi began at the beginning.
 
Terhi's Avatar
 
Posts: 4
Karma: 10
Join Date: Nov 2011
Location: Finland
Device: PRS T-1
Recovery mode & win10? (resolved)

Hi,

my ol'sony reader has badsectors which causes unresponsive dictionary, hang after battery charge, hang after reading too many pages, hang after you name it...

To fix this with the help of wiki, I tried to get to recovery mode with unrooted device, however it just didn't. So I rooted it which went fine.

No, when I try to enter security mode (by using ebook_msc.exe), opening book stops 100%, and then just nothing happens. What I think should happen is that windows installs a driver (or I should manually update "Gadget Serial 2.4" -driver). Yellow led is blinking now and then...so maybe it's trying to do something?

There is no recognized or unrecognized devices and COM10 is not active (or any other serialport).

I have allowed my windows 10 to accept non-digital signed drivers to be installed if I need to manually install the driver.

Maybe windows 10 is not responsing properly? Or something else I'm not doing right?

EDIT: I had 32-bit pc with windows 10. It recognizes the device, however provided gadget serial driver doesn't work. Device don't start and putty of course don't connect. I tried alternative usb to serial drivers, but none worked...

EDIT2: I dug out old dusty win 7 home laptop, and yes was able to connect the device with putty BUT the instruction said to mount /dev/mmcblk0p1 and I get file not found. And I checked that, yes, dev-folder doesn't have mmcblk0p1 at all...

UPDATE & SOLUTION! Seems that windows10 comes with a ELMO GMAS-driver which connects the device. I just thougth to try and connected with Putty to COM3 (ELMO GMAS port), and voilá, I was in my device. I didn't need to install Gagdet drivers or anything. So it's even more easer with win10. I found a 500MB microSD from an old mobile phone and fixed all partitions via sd card (READER-partition (mmcblk2p8), Dictionary partition(mmcblk2p6) and mmcblk2p9 & mmcblk2p10 partitions). Reader- and dictionary-partitions had badblocks, so no need to wonder why ebooks jammed once in a while.

Last edited by Terhi; 12-17-2016 at 03:49 PM.
Terhi is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Calibre get & conversion disabled in Win10 & Mac El Capitan sandysot Devices 8 01-24-2016 04:52 AM
C65ML BootLoop looking for recovery mode murciano2 Onyx Boox 6 11-12-2014 01:07 PM
PRS-T2 can't access recovery mode Byske Sony Reader Dev Corner 2 01-08-2013 06:02 PM
Request Safe mode or recovery mode for Pocket Edge? felixblackcat enTourage eDGe 25 01-08-2012 06:07 PM
Kindle Touch: Anyway to go to Recovery Mode??? JRyn Kindle Developer's Corner 4 12-17-2011 02:11 PM


All times are GMT -4. The time now is 11:15 AM.


MobileRead.com is a privately owned, operated and funded community.