Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 06-15-2017, 12:04 PM   #1
Ackis
Member
Ackis began at the beginning.
 
Posts: 21
Karma: 10
Join Date: Sep 2013
Location: Canada
Device: Galaxy Tab 2 10.1, iPad 2
Calibre not auto-starting on Ubuntu 16.04

Hello everyone - having a weird issue.

Whenever my server reboots, Calibre doesn't automatically start. I'm not sure why.

Here's the error when checking its service status:

Code:
>sudo service calibre status
● calibre.service - Calibre eBook Server
   Loaded: loaded (/lib/systemd/system/calibre.service; enabled; vendor preset: enabled)
   Active: failed (Result: timeout) since Wed 2017-06-14 04:05:28 MDT; 1 day 5h ago
  Process: 1764 ExecStart=/usr/bin/calibre-server --daemonize --max-cover=600x800 --max-opds-items=100 --max-opds-ungrouped-items=100 --url-prefix /calibre --pidfile=/var/run/calibre/calibre

Jun 14 04:03:58 ubuntu systemd[1]: Starting Calibre eBook Server...
Jun 14 04:05:28 ubuntu systemd[1]: calibre.service: Start operation timed out. Terminating.
Jun 14 04:05:28 ubuntu systemd[1]: Failed to start Calibre eBook Server.
Jun 14 04:05:28 ubuntu systemd[1]: calibre.service: Unit entered failed state.
Jun 14 04:05:28 ubuntu systemd[1]: calibre.service: Failed with result 'timeout'.
When I manually turn it on, it works (except for the PID issue):

Code:
>sudo service calibre start
>sudo service calibre status
● calibre.service - Calibre eBook Server
   Loaded: loaded (/lib/systemd/system/calibre.service; enabled; vendor preset: enabled)
   Active: active (running) since Thu 2017-06-15 09:59:12 MDT; 1s ago
  Process: 4923 ExecStart=/usr/bin/calibre-server --daemonize --max-cover=600x800 --max-opds-items=100 --max-opds-ungrouped-items=100 --url-prefix /calibre --pidfile=/var/run/calibre/calibre
 Main PID: 4932 (calibre-server)
   CGroup: /system.slice/calibre.service
           └─4932 /opt/calibre/bin/calibre-server --daemonize --max-cover=600x800 --max-opds-items=100 --max-opds-ungrouped-items=100 --url-prefix /calibre --pidfile=/var/run/calibre/calibre

Jun 15 09:59:08 ubuntu systemd[1]: Starting Calibre eBook Server...
Jun 15 09:59:10 ubuntu systemd[1]: calibre.service: PID file /var/run/calibre/calibre-server.pid not readable (yet?) after start: No such file or directory
Jun 15 09:59:12 ubuntu systemd[1]: Started Calibre eBook Server.
This is the configuration that I'm using to start the server:

Code:
[Unit]
Description=Calibre eBook Server
After=syslog.target network.target

[Service]
Type=forking
User=calibre
Group=calibre
PIDFile=/var/run/calibre/calibre-server.pid
ExecStart=/usr/bin/calibre-server \
        --daemonize \
        --max-cover=600x800 \
        --max-opds-items=100 \
        --max-opds-ungrouped-items=100 \
        --url-prefix /calibre \
        --pidfile=/var/run/calibre/calibre-server.pid \
        --username=calibre \
        --port=8080 \
        --with-library=/media/eBooks/

[Install]
WantedBy=multi-user.target
Ackis is offline   Reply With Quote
Advert
Old 08-03-2017, 06:46 AM   #2
mrbriggs
Junior Member
mrbriggs is on a distinguished road
 
Posts: 1
Karma: 56
Join Date: Nov 2010
Device: none
I recently had the same error after upgrading calibre.

It appears that the options for calibre-server have changed. I updated my service file to the following and everything seems to work fine now:

Code:
[Unit]
Description=Calibre (ebook manager) content server service
After=network.target

[Service]
Type=forking
PIDFile=/var/run/calibre-server.pid
ExecStart=/usr/bin/calibre-server \
        --daemonize \
        --log=/home/<USERNAME>/calibre.log \
        --max-opds-items=30 \
        --max-opds-ungrouped-items=100 \
        --port=8080 \
        --pidfile=/var/run/calibre-server.pid \
        /<LIBRARY PATH>/
[Install]
WantedBy=multi-user.target

Replace <USERNAME> with your username (I.e. joe)
Replace <LIBRARY PATH> with the path to your library (I.e. media/eBooks )
Note: I left the leading and trailing "/" in the code above so make sure you do not end up with //media/eBooks//, the line should read /media/eBooks/ for your example.

You will need to create a log file called calibre.log or you will get an error:
Code:
touch /home/<USERNAME>/calibre.log
You will need to reload your systemctrl daemons to get the updated file to work
Code:
systemctl daemon-reload
Then start your system service normally.

I hope this helps.

Last edited by mrbriggs; 08-03-2017 at 06:51 AM.
mrbriggs is offline   Reply With Quote
Old 08-04-2017, 02:42 PM   #3
Ackis
Member
Ackis began at the beginning.
 
Posts: 21
Karma: 10
Join Date: Sep 2013
Location: Canada
Device: Galaxy Tab 2 10.1, iPad 2
Thanks - I hadn't upgraded Calibre in a while. Just upgraded it, and thanks for your advice/tips with the parameters changing.

Looks like there's a few more to play with as well.

I'm still not sure if it'll auto-start when I reboot, but we'll see soon enough.
Ackis is offline   Reply With Quote
Reply

Tags
linux, systemd, ubuntu

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
:help: Auto Numbering With Starting Number Inserted? yonkyunior Editor 2 02-25-2016 01:17 AM
Ubuntu Calibre only auto adds on program startup LoRdAc][d Calibre 12 06-08-2014 10:03 AM
Calibre not starting on debian saturnblackhole Calibre 3 12-11-2011 12:05 AM
How to stop eBookLibrary from auto-starting? Kypt Sony Reader 11 10-31-2009 09:03 PM
Starting off without calibre dhylton Calibre 3 05-05-2009 11:24 AM


All times are GMT -4. The time now is 03:30 PM.


MobileRead.com is a privately owned, operated and funded community.