Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 10-07-2019, 04:13 PM   #1
Dan__
Enthusiast
Dan__ began at the beginning.
 
Posts: 46
Karma: 10
Join Date: Feb 2011
Device: Nook - Simple Touch
Version 4 on Mac High Sierra

Hello,
When I open the v4 dmg on high sierra, the app icon is overlaid with a "No Entry" symbol [circle + diagonal slash]. I assume that means that v4 is not compatible with high sierra. Is that assumption correct? It is not mentioned in the Backward Incompatibilities section.

Thank you
Dan__ is offline   Reply With Quote
Old 10-07-2019, 04:19 PM   #2
DNSB
Bibliophagist
DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.
 
DNSB's Avatar
 
Posts: 6,296
Karma: 27305947
Join Date: Jul 2010
Location: Vancouver
Device: Kobo Aura One, Aura H2O, Aura HD, Nexus 7 HD, iPad Air, Tolino epos
Quote:
Originally Posted by Dan__ View Post
Hello,
When I open the v4 dmg on high sierra, the app icon is overlaid with a "No Entry" symbol [circle + diagonal slash]. I assume that means that v4 is not compatible with high sierra. Is that assumption correct? It is not mentioned in the Backward Incompatibilities section.

Thank you
Mojave or higher only need apply. Hmm... given the new hoops for Catalina, make that Mojave for now.
DNSB is offline   Reply With Quote
Advert
Old 10-07-2019, 04:58 PM   #3
odamizu
just an egg
odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.
 
odamizu's Avatar
 
Posts: 1,019
Karma: 1831590
Join Date: Mar 2015
Device: Kindle Oasis1 & Voyage, iOS
The macOS download page does say, "calibre works on macOS 10.14 (Mojave) and higher". This is right at the top underneath the "Download for macOS" header. Plus note #3 at the bottom reads: "If you are using macOS older than 10.14 (Mojave), the last version of calibre that will work on your machine is 3.48, available here."

As for Catalina, Kovid has reported that he succeeded in notarizing Calibre 4, so it should work, theoretically.
odamizu is offline   Reply With Quote
Old 10-07-2019, 06:44 PM   #4
Dan__
Enthusiast
Dan__ began at the beginning.
 
Posts: 46
Karma: 10
Join Date: Feb 2011
Device: Nook - Simple Touch
Thanks

Quote:
Originally Posted by odamizu View Post
The macOS download page does say, "calibre works on macOS 10.14 (Mojave) and higher". This is right at the top underneath the "Download for macOS" header. Plus note #3 at the bottom reads: "If you are using macOS older than 10.14 (Mojave), the last version of calibre that will work on your machine is 3.48, available here."

As for Catalina, Kovid has reported that he succeeded in notarizing Calibre 4, so it should work, theoretically.
I’ve got 195 32-bit components. I doubt that I will ever be able to upgrade.
Dan__ is offline   Reply With Quote
Old 10-07-2019, 06:46 PM   #5
JSWolf
Resident Curmudgeon
JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.
 
JSWolf's Avatar
 
Posts: 53,522
Karma: 49384553
Join Date: Nov 2006
Location: Roslindale, Massachusetts
Device: Kobo Aura H2O, Sony PRS-650, Sony PRS-T1, nook STR, iPad 4, iPhone 5
You could try running from source and see if that works.
JSWolf is offline   Reply With Quote
Advert
Old 10-07-2019, 07:04 PM   #6
odamizu
just an egg
odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.
 
odamizu's Avatar
 
Posts: 1,019
Karma: 1831590
Join Date: Mar 2015
Device: Kindle Oasis1 & Voyage, iOS
Quote:
Originally Posted by Dan__ View Post
I’ve got 195 32-bit components. I doubt that I will ever be able to upgrade.
I'm still on High Sierra as well. Fortunately Calibre 3.48 is fine for me.

Catalina creates such a quandary.

Quote:
Originally Posted by JSWolf View Post
You could try running from source and see if that works.
What does that mean? "running from source"?
odamizu is offline   Reply With Quote
Old 10-09-2019, 01:27 PM   #7
TheDreamer
Member
TheDreamer began at the beginning.
 
TheDreamer's Avatar
 
Posts: 11
Karma: 10
Join Date: Jun 2017
Device: Kobo Aura One, Onyx Boox Max Carta, various Kindles start from 2
Yeah, I wish Calibre 4 had been 10.13 or newer rather than 10.14 or newer....since I'm running a mid-2011 iMac (was last 21.5" that could do 32GB of RAM, until retina...which might be a while before I can afford an upgrade.)

Though I have also been looking at trying the patcher to get it up to 10.14....though not sure if 10.15 will ever make it into my systems....since I'm hanging onto a pre-KFX Kindle Reader, which is a 32-bit app...

The Dreamer.
TheDreamer is offline   Reply With Quote
Old 10-09-2019, 10:34 PM   #8
eschwartz
Ex-Helpdesk Junkie
eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.
 
eschwartz's Avatar
 
Posts: 19,324
Karma: 83238367
Join Date: Nov 2012
Location: The Beaten Path, USA, Roundworld, This Side of Infinity
Device: Kindle Touch fw5.3.7 (Wifi only)
Quote:
Originally Posted by odamizu View Post
What does that mean? "running from source"?
It doesn't mean anything. It's a buzzword unrelated to reality. It's something being said by someone who doesn't actually know what they're talking about.

If you have a copy of Calibre already installed, containing the binary components that don't work on older versions of macOS, you can check out the calibre source code and modify the pure python components, or run against newer versions of the pure python components.

This does not, not has it ever, allowed you to run Qt5 itself from source. (As in, the thing-that-doesnt-work-on-older-macOS-releases-Qt5. Yeah, that.)

...

In theory, it may be possibly to compile all of Calibre from the ground up, using a full blown development environment, targeting the version of macOS you need. There's a thread in the development subforum about this -- it's been suggested that you *might* be in luck if you need 10.12 support, but 10.11 is simply utterly hopeless as Qt>=5.12.x won't compile under any circumstances.

If that's okay with you and you find yourself excited by the idea of *experimenting* with compiling calibre from source, then by all means don't let me dampen your enthusiasm and feel free to hop right by the development subforum to ask questions.

(I'm pretty sure I remember you saying you're not that sort of person though...)
eschwartz is offline   Reply With Quote
Old 10-10-2019, 01:32 AM   #9
odamizu
just an egg
odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.
 
odamizu's Avatar
 
Posts: 1,019
Karma: 1831590
Join Date: Mar 2015
Device: Kindle Oasis1 & Voyage, iOS
Thank you eschwartz! And good to see you on MR You are correct that all this is beyond my knowledge base and skill set. I wish my brain were wired for this as it interests me so!

Fortunately 3.48 is fine for me, so this is not a big deal. I do plan to install Catalina on an external boot drive soon and will play with Calibre 4 then.
odamizu is offline   Reply With Quote
Old 10-10-2019, 04:43 AM   #10
JSWolf
Resident Curmudgeon
JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.
 
JSWolf's Avatar
 
Posts: 53,522
Karma: 49384553
Join Date: Nov 2006
Location: Roslindale, Massachusetts
Device: Kobo Aura H2O, Sony PRS-650, Sony PRS-T1, nook STR, iPad 4, iPhone 5
YOu might be able to install Catalina on your Mac that doesn't allow it.

http://dosdude1.com/catalina/
JSWolf is offline   Reply With Quote
Old 10-10-2019, 02:07 PM   #11
odamizu
just an egg
odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.odamizu ought to be getting tired of karma fortunes by now.
 
odamizu's Avatar
 
Posts: 1,019
Karma: 1831590
Join Date: Mar 2015
Device: Kindle Oasis1 & Voyage, iOS
Quote:
Originally Posted by JSWolf View Post
YOu might be able to install Catalina on your Mac that doesn't allow it.

http://dosdude1.com/catalina/
This is interesting. Have you tried it?

I also have to wonder who "dosdude1" is and whether their software, which by nature would seem to be incredibly invasive, is safe to use.
odamizu is offline   Reply With Quote
Old 10-10-2019, 02:16 PM   #12
JSWolf
Resident Curmudgeon
JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.
 
JSWolf's Avatar
 
Posts: 53,522
Karma: 49384553
Join Date: Nov 2006
Location: Roslindale, Massachusetts
Device: Kobo Aura H2O, Sony PRS-650, Sony PRS-T1, nook STR, iPad 4, iPhone 5
Quote:
Originally Posted by odamizu View Post
This is interesting. Have you tried it?

I also have to wonder who "dosdude1" is and whether their software, which by nature would seem to be incredibly invasive, is safe to use.
dosdue1 did it for other versions of OS X. I got the name from one of the known tech blogs. So I'd trust it.

Besides, I'm on Windows. I'm posting this for those that are not able to install Catalina who might be able to with this program and a new video card.
JSWolf is offline   Reply With Quote
Old 10-11-2019, 10:58 AM   #13
TheDreamer
Member
TheDreamer began at the beginning.
 
TheDreamer's Avatar
 
Posts: 11
Karma: 10
Join Date: Jun 2017
Device: Kobo Aura One, Onyx Boox Max Carta, various Kindles start from 2
I briefly looked at running from source, and found the xcode project was a for a newer version than I have....not sure what it would take to downgrade the project...

The alternative might be to see if 3.48's calibre-debug will run the latest python code, probably depends on whether the latest can still be run with python 2.7...though thought there were framework changes as well.

I'm sure dosdude1 will come out with a patch to get Catalina onto an unsupported Mac. I saw that there had been patches to get 10.7 or newer to install onto 32-bit hardware...which I might have tried, if I had known about it. Since until a last year, I still had a first generation MacBook Pro (core duo). I was in the process of trying to find a new hard drive for it (had already gotten a new battery), and reinstall with final 10.6 (re-purchased from ebay) When, I had the darn thing stolen

Not sure if a new MacBook Pro/Air/X is in my future.....might attempt another hack instead.

But, given no support for 32-bit apps in Catalina, it might be a long time before I make that leap. First I need to work up the courage to crack my iMac and attempt a video card upgrade....and, it takes a lot since I have Cerebellar Ataxia...

The Dreamer
TheDreamer is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Support for High Sierra? jeffwalker Calibre 13 10-12-2019 12:20 AM
running Catalina and High Sierra on same Mac odamizu Apple Devices 34 07-31-2019 03:03 PM
Can i build calibre on OS X High Sierra 10.13 on a Mac ? exAppl088 Development 1 05-28-2019 11:02 PM
Mac High Sierra : background process at boot reinsley Calibre 2 02-05-2018 11:31 AM
Problems adding .epub to calibre Mac OS High Sierra cateroseg Devices 1 12-21-2017 12:16 AM


All times are GMT -4. The time now is 02:04 AM.


MobileRead.com is a privately owned, operated and funded community.