Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Plugins

Notices

Reply
 
Thread Tools Search this Thread
Old 03-02-2024, 10:06 AM   #106
sgmoore
Enthusiast
sgmoore reads XML... blindfoldedsgmoore reads XML... blindfoldedsgmoore reads XML... blindfoldedsgmoore reads XML... blindfoldedsgmoore reads XML... blindfoldedsgmoore reads XML... blindfoldedsgmoore reads XML... blindfoldedsgmoore reads XML... blindfoldedsgmoore reads XML... blindfoldedsgmoore reads XML... blindfoldedsgmoore reads XML... blindfolded
 
Posts: 42
Karma: 52636
Join Date: Mar 2021
Device: Kindle Voyage
Quote:
Originally Posted by KindleAZWorKFX View Post

ValueError:time data '2-19-12-03T00:00:00'*does not match known formats ('%Y-%m-%dT%H:%M:%SZ', '%Y-%m-%dT%H:%M:%S.%fZ', '%Y-%m-%dT%H:%M:%S%z', '%Y-%m-%dT%H:%M:%S.%f%z', '%m/%d/%Y')
Take a look at https://github.com/ping/libby-calibre-plugin/pull/17 and see if it helps

Last edited by sgmoore; 03-02-2024 at 10:44 AM.
sgmoore is offline   Reply With Quote
Old 03-02-2024, 05:26 PM   #107
KindleAZWorKFX
Connoisseur
KindleAZWorKFX knows what time it isKindleAZWorKFX knows what time it isKindleAZWorKFX knows what time it isKindleAZWorKFX knows what time it isKindleAZWorKFX knows what time it isKindleAZWorKFX knows what time it isKindleAZWorKFX knows what time it isKindleAZWorKFX knows what time it isKindleAZWorKFX knows what time it isKindleAZWorKFX knows what time it isKindleAZWorKFX knows what time it is
 
KindleAZWorKFX's Avatar
 
Posts: 57
Karma: 2378
Join Date: Jul 2018
Location: CA, USA.
Device: Kindle Paperwhite Signature Edition and Samsung 10.1 tablet
Question

Quote:
Originally Posted by sgmoore View Post
Take a look at https://github.com/ping/libby-calibre-plugin/pull/17 and see if it helps
https://github.com/ping/libby-calibre-plugin/pull/17

I took a look at this page, it sounds like importing the downloaded zip file plugin without unzipping it might be the cause from the comments, but since I didn't directly download this from the calibre forums, I am not sure that applies since I used the get plugin download feature within calibre itself, and I didn't directly download most of them from this forum, I normally install most of the plugins directly from calibre's plugin download system.

Quote:
spicefather commented last month

Seems like you might be using the repo zip directly, you do need to unzip that and re-zip it as noted in my comment above. Once unzipped, go into the calibre-plugin folder, select everything, and create zip (7-zip or Windows' "Send to > Compressed folder" should both be fine).
this comment is the one I am referring to, since I don't need to uncompress or do a 7-zip thing with the plugin, I should not have to unzip the one that was downloaded with Calibre's plugin download system I think, it a bit confused me. but it almost sounds like a different problem.

my error does not have this in it below, from that page link.

Quote:
calibre.customize.InvalidPlugin: The plugin in 'D:\\Documents\\libby-calibre-plugin-main.zip' is invalid. It does not contain a top-level __init__.py file
this page some what matches to the main code on that page,

Quote:
Traceback (most recent call last):
File "calibre_plugins.overdrive_libby.models", line 1077, in data
File "calibre_plugins.overdrive_libby.libby.client" , line 337, in parse_datetime
ValueError: time data '2019-12-03T00:00:00' does not match known formats ('%Y-%m-%dT%H:%M:%SZ', '%Y-%m-%dT%H:%M:%S.%fZ', '%Y-%m-%dT%H:%M:%S%z', '%Y-%m-%dT%H:%M:%S.%f%z', '%m/%d/%Y')
but that page has a few lines in the traceback that mine did not have if that matters, below in bold is the only matching traceback line, the rest of them I didn't get in my error.

Quote:
File "calibre\gui2\threaded_jobs.py", line 82, in start_work
File "calibre_plugins.overdrive_libby.ebook_downloa d", line 59, in __call__
File "calibre_plugins.overdrive_libby.download", line 253, in add
File "calibre_plugins.overdrive_libby.download", line 97, in update_metadata
File "calibre_plugins.overdrive_libby.libby.client" , line 337, in parse_datetime

Last edited by KindleAZWorKFX; 03-02-2024 at 05:31 PM. Reason: added more detail.
KindleAZWorKFX is offline   Reply With Quote
Old 03-02-2024, 06:55 PM   #108
sgmoore
Enthusiast
sgmoore reads XML... blindfoldedsgmoore reads XML... blindfoldedsgmoore reads XML... blindfoldedsgmoore reads XML... blindfoldedsgmoore reads XML... blindfoldedsgmoore reads XML... blindfoldedsgmoore reads XML... blindfoldedsgmoore reads XML... blindfoldedsgmoore reads XML... blindfoldedsgmoore reads XML... blindfoldedsgmoore reads XML... blindfolded
 
Posts: 42
Karma: 52636
Join Date: Mar 2021
Device: Kindle Voyage
Quote:
Originally Posted by KindleAZWorKFX View Post
https://github.com/ping/libby-calibre-plugin/pull/17

I took a look at this page, it sounds like importing the downloaded zip file plugin without unzipping it might be the cause from the comments, but since I didn't directly download this from the calibre forums , I am not sure that applies

.
Sorry, I shouldn't have just pointed you to this page without explaining what it was.

The page is (I hope) instructions on how to fix your problem.

So downloading the zip and unzipping is not causing your problem but instead is (hopefully) the solution to your problem.

Basically what I think happened is this.

p1nkyy had a problem with an error message that sound very similar to yours and reported it at https://github.com/ping/libby-calibre-plugin/issues/20

spicefather fixed the issue and also sent the details of the fix to ping who wrote the plugin and maintains/publishes it.

Unfortunately ping is busy and does not have time to deal with this. So the official plugin still does not contain the fix.

p1nkyy then asked spicefather how he fixed the issue.

He/she was given instructions, but didn't follow them completely. He/she must have downloaded the zip from https://github.com/spicefather/libby...heads/main.zip , but missed the bit where he needed to extract the files and then re-zip just the files in the calibre-plugin folder.

This is when he/she got the InvalidPlugin error

spicefather then clarifies what needs to be done to fix the issue.

p1knkky then follows the instructions correctly and it sorted their problem.

So I was hoping if you followed the same instructions, then it might sort yours.

Does that make sense now?
sgmoore is offline   Reply With Quote
Old 03-04-2024, 09:04 AM   #109
miss_p1nky
Enthusiast
miss_p1nky will become famous soon enoughmiss_p1nky will become famous soon enoughmiss_p1nky will become famous soon enoughmiss_p1nky will become famous soon enoughmiss_p1nky will become famous soon enoughmiss_p1nky will become famous soon enough
 
Posts: 42
Karma: 636
Join Date: Aug 2022
Location: Indonesia
Device: Moon+ Reader Pro
@sgmoore is correct, I had troubles applying the forked plugin but finally made it work and it got rid of the problem of the unmatched date.
miss_p1nky is offline   Reply With Quote
Old 03-09-2024, 06:12 PM   #110
KindleAZWorKFX
Connoisseur
KindleAZWorKFX knows what time it isKindleAZWorKFX knows what time it isKindleAZWorKFX knows what time it isKindleAZWorKFX knows what time it isKindleAZWorKFX knows what time it isKindleAZWorKFX knows what time it isKindleAZWorKFX knows what time it isKindleAZWorKFX knows what time it isKindleAZWorKFX knows what time it isKindleAZWorKFX knows what time it isKindleAZWorKFX knows what time it is
 
KindleAZWorKFX's Avatar
 
Posts: 57
Karma: 2378
Join Date: Jul 2018
Location: CA, USA.
Device: Kindle Paperwhite Signature Edition and Samsung 10.1 tablet
@sgmoore is correct, I also was able to fix it, I tried and worked it out, I had to import the new files into a zipped folder, then from calibre import it, I was unable to just edit and rezip it under the folder in calibre's plugins, I had to use the interface and import a modified zip file with the data files from github, but that worked for me. it didn't like me just reziping the files in the source folder for calibre's plugins, again I was able to get it updated and no more time error so far. thanks for the help when I had just reziped the files from github, without using the import zip feature of calibre, it just didn't load the plugin at all with just that method, but when I added the files and imported it with

load plugin from file option in calibre, that worked once I took the files from github for overdrive libby and made a zip of those files, that's how I was able to fix it.
KindleAZWorKFX is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[GUI Plugin] Overdrive Link jhowell Plugins 1261 01-15-2024 08:31 AM
No Local Public Library. Overdrive/Libby Possible? enuddleyarbl Kobo Reader 2 06-08-2023 07:23 PM
Library borrowing: Overdrive vs. Libby haertig General Discussions 83 01-30-2023 04:21 PM
Libby, the new Overdrive App Cosimo News 30 12-02-2017 09:42 AM
Overdrive's Libby Loves2Read4Fun General Discussions 2 12-20-2016 01:32 PM


All times are GMT -4. The time now is 03:21 PM.


MobileRead.com is a privately owned, operated and funded community.