Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Amazon Kindle > Kindle Developer's Corner

Notices

Reply
 
Thread Tools Search this Thread
Old 12-08-2018, 11:38 AM   #1
hanalee
Member
hanalee began at the beginning.
 
Posts: 11
Karma: 12
Join Date: Jul 2018
Device: kindle pw3
Kindle 4 serial port problem

I have two problems.

One is that the Kindle 4 will not boot.
The screen is frozen and the computer is disconnected.
I have a serial port connection and this is the log file.
What is the problem?

Spoiler:

U-Boot 2009.08-lab126 (Sep 02 2011 - 22:45:17)

CPU: Freescale i.MX50 family 1.1V at 800 MHz
mx50 pll1: 800MHz
mx50 pll2: 400MHz
mx50 pll3: 216MHz
ipg clock : 50000000Hz
ipg per clock : 50000000Hz
uart clock : 24000000Hz
ahb clock : 100000000Hz
axi_a clock : 400000000Hz
axi_b clock : 200000000Hz
weim_clock : 100000000Hz
ddr clock : 800000000Hz
esdhc1 clock : 80000000Hz
esdhc2 clock : 80000000Hz
esdhc3 clock : 80000000Hz
esdhc4 clock : 80000000Hz
MMC: FSL_ESDHC: 0, FSL_ESDHC: 1
Board: Tequila
Boot Reason: [POR]
Boot Device: MMC
Board Id: 0031501114020QCD
S/N: B00E150114023JTL
Initing MDDR memory
ZQ calibration complete: 0x128=0x04080010 0x12C=0x00000307
DRAM: 256 MB
Using default environment

In: serial
Out: logbuff
Err: logbuff
Quick Memory Test 0x70000000, 0x10000000
POST done in 14 ms
Hit any key to stop autoboot: 0
## Booting kernel from Legacy Image at 70800000 ...

Image Name: Linux-2.6.31-rt11-lab126
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 4761152 Bytes = 4.5 MB
Load Address: 70008000
Entry Point: 70008000
Verifying Checksum ... OK
Loading Kernel Image ... OK
OK
Starting kernel ...
Linux version 2.6.31-rt11-lab126 (jenkins-official@lucid-build02) (gcc version 4.5.3 20110406 (prerelease) (Linaro GCC 4.5-2011.04-0) ) #5 Sat Jan 12 20:39:09 PST 2013
CPU: ARMv7 Processor [412fc085] revision 5 (ARMv7), cr=10c53c7f
CPU: VIPT nonaliasing data cache, VIPT nonaliasing instruction cache
Machine: Amazon.com MX50 YOSHI Board
Board ID and Serial Number driver for Lab126 boards version 1.0
MX50 Board id - 0031501114020QCD
Memory policy: ECC disabled, Data cache writeback
On node 0 totalpages: 65536
free_area_init_node: node 0, pgdat c0491c3c, node_mem_map c04bd000
DMA zone: 192 pages used for memmap
DMA zone: 0 pages reserved
DMA zone: 24384 pages, LIFO batch:3
Normal zone: 320 pages used for memmap
Normal zone: 40640 pages, LIFO batch:7
Built 1 zonelists in Zone order, mobility grouping on. Total pages: 65024
Kernel command line: consoleblank=0 rootwait ro ip=off root=/dev/mmcblk0p1 debug eink=fslepdc video=mxcepdcfb:E60,bpp=8 console=ttymxc0,115200
PID hash table entries: 1024 (order: 10, 4096 bytes)
Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
Memory: 256MB = 256MB total
Memory: 254860KB available (3380K code, 363K data, 1068K init, 0K highmem)
NR_IRQS:368
MXC IRQ initialized
cko2_set_rate, new divider=5
MXC_Early serial console at MMIO 0x53fbc000 (options '115200')
console [ttymxc0] enabled
Console: colour dummy device 80x30
Calibrating delay loop... 799.53 BogoMIPS (lpj=3997696)
Mount-cache hash table entries: 512
CPU: Testing write buffer coherency: ok
regulator: core version 0.5
NET: Registered protocol family 16
i.MX IRAM pool: 128 KB@0xd0840000
CPU is i.MX50 Revision 1.1
MXC GPIO hardware
Using SDMA I.API
MXC DMA API initialized
bio: create slab <bio-0> at 0
mxc_spi mxc_spi.0: can't setup spi1.0, status -22
CSPI: mxc_spi-0 probed
mxc_spi mxc_spi.1: chipselect 0 already in use
mxc_spi mxc_spi.1: chipselect 0 already in use
CSPI: mxc_spi-1 probed
mxc_spi mxc_spi.2: chipselect 0 already in use
CSPI: mxc_spi-2 probed
MXC I2C driver
MXC I2C driver
PMIC Light driver loading...
mc13892 Rev 2.1 FinVer 2 detected
Initializing regulators for mx50 yoshi.
regulator: SW1: 600 <--> 1375 mV
regulator: SW2: 900 <--> 1850 mV
regulator: SW3: 900 <--> 1850 mV
regulator: SW4: 1100 <--> 1850 mV
regulator: SWBST: 0 mV
regulator: VIOHI: 0 mV
regulator: VPLL: 1050 <--> 1800 mV
regulator: VDIG: 1200 mV
regulator: VSD: 1800 <--> 3150 mV
regulator: VUSB2: 2400 <--> 2775 mV
regulator: VVIDEO: 2775 mV
regulator: VAUDIO: 2300 <--> 3000 mV
regulator: VCAM: 2500 <--> 3000 mV fast normal
regulator: VGEN1: 3000 mV
regulator: VGEN2: 1200 <--> 3150 mV
regulator: VGEN3: 1800 mV
regulator: VUSB: 0 mV
regulator: GPO1: 0 mV
regulator: GPO2: 0 mV
regulator: GPO3: 0 mV
regulator: GPO4: 0 mV
PMIC ADC start probe
PMIC Light successfully loaded
Device spi3.0 probed
NET: Registered protocol family 2
IP route cache hash table entries: 2048 (order: 1, 8192 bytes)
TCP established hash table entries: 8192 (order: 4, 65536 bytes)
TCP bind hash table entries: 8192 (order: 3, 32768 bytes)
TCP: Hash tables configured (established 8192 bind 8192)
TCP reno registered
NET: Registered protocol family 1
LPMode driver module loaded
Static Power Management for Freescale i.MX5
PM driver module loaded
sdram autogating driver module loaded
Bus freq driver module loaded
Initializing MX50 Yoshi Accessory Port
mxc_dvfs_core_probe
DVFS driver module loaded
i.MXC CPU frequency driver
msgmni has been set to 498
alg: No test for stdrng (krng)
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
i2c-adapter i2c-1: E mxc_i2c_handler:def::Bus Arbitration lost
i2c-adapter i2c-1: E mxc_i2c_xfer:start:return=-EBUSY:Could not grab Bus ownership
Papyrus: Enable failed. Retrying : 1
i2c-adapter i2c-1: E mxc_i2c_handler:def::Bus Arbitration lost
i2c-adapter i2c-1: E mxc_i2c_xfer:start:return=-EBUSY:Could not grab Bus ownership
Papyrus: Enable failed. Retrying : 0
Papyrus: I2C Send ENABLE failed! : -121
Retrying Papyrus enable
i2c-adapter i2c-1: E mxc_i2c_handler:def::Bus Arbitration lost
i2c-adapter i2c-1: E mxc_i2c_xfer:start:return=-EBUSY:Could not grab Bus ownership
Papyrus: Enable failed. Retrying : 1
i2c-adapter i2c-1: E mxc_i2c_handler:def::Bus Arbitration lost
i2c-adapter i2c-1: E mxc_i2c_xfer:start:return=-EBUSY:Could not grab Bus ownership
Papyrus: Enable failed. Retrying : 0
Papyrus: I2C Send ENABLE failed! : -121
Retrying Papyrus enable
papyrus: probe of 1-0048 failed with error -1
Amazon MX35 Yoshi Power Button Driver
Serial: MXC Internal UART driver
mxcintuart.0: ttymxc0 at MMIO 0x53fbc000 (irq = 31) is a Freescale MXC
console handover: boot [ttymxc0] -> real [ttymxc0]
loop: module loaded
mxc_rtc mxc_rtc.0: rtc core: registered mxc_rtc as rtc0
Probing mxc_rtc done
mc13892 rtc probe start
pmic_rtc pmic_rtc.1: rtc core: registered pmic_rtc as rtc1
mc13892 rtc probe succeed
i2c /dev entries driver
i2c-adapter i2c-1: E mxc_i2c_handler:def::Bus Arbitration lost
i2c-adapter i2c-1: E mxc_i2c_xfer:start:return=-EBUSY:Could not grab Bus ownership
yoshi_battery: i2c read retry
yoshi_battery: E battery:not detected:
MXC WatchDog Driver 2.0
MXC Watchdog # 0 Timer: initial timeout 127 sec
MXC Watchdog: Started 10000 millisecond watchdog refresh
PMIC Character device: successfully loaded
pmic_battery: probe of pmic_battery.1 failed with error -1
sdhci: Secure Digital Host Controller Interface driver
sdhci: Copyright(c) Pierre Ossman
mxsdhci: MXC Secure Digital Host Controller Interface driver
mxsdhci: MXC SDHCI Controller Driver.
mmc0: SDHCI detect irq 273 irq 2 INTERNAL DMA
mxsdhci: MXC SDHCI Controller Driver.
mmc1: SDHCI detect irq 0 irq 3 INTERNAL DMA
Registered led device: pmic_ledsr
Registered led device: pmic_ledsg
Registered led device: pmic_ledsb
nf_conntrack version 0.5.0 (4096 buckets, 16384 max)
ip_tables: (C) 2000-2006 Netfilter Core Team
TCP cubic registered
NET: Registered protocol family 17
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
kernel: I perf:kernel:kernel_loaded=3.45 seconds:
VFP support v0.3: implementor 41 architecture 3 part 30 variant c rev 2
regulator_init_complete: disabling GPO4
regulator_init_complete: disabling GPO3
regulator_init_complete: disabling GPO2
regulator_init_complete: disabling GPO1
regulator_init_complete: disabling VGEN3
regulator_init_complete: disabling VGEN1
regulator_init_complete: disabling VCAM
regulator_init_complete: disabling VAUDIO
regulator_init_complete: disabling VVIDEO
regulator_init_complete: disabling VSD
regulator_init_complete: disabling SWBST
mxc_rtc mxc_rtc.0: setting system clock to 1970-01-01 00:37:22 UTC (2242)
Freeing init memory: 1068K
mmc0: queuing CIS tuple 0x01 length 3
mmc0: queuing CIS tuple 0x1a length 5
2.6.31-rt11-lab126 #5 Sat Jan 12 20:39:09 PST 2013 armv7l
mmc0: queuing CIS tuple 0x1b length 8
mmc0: queuing CIS tuple 0x14 length 0
mmc0: queuing CIS tuple 0x80 length 1
mmc0: queuing CIS tuple 0x81 length 1
mmc0: queuing CIS tuple 0x82 length 1
mmc0: new high speed SDIO card at address 0001
emmc: I def:mmcpartinfo:vendor=sandisk, ddr=1, host=mmc1:
mmc1: new high speed MMC card at address 0001
mmcblk0: mmc1:0001 SEM02G 1.82 GiB
mmcblk0: p1 p2 p3 p4
INFO:Loaded module /lib/modules/eink_fb_waveform.ko (36308 bytes)
INFO:Loaded module /lib/moduregulator: Unable to get requested regulator: DISPLAY
mxc_epdc_fb mxc_epdc_fb: Unable to get display PMIC regulator.err = 0xffffffed
les/eink_fb_hal.ko (71576 bytesregulator: Unable to get requested regulator: DISPLAY
regulator: Unable to get requested regulator: VCOM
regulator: Unable to get requested regulator: TMST
eink_fb: W fslepdc_pmic_init:def:FSL EPDC PMIC access not available
)
INFO:Loaded module /lib/moduleink_fb: I EINKFB_PROBE:def:fb0 using 1416K of RAM for framebuffer
es/mxc_epdc_fb.ko dont_register_fb=1 (43212 bytes)
INFO:Loaded module /lib/modules/eink_fb_hal_fslepdc.ko (21648 bytes)
INFO:Loaded module /lib/modules/eink_input: tequila-keypad as /devices/platform/tequila-keypad/input/input0
fb_shim.ko (119240 bytes)
INFO:eink initialized... (480000 bytes)
INFO:Using default keypad setting. (not passing "kb_rev" to module)
INFO:Loaded module /lib/modules/tequila_keypad.ko (11264 bytes)
Press [ENTER] for recovery menu... 0 /ERROR:gasgauge_battery_id_valid: No battery found
ERROR:
=== BATTERY ID IS INVALID. STOPPING BOOT ===
kernel: I perf:usb:usb_gadget_loaded=5.25 seconds:
INFO:Loaded module /lib/modules/arcotg_udc.ko (42460 bytes)
g_file_storage gadget: File-backed Storage Gadget, version: 7 August 2007
g_file_storage gadget: Number of LUNs=1
INFO:Loaded module /lib/modules/g_file_storage.ko recovery_mode=1 (36008 bytes)
--


Another problem is that keyboard input is not available on the serial port.
So I can not get into u-boot.
The current values are tx 3.26v, rx 1.97v.
Why does not keyboard input work?
Attached Files
File Type: txt k4_boot_log.txt (10.1 KB, 4 views)

Last edited by hanalee; 12-08-2018 at 11:49 AM.
hanalee is online now   Reply With Quote
Old 12-08-2018, 12:27 PM   #2
knc1
On Holiday
knc1 ought to be getting tired of karma fortunes by now.knc1 ought to be getting tired of karma fortunes by now.knc1 ought to be getting tired of karma fortunes by now.knc1 ought to be getting tired of karma fortunes by now.knc1 ought to be getting tired of karma fortunes by now.knc1 ought to be getting tired of karma fortunes by now.knc1 ought to be getting tired of karma fortunes by now.knc1 ought to be getting tired of karma fortunes by now.knc1 ought to be getting tired of karma fortunes by now.knc1 ought to be getting tired of karma fortunes by now.knc1 ought to be getting tired of karma fortunes by now.
 
knc1's Avatar
 
Posts: 16,323
Karma: 17324622
Join Date: Feb 2012
Location: Central Texas
Device: No K1, PW2, KV, KOA
The Kindle's virtual keyboard is not suppose to be operated from the serial port or to be available on-screen.

The serial port input from your terminal emulator is the only input device.
The serial port output to your terminal emulator is the only output.

- - - - -

Most likely problem: User error.

See the section you posted:
Code:
Press [ENTER] for recovery menu... 
0 /ERROR:gasgauge_battery_id_valid: No battery found
ERROR:
=== BATTERY ID IS INVALID. STOPPING BOOT ===
Does not show you ever pressed "Enter" and is pretty explicit in why the boot process halted.

Last edited by knc1; 12-08-2018 at 12:30 PM.
knc1 is offline   Reply With Quote
Advert
Old 12-08-2018, 01:32 PM   #3
hanalee
Member
hanalee began at the beginning.
 
Posts: 11
Karma: 12
Join Date: Jul 2018
Device: kindle pw3
Thank you for answer.
My description was not enough.
The keyboard is the pc keyboard.
I have rebooted the Kindle. I tried to enter the u-boot menu by pressing the pc keyboard key.
But the keystroke did not work.
The serial port connection was made by soldering.
The voltage of the wire connected to the serial port is normal.
What is the problem?

Is it a battery problem that Kindle does not boot ...
But the charge is enough. The battery voltage is 4.17V.
Is the battery broken ...?
hanalee is online now   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
PW3 Serial port in Kindle PaperWhite 3 mesblau Kindle Developer's Corner 31 Yesterday 12:36 PM
PW1 lost PADs for serial port, but found signals near USB port uniqdom Kindle Developer's Corner 1 04-29-2015 09:45 AM
Kindle Touch serial port recovery. geekmaster Kindle Developer's Corner 41 03-11-2013 10:41 PM
K3 using serial port problem BusterBrown Kindle Developer's Corner 42 06-05-2012 07:11 PM
Help with unbricking kindle via serial port yifanlu Kindle Developer's Corner 12 03-10-2011 08:51 AM


All times are GMT -4. The time now is 03:02 AM.


MobileRead.com is a privately owned, operated and funded community.