Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre


Thread Tools Search this Thread
Old 06-14-2009, 06:16 PM   #1
TMF began at the beginning.
Posts: 41
Karma: 10
Join Date: May 2009
Device: PRS-505
"Send to device" problems with 0.5.14 / PRS-505

Hi, I'm having what seem to be performance problems with attempting to send files to my PRS-505's memory card under Windows Vista.

Individual files transfer just fine, but today I tried to transfer 69 files (about 900 MB) at a time. Calibre appeared to lock up for about 15 minutes before it began copying, and overall system performance degraded noticeably. During this time, Calibre appeared to be buffering the files to the AppData/Local/Temp directory, but I don't understand why it needs to do this or why it takes so long. Then, after the actual transfer started, it aborted with this error message:

Job: **Upload 69 books to device: <long list of titles removed>**
**IOError**: (2, 'No such file or directory')
Traceback (most recent call last):
File "calibre\gui2\device.pyo", line 43, in run
File "calibre\gui2\device.pyo", line 173, in _upload_books
File "calibre\devices\prs505\driver.pyo", line 430, in upload_books
File "calibre\devices\prs505\driver.pyo", line 376, in put_file
File "shutil.pyo", line 30, in copyfileobj
IOError: [Errno 2] No such file or directory

And then the PRS-505 rebooted.

Moreover, when I also today attempted to transfer my whole library (about 6 GB) to a fresh memory card, the operating system locked up entirely after a few minutes (not even Ctrl-Alt-Delete helped) and I had to force a reboot of the computer.

I'm not sure if it would be helpful if I opened a ticket about this, but I suggest that a progress bar or some indication of activity during the buffering stage, at least, would be helpful from a UI point of view.



Addition: Transfering the files in batches of ten worked fine, too. It seems that there is something in the transfer code that does not scale well.

Last edited by TMF; 06-14-2009 at 06:42 PM. Reason: typo
TMF is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to change "Send to device" without folders? Skydog Calibre 12 05-23-2010 01:13 PM
template for "send to device" customization sbin Calibre 8 01-07-2010 08:22 AM
New PRS-700: "USB Device Not Recognized" -- HELP! Cyrusx7 Sony Reader 13 09-10-2009 01:38 AM
SONY PRS-700 "Date and Time" problems dda Sony Reader 8 06-11-2009 02:13 PM
Help needed! E-ink Device (PRS-505) or PDA (4" VGA Backlighted screen)? Faenad Which one should I buy? 9 08-28-2008 12:20 AM

All times are GMT -4. The time now is 11:54 AM. is a privately owned, operated and funded community.