Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Kobo Reader

Notices

Reply
 
Thread Tools Search this Thread
Old 06-05-2011, 04:49 PM   #196
barberiggs
Junior Member
barberiggs began at the beginning.
 
Posts: 2
Karma: 10
Join Date: Jun 2011
Device: kobo
hello all

Just bought the n647 kobo today and looking for a 64bit software for the linux mint debian edition (LMDE) or a 32 bit for the same edition.
Anyone know if these are out yet?
Sent a pm but just double checking in case it is already out for download.

Thanks
barberiggs is offline   Reply With Quote
Old 06-05-2011, 10:40 PM   #197
PeterT
Grand Sorcerer
PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.
 
PeterT's Avatar
 
Posts: 10,342
Karma: 60928043
Join Date: Nov 2007
Location: Toronto
Device: Nexus 7, Clara, Touch, Tolino EPOS
Quote:
Originally Posted by barberiggs View Post
Just bought the n647 kobo today and looking for a 64bit software for the linux mint debian edition (LMDE) or a 32 bit for the same edition.
Anyone know if these are out yet?
Sent a pm but just double checking in case it is already out for download.

Thanks
Lol.. I had to check! You mean the Kobo WiFi !
PeterT is offline   Reply With Quote
Advert
Old 06-06-2011, 11:35 AM   #198
barberiggs
Junior Member
barberiggs began at the beginning.
 
Posts: 2
Karma: 10
Join Date: Jun 2011
Device: kobo
Yes it runs wifi also, I installed it on the lmde version 32 bit and it works fine, had to reset the kobo to get it to read since it was new nothing was lost, after that all works great, it syncs updated etc etc etc, just had to install the libzip file other than that all went well, now I am going to try it on the 64bit lmde version and see how it works, then I'll deal with the ADE wine and try to get that running. (well my husband will lol).
barberiggs is offline   Reply With Quote
Old 06-14-2011, 04:52 PM   #199
2doggiesmom
Junior Member
2doggiesmom began at the beginning.
 
Posts: 2
Karma: 10
Join Date: Jun 2011
Device: Kobo
Hi. This is my first post so apologies for my knowledge gaps.

I had a Kobo which died and it was replaced with a refurbished one. Now I have to get the unofficial desktop version so I can reinstall the books I had purchased but not read.

If someone would tell me how to send a PM to JCKobo I would be very grateful.

2doggiesmom
2doggiesmom is offline   Reply With Quote
Old 06-15-2011, 01:31 PM   #200
taming
Trying for calm & polite
taming ought to be getting tired of karma fortunes by now.taming ought to be getting tired of karma fortunes by now.taming ought to be getting tired of karma fortunes by now.taming ought to be getting tired of karma fortunes by now.taming ought to be getting tired of karma fortunes by now.taming ought to be getting tired of karma fortunes by now.taming ought to be getting tired of karma fortunes by now.taming ought to be getting tired of karma fortunes by now.taming ought to be getting tired of karma fortunes by now.taming ought to be getting tired of karma fortunes by now.taming ought to be getting tired of karma fortunes by now.
 
taming's Avatar
 
Posts: 4,012
Karma: 9455193
Join Date: May 2010
Location: Mostly in Canada
Device: kobo original, WiFI, Touch, Glo, and Aura
JC is spending most of his time on a different project. You might PM George instead as he is posting here often, these days. Of course JC might still hook you up.
taming is offline   Reply With Quote
Advert
Old 06-15-2011, 03:58 PM   #201
george.talusan
Kobo Developer Intern
george.talusan ought to be getting tired of karma fortunes by now.george.talusan ought to be getting tired of karma fortunes by now.george.talusan ought to be getting tired of karma fortunes by now.george.talusan ought to be getting tired of karma fortunes by now.george.talusan ought to be getting tired of karma fortunes by now.george.talusan ought to be getting tired of karma fortunes by now.george.talusan ought to be getting tired of karma fortunes by now.george.talusan ought to be getting tired of karma fortunes by now.george.talusan ought to be getting tired of karma fortunes by now.george.talusan ought to be getting tired of karma fortunes by now.george.talusan ought to be getting tired of karma fortunes by now.
 
george.talusan's Avatar
 
Posts: 84
Karma: 253043
Join Date: Apr 2010
Location: Toronto, ON
Device: Kobo Touch, Kobo Mini, Kobo Glo
http://dl.dropbox.com/u/2183775/kobo-desktop.deb for the Touch compatible desktop

http://dl.dropbox.com/u/2183775/kobo-desktop-older.deb for the original Kobo and Kobo Wifi compatible desktop.

The two will hopefully be merged into one awesome release real soon now.
george.talusan is offline   Reply With Quote
Old 06-16-2011, 03:16 PM   #202
daewon
Enthusiast
daewon began at the beginning.
 
Posts: 33
Karma: 10
Join Date: Jun 2011
Device: Nook STR
I'm running opensuse 11.4 linux and i just tried the .exe installer under the latest wine and it does not seem to be detecting when i plug the Kobo Touch into the usb port...

I refuse to and will not run windows...I saw some mention of using the files in the deb file and placing them manually that some people have had luck with?

Assuming there is going to be no rpm version any time soon...Hw do i install the files from the deb file?

Last edited by daewon; 06-16-2011 at 03:26 PM.
daewon is offline   Reply With Quote
Old 06-17-2011, 12:40 AM   #203
daewon
Enthusiast
daewon began at the beginning.
 
Posts: 33
Karma: 10
Join Date: Jun 2011
Device: Nook STR
dot dot dot

Last edited by daewon; 06-17-2011 at 02:27 AM. Reason: removing inappropriate posting
daewon is offline   Reply With Quote
Old 06-17-2011, 01:08 AM   #204
george.talusan
Kobo Developer Intern
george.talusan ought to be getting tired of karma fortunes by now.george.talusan ought to be getting tired of karma fortunes by now.george.talusan ought to be getting tired of karma fortunes by now.george.talusan ought to be getting tired of karma fortunes by now.george.talusan ought to be getting tired of karma fortunes by now.george.talusan ought to be getting tired of karma fortunes by now.george.talusan ought to be getting tired of karma fortunes by now.george.talusan ought to be getting tired of karma fortunes by now.george.talusan ought to be getting tired of karma fortunes by now.george.talusan ought to be getting tired of karma fortunes by now.george.talusan ought to be getting tired of karma fortunes by now.
 
george.talusan's Avatar
 
Posts: 84
Karma: 253043
Join Date: Apr 2010
Location: Toronto, ON
Device: Kobo Touch, Kobo Mini, Kobo Glo
Quote:
Originally Posted by daewon View Post
This is so irritating...I sent all this money on something i had faith in and it turns out i can't even use it...Come on devs...I see there's been the debian package out for about a year...Does it take that long to do an rpm package? I understand the touch was shipped with not so ready for prime time firmware? You should make people more aware of that who do not use the most mainstream operating systems and might be screwed if they buy the touch not knowing it may end up not being able to use without having to just through a mile of hoops...I swear i am so totally ready to return this and go o something else...
Howdy Daewon,

The developer responsible for providing an unsupported build of the Kobo Desktop to Linux users happens to be me. Unfortunately it's not within my means to target every single distribution - it'd mean the company would have more unsupported than supported software.

You've been given several answers to help you along, and given that you're a Linux user I'm hoping you should be accustomed to doing things from the command line. In brief, download 'alien' using OpenSUSE's package management system. If it's not provided by OpenSUSE, then please download it from the Internet using a searchtool like Google. Once you have alien, you can run this:

Code:
sudo alien -r kobo-desktop.deb
It should create a .rpm from the .deb file. Don't forget to download the .deb file if you haven't. Now you can install it using whatever tool installs .rpms on OpenSUSE. You may need to resolve some dependency issues around libzip or if you're running a 64-bit version of OpenSUSE.
george.talusan is offline   Reply With Quote
Old 06-17-2011, 01:28 AM   #205
daewon
Enthusiast
daewon began at the beginning.
 
Posts: 33
Karma: 10
Join Date: Jun 2011
Device: Nook STR
Quote:
Originally Posted by george.talusan View Post
Howdy Daewon,

The developer responsible for providing an unsupported build of the Kobo Desktop to Linux users happens to be me. Unfortunately it's not within my means to target every single distribution - it'd mean the company would have more unsupported than supported software.

You've been given several answers to help you along, and given that you're a Linux user I'm hoping you should be accustomed to doing things from the command line. In brief, download 'alien' using OpenSUSE's package management system. If it's not provided by OpenSUSE, then please download it from the Internet using a searchtool like Google. Once you have alien, you can run this:

Code:
sudo alien -r kobo-desktop.deb
It should create a .rpm from the .deb file. Don't forget to download the .deb file if you haven't. Now you can install it using whatever tool installs .rpms on OpenSUSE. You may need to resolve some dependency issues around libzip or if you're running a 64-bit version of OpenSUSE.
Hi George. I apologize for being cross...It's just frustrating you know?...I know you all work hardSometimes linux tends to be touchy between distros even though it may be an rpm file or deb...I did try the suggestions but thye just didn't seem to be working for me...I did look at the alien thing...it didnt say it made rpm's...it said it made packages from rpm's? So i didn't try it...But I've been tinkering with it all this time and i think i'm having some success...

But since i have you on here...What do i do if the touch is telling me that i'm using the wrong network login and i know i am not? :-)

Again i do apologize for being cross...Just venting...I was actually about to delete this post but then yu had already replied...So yeah...Sorry everyne
daewon is offline   Reply With Quote
Old 06-17-2011, 01:55 AM   #206
portablejim
Enthusiast
portablejim has learned how to buy an e-book online
 
portablejim's Avatar
 
Posts: 49
Karma: 88
Join Date: Jun 2011
Location: NSW, Australia
Device: Kobo Touch Black
Quote:
Originally Posted by george.talusan View Post
http://dl.dropbox.com/u/2183775/kobo-desktop.deb for the Touch compatible desktop

http://dl.dropbox.com/u/2183775/kobo-desktop-older.deb for the original Kobo and Kobo Wifi compatible desktop.

The two will hopefully be merged into one awesome release real soon now.
For those with a 64-bit installation, you may need to get libzip as a 32-bit library.

For those on Debian based (64-bit) distributions (e.g. Ubuntu):
First you need ia32-libs
Code:
sudo apt-get install ia32-libs
Install the downloaded package with
Code:
sudo dpkg --force-architecture -i kobo-desktop.deb
Install getlibs by getting the latest from http://frozenfox.freehostia.com/cappy/ and installing
then install the needed libraries (in this case libzip)
Code:
getlibs -p libzip1
The software can now be launched from /usr/bin/Kobo with
Code:
Kobo

Last edited by portablejim; 06-17-2011 at 09:51 PM. Reason: Fixing / Finish writing
portablejim is offline   Reply With Quote
Old 06-17-2011, 08:54 PM   #207
Solicitous
Wizard
Solicitous ought to be getting tired of karma fortunes by now.Solicitous ought to be getting tired of karma fortunes by now.Solicitous ought to be getting tired of karma fortunes by now.Solicitous ought to be getting tired of karma fortunes by now.Solicitous ought to be getting tired of karma fortunes by now.Solicitous ought to be getting tired of karma fortunes by now.Solicitous ought to be getting tired of karma fortunes by now.Solicitous ought to be getting tired of karma fortunes by now.Solicitous ought to be getting tired of karma fortunes by now.Solicitous ought to be getting tired of karma fortunes by now.Solicitous ought to be getting tired of karma fortunes by now.
 
Posts: 1,434
Karma: 1525776
Join Date: Aug 2009
Location: TAS, Australia
Device: Astak Pocket Pro (Black), 2 x Kindle WiFi (Graphite), iPod Touch 4G
Quote:
Originally Posted by george.talusan View Post
http://dl.dropbox.com/u/2183775/kobo-desktop.deb for the Touch compatible desktop

http://dl.dropbox.com/u/2183775/kobo-desktop-older.deb for the original Kobo and Kobo Wifi compatible desktop.

The two will hopefully be merged into one awesome release real soon now.
Is it just me, or do both report at being 1.8.1 when you go to install either of them?
Solicitous is offline   Reply With Quote
Old 06-19-2011, 02:18 AM   #208
thdurrant
Junior Member
thdurrant began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Jun 2011
Device: Kobo Touch
Following portablejim's instructions, I get the following error


dpkg: warning: overriding problem because --force enabled:
package architecture (i386) does not match system (amd64)
(Reading database ... 211030 files and directories currently installed.)
Preparing to replace kobo-desktop:i386 1.8-1 (using kobo-desktop.deb) ...
Unpacking replacement kobo-desktop:i386 ...
dpkg: dependency problems prevent configuration of kobo-desktop:i386:
kobo-desktop:i386 depends on libusb-0.1-4.
kobo-desktop:i386 depends on libpng3.
kobo-desktop:i386 depends on libpng12-0.
kobo-desktop:i386 depends on libjpeg62.
kobo-desktop:i386 depends on libxml2.
dpkg: error processing kobo-desktop:i386 (--install):
dependency problems - leaving unconfigured
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_AU.utf8.cache...
Processing triggers for python-support ...
Errors were encountered while processing:
kobo-desktop:i386

On ubuntu 11.04
thdurrant is offline   Reply With Quote
Old 06-19-2011, 03:03 AM   #209
portablejim
Enthusiast
portablejim has learned how to buy an e-book online
 
portablejim's Avatar
 
Posts: 49
Karma: 88
Join Date: Jun 2011
Location: NSW, Australia
Device: Kobo Touch Black
Quote:
Originally Posted by thdurrant View Post
dpkg: dependency problems prevent configuration of kobo-desktop:i386:
kobo-desktop:i386 depends on libusb-0.1-4.
kobo-desktop:i386 depends on libpng3.
kobo-desktop:i386 depends on libpng12-0.
kobo-desktop:i386 depends on libjpeg62.
kobo-desktop:i386 depends on libxml2.
Try running 'getlibs' for the dependancies, using the package name without the version (some numbers are part of the package name).
i.e. I'd try: 'libusb', 'libpng3', 'libpng12', ,libjpeg62', 'libxml2'

e.g.
Code:
getlibs -p libusb
Quote:
Originally Posted by thdurrant View Post
On ubuntu 11.04
I am on 10.10, and have had the 32-bit support for a while, so I guess some of the dependencies were already installed for me. The list above ("I'd try ...") is the complete list of dependencies

Last edited by portablejim; 06-19-2011 at 08:26 AM. Reason: Fix up getlibs command
portablejim is offline   Reply With Quote
Old 06-19-2011, 04:09 AM   #210
thdurrant
Junior Member
thdurrant began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Jun 2011
Device: Kobo Touch
Thanks for the suggestions portablejim,

I tried the package names you suggested, as well as the full names, no good I am afraid...

Given these are the only dependencies, could it be a path issue? i.e. does getlibs download to a non-standard path, that kobo doesn't look for?
thdurrant is offline   Reply With Quote
Reply

Tags
desktop, kobo, linux, software

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Get Sony Reader Desktop Version to Work with Linux? Flyweight Sony Reader 3 11-14-2010 07:47 PM
Over trying to manage Kobo reader with Kobo desktop. Some help with Calibre? digital_steve Calibre 14 09-18-2010 01:12 AM
Over trying to manage Kobo reader with Kobo desktop. Some help with Calibre? digital_steve Kobo Reader 11 08-02-2010 10:31 PM
Kobo Desktop for Linux: Update Available? luqmaninbmore Kobo Reader 2 07-16-2010 11:00 AM
Using Kobo Desktop issues... clicker666 Kobo Reader 6 06-29-2010 04:21 PM


All times are GMT -4. The time now is 05:52 AM.


MobileRead.com is a privately owned, operated and funded community.