Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Amazon Kindle > Kindle Developer's Corner

Notices

Reply
 
Thread Tools Search this Thread
Old 02-13-2020, 05:49 PM   #1
WaseemAlkurdi
Zealot
WaseemAlkurdi began at the beginning.
 
Posts: 147
Karma: 12
Join Date: Jul 2019
Device: Kindle Touch (K5) Wi-Fi x 2, Kindle (7th Gen, KT2), Paperwhite 3rd Gen
Serial port not working

Hi!

Background:
I'm trying to jailbreak my newest acquisition, a White Paperwhite 3.
I've dismantled it (the easy part), but the serial port doesn't seem to provide output.
A multimeter test shows that it has an output of ~1.2 volts (+/-). (It wasn't the usual 1.8 volts).
A continuity/flow test causes the multimeter to beep, indicating that there is flow.
However, the serial adapter is not sending any output to Minicom.

A picture:
Code:
Kindle                      Adapter
======                      =======
Blue (Tx)                   Pin labeled Rx, 2nd pin from adapter left
Pink (Rx)                   Pin labeled Tx, 3rd pin from adapter left
Gray (third Kindle pin)     Tried connecting as (a) Ground (b) Vcc - 4th pin from adapter left (c) to nothing)
Red (ground under screw)    GND - last pin from adapter left
TP1706 as red cabe (ref)    Vcc - 4th pin from adapter left



What I tried:
1. Connecting the TP1706 reference battery voltage pin (via the non-soldered red cable) to ground and to the Vcc pin (4th pin from adapter left). Doing the latter would make the adapter freak out (the two adapter LEDs would illuminate, and Minicom would print "Cannot open /dev/ttyUSB0") until I remove the offending connection.
2. Connecting the gray cable as ground and as adapter voltage (yikes! But I know better now).

What was expected to happen:
A serial connection, flashing adapter Rx and Tx LEDs, or at least noise on the terminal.

What did happen:
Nothing on terminal, except for two (only two) characters of noise. (These: �� )

What I suspect and reasons to eliminate each suspicion:
1. Bad solder ---> but it does produce a reading on the multimeter and continuity tests.
2. Adapter, since I misplaced it for some time ----> see below

Why I believe the adapter isn't toast:
It does the following:
1. Its LEDs blink twice when connecting the adapter (even if the terminals were disconnected)
2. It is detected by Linux and Minicom
3. It did print out two characters of noise.
4. Connecting it prints the following lines in dmesg:
Code:
[69045.337976] usb 2-3: new full-speed USB device number 110 using xhci_hcd
[69045.492152] usb 2-3: New USB device found, idVendor=0403, idProduct=6001, bcdDevice= 6.00
[69045.492158] usb 2-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[69045.492162] usb 2-3: Product: FT232R USB UART
[69045.492165] usb 2-3: Manufacturer: FTDI
[69045.492167] usb 2-3: SerialNumber: A5XK3RJT
[69045.495635] ftdi_sio 2-3:1.0: FTDI USB Serial Device converter detected
[69045.495747] usb 2-3: Detected FT232RL
[69045.496525] usb 2-3: FTDI USB Serial Device converter now attached to ttyUSB0
while disconnecting it prints this:
Code:
[69122.286060] usb 2-3: USB disconnect, device number 110
[69122.286254] ftdi_sio ttyUSB0: error from flowcontrol urb
[69122.287009] ftdi_sio ttyUSB0: FTDI USB Serial Device converter now disconnected from ttyUSB0
[69122.287076] ftdi_sio 2-3:1.0: device disconnected
What should I do now?


UPDATE: It just worked. Spontaneously. Miraculously. I haven't the slightest clue as to why. The only thing I had done before it started working is to shake the cables ... but I did that like two gazillion times before that.

I'd appreciate it if a mod deletes this thread.

Last edited by WaseemAlkurdi; 02-13-2020 at 05:56 PM.
WaseemAlkurdi is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
jailbreak KV via serial port? procyon Kindle Developer's Corner 1 08-01-2017 06:34 AM
Aura H2O How to get messages from the serial port ? sahbi Kobo Developer's Corner 3 03-10-2017 02:59 PM
Serial port debrick Fridolf Kindle Developer's Corner 9 05-19-2015 06:14 AM
PW1 lost PADs for serial port, but found signals near USB port uniqdom Kindle Developer's Corner 1 04-29-2015 09:45 AM
K3 using serial port problem BusterBrown Kindle Developer's Corner 42 06-05-2012 07:11 PM


All times are GMT -4. The time now is 02:42 AM.


MobileRead.com is a privately owned, operated and funded community.