Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Server

Notices

Reply
 
Thread Tools Search this Thread
Old 06-12-2021, 10:01 PM   #1
basker
Junior Member
basker began at the beginning.
 
Posts: 4
Karma: 10
Join Date: Nov 2020
Device: none
Content Server, wireless inaccessible on local network, but work locally (Mac)

Hi,

On macOS Big Sur, I'm having trouble with the content server and wireless client connection. They used to work, but seem to no longer work. Maybe with the 5.20/5.21 update. The settings are the defaults.

I can see the calibre process listening on 0.0.0.0 for ports 8080 and 9090 with netstat and GUI programs. In the Calibre interface it says it's sharing on the actual DHCP supplied IPs.

On the mac where Calibre is running I can access the content server on all the local IP addresses -- 127.0.0.1 and the addresses provided by DHCP to the ethernet and wireless connections. No problem here.

For other computers on the same network, I cannot reach the content server. My firewall settings are set to allow Calibre. However if I disable the firewall I still have the problem.

What really confuses me is that if I quit calibre and run a different web server on ports port 8080 and 9090, then I can see the server and view files with the firewall on or disabled. No blocking.

For example, if I run `python3 -m http.server 8080`, I have no problems getting to the caliber mac from any other machine on my network.

I also noticed that if I run a network scanner against my mac, then when Calibre is not running ports 8080 and 9090 show as closed. When I run Calibre, the ports show as "blocked".

The other ports where apps are running show as open and respond to the scan. Calibre is the only app that's not able to respond to network requests.

I've tried all the normal troubleshooting, including deleting my system and firewall prefs so they have the default settings.

Has anyone else seen this sort of thing?

Thanks,

B
basker is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Content server: Add a button to delete all locally cached books stumped Calibre 11 03-07-2020 02:08 AM
calibredb does not work with content server running (content server is using --enable Irvin Server 3 01-08-2019 02:47 AM
Content Server on a home network mtjj Calibre 10 11-08-2017 09:23 AM
Content Server is using a wrong network card myki Devices 5 03-25-2015 01:02 PM
Cannot access Content Server - even locally BumbleBernie Devices 27 03-16-2014 08:59 AM


All times are GMT -4. The time now is 12:16 AM.


MobileRead.com is a privately owned, operated and funded community.