Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Plugins

Notices

Reply
 
Thread Tools Search this Thread
Old 09-02-2014, 03:31 AM   #61
davidfor
Grand Sorcerer
davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.
 
Posts: 12,446
Karma: 18869148
Join Date: Jul 2011
Location: Sydney, Australia
Device: Kobo: Touch, Glo, Aura H2O, Glo HD
Quote:
Originally Posted by Jwt0001 View Post
Here is the log. I was able to get it to connect this time:
Well, that is to be expected. It always works when the repairman is looking over your shoulder

If it doesn't work again, can you try the debug mode and see if we can capture something.
davidfor is offline   Reply With Quote
Advert
Old 09-02-2014, 04:03 AM   #62
dgparryuk
Enthusiast
dgparryuk began at the beginning.
 
Posts: 25
Karma: 10
Join Date: Dec 2013
Device: Kobo Glo
Ran Beta copy on Win7, - Calibre 64-Bit 2.1 - onto Marvinon an iOS7 - and it worked perfectly
dgparryuk is offline   Reply With Quote
Old 09-02-2014, 09:38 AM   #63
amintarabay
Junior Member
amintarabay began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Sep 2014
Device: iPad Mini
Error Communicationg with device. Mac OSX 10.9.4

I got "Error Communicating With Device" using Calibre 2.1 on OSX 10.9.4. After I press ok on the warning popup calibre shows the device tab and the marvin tab but every time I try to send to device or update metadata I get the same "Error Communication With Device" warning that i get when first connecting.
the log is as follows:

calibre, version 2.1.0
ERROR: Error: Error communicating with device

database disk image is malformed

Traceback (most recent call last):
File "site-packages/calibre/gui2/device.py", line 86, in run
File "site-packages/calibre/gui2/device.py", line 501, in _books
File "/var/folders/jd/z5fd7qh13hsgxw4l1j8gvkk00000gn/T/calibre_2.1.0_tmp_jbwQtV/8VIwYJ_ios_local_db/Marvin_overlays.py", line 285, in books
File "/var/folders/jd/z5fd7qh13hsgxw4l1j8gvkk00000gn/T/calibre_2.1.0_tmp_jbwQtV/8VIwYJ_ios_local_db/Marvin_overlays.py", line 2352, in _restore_from_snapshot
File "/var/folders/jd/z5fd7qh13hsgxw4l1j8gvkk00000gn/T/calibre_2.1.0_tmp_jbwQtV/8VIwYJ_ios_local_db/Marvin_overlays.py", line 2328, in _validate_mainDb_profile
File "/var/folders/jd/z5fd7qh13hsgxw4l1j8gvkk00000gn/T/calibre_2.1.0_tmp_jbwQtV/8VIwYJ_ios_local_db/Marvin_overlays.py", line 1579, in _compare_mainDb_profiles
File "/var/folders/jd/z5fd7qh13hsgxw4l1j8gvkk00000gn/T/calibre_2.1.0_tmp_jbwQtV/8VIwYJ_ios_local_db/Marvin_overlays.py", line 2109, in _profile_db
DatabaseError: database disk image is malformed
amintarabay is offline   Reply With Quote
Old 09-02-2014, 10:43 AM   #64
Philantrop
Addict
Philantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beauty
 
Philantrop's Avatar
 
Posts: 271
Karma: 32153
Join Date: Dec 2008
Device: Kindle PW3, iOS devices
I've just posted a new release (1.4.3) that fixes 2.x compatibility and some other minor issues.

Thanks, David, for contributing most of the code needed for 2.x compatibility. Greatly appreciated!
Philantrop is offline   Reply With Quote
Old 09-02-2014, 11:38 AM   #65
MSWallack
Right, Except When Wrong
MSWallack ought to be getting tired of karma fortunes by now.MSWallack ought to be getting tired of karma fortunes by now.MSWallack ought to be getting tired of karma fortunes by now.MSWallack ought to be getting tired of karma fortunes by now.MSWallack ought to be getting tired of karma fortunes by now.MSWallack ought to be getting tired of karma fortunes by now.MSWallack ought to be getting tired of karma fortunes by now.MSWallack ought to be getting tired of karma fortunes by now.MSWallack ought to be getting tired of karma fortunes by now.MSWallack ought to be getting tired of karma fortunes by now.MSWallack ought to be getting tired of karma fortunes by now.
 
MSWallack's Avatar
 
Posts: 273
Karma: 1090652
Join Date: Aug 2007
Location: Indianapolis
Device: iPad Mini (but I have numerous other devices buried here & there...)
If I'm stuck with Calibre 1.48 (I'm forced to use WinXP...), should I or should I not update to the new version of iOS reader application plugin?
MSWallack is offline   Reply With Quote
Advert
Old 09-02-2014, 11:40 AM   #66
Philantrop
Addict
Philantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beauty
 
Philantrop's Avatar
 
Posts: 271
Karma: 32153
Join Date: Dec 2008
Device: Kindle PW3, iOS devices
Quote:
Originally Posted by MSWallack View Post
If I'm stuck with Calibre 1.48 (I'm forced to use WinXP...), should I or should I not update to the new version of iOS reader application plugin?
The new version should work with both Calibre 1.x and 2.x. If you find any issues, please file a bug report on github.
Philantrop is offline   Reply With Quote
Old 09-02-2014, 03:37 PM   #67
kaufman
Calibre Companion Fanatic
kaufman ought to be getting tired of karma fortunes by now.kaufman ought to be getting tired of karma fortunes by now.kaufman ought to be getting tired of karma fortunes by now.kaufman ought to be getting tired of karma fortunes by now.kaufman ought to be getting tired of karma fortunes by now.kaufman ought to be getting tired of karma fortunes by now.kaufman ought to be getting tired of karma fortunes by now.kaufman ought to be getting tired of karma fortunes by now.kaufman ought to be getting tired of karma fortunes by now.kaufman ought to be getting tired of karma fortunes by now.kaufman ought to be getting tired of karma fortunes by now.
 
kaufman's Avatar
 
Posts: 854
Karma: 1088482
Join Date: Nov 2006
Device: Galaxy Note 4, Kindle Voyage
A friend of mine has asked me to post this here. He is using this plugin with the marvin one. He is using the most current versions of Claibre and all the plugins. Recently, he noticed that the Marvin plugin was no longer showing up on his toolbar. He tried a couple of things but finally removed and reinstalled the plugins. When he tries to configure the IOS reader one now, he gets the following error:



When he tried to configure it the second time, he got:



Any suggestions/help would be appreciated.

Thanks.
kaufman is offline   Reply With Quote
Old 09-02-2014, 06:08 PM   #68
lamp
Junior Member
lamp began at the beginning.
 
Posts: 9
Karma: 10
Join Date: Jan 2014
Location: Mountain View, California
Device: iPad Air using Marvin, Nexus 7 (2Gen) using Calibre Companion
Hi I've upgraded to the latest ios reader app (1.4.3). I uninstalled the plugins and resources again because I encountered "importerror no module named pyqt4 calibre" the first time around. Now when I started calibre, I did see "Marvin XD and IOS Reader App pointing to Marvin, however also have the error where it said Database disk image is malformed.

calibre, version 2.1.0
ERROR: Error: Error communicating with device

database disk image is malformed

Traceback (most recent call last):
File "site-packages/calibre/gui2/device.py", line 86, in run
File "site-packages/calibre/gui2/device.py", line 501, in _books
File "/var/folders/x7/94fnxx_91nl3m6wtrll3_qnr0000gn/T/calibre_2.1.0_tmp_vqRLiK/_FDTd2_ios_local_db/Marvin_overlays.py", line 301, in books
DatabaseError: database disk image is malformed
lamp is offline   Reply With Quote
Old 09-02-2014, 06:26 PM   #69
Philantrop
Addict
Philantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beautyPhilantrop does all things with Zen-like beauty
 
Philantrop's Avatar
 
Posts: 271
Karma: 32153
Join Date: Dec 2008
Device: Kindle PW3, iOS devices
kaufman, lamp, you both should uninstall the plugins completely first (the following describes the procedure for iOS reader apps but it's similar for Marvin XD - if it smells like either, kill it):

- Go to Preferences | Advanced | Plugins | Device Interface plugins, select iOS reader applications.
- Click Remove plugin.
- Click Apply.
- Go to Preferences | Advanced | Miscellaneous, click Open calibre configuration directory.
- Open the plugins folder.
- Delete iOS reader applications.json.
- Delete the iOS_reader_applications_resources folder.
- Restart calibre.

Then try installing the plugin(s) again.

And please always state your operating system. And if there's a "Show details" button, it helps to click it and copy & paste the text. :-)
Philantrop is offline   Reply With Quote
Old 09-02-2014, 07:39 PM   #70
WJCronon
Junior Member
WJCronon began at the beginning.
 
Posts: 9
Karma: 10
Join Date: Aug 2007
Device: Marvin XD
I am having exactly the same problems as kaufman and lamp after having followed Philantrop's suggestion to uninstall the plugins completely by removing the plugin and then deleting the .json files and the resources folder in the calibre configuration directory. Worse, when I tried to go back to calibre 1.48 (since it will still talk with Marvin), the new versions of the plugins were the only ones available via calibre and now 1.48 won't interface with Marvin either using those plugins. The only thing that saved me was going into Time Machine on my Mac and restoring the old versions of the plugins to get calibre 1.48 working again. It's up and running, but I'm now feeling very nervous about these new plugins. I've gotten the same error messages as lamp and kaufman's friend. Help! I hope you now how much we all appreciate the work you're doing on this!!!

Last edited by WJCronon; 09-02-2014 at 07:50 PM. Reason: I'm no longer using a Sony Reader; I use Marvin XD
WJCronon is offline   Reply With Quote
Old 09-02-2014, 08:09 PM   #71
WJCronon
Junior Member
WJCronon began at the beginning.
 
Posts: 9
Karma: 10
Join Date: Aug 2007
Device: Marvin XD
To make sure I wasn't misleading anyone, I just completely uninstalled calibre, made sure all files relating to these plugins were deleted, and then installed calibre 2.1 followed by the plugins for IOS Reader followed by Marvin. When I tried to connect Marvin XD on an iPad with calibre, I got this set of error messages (I'm running Mac OS X 10.9.4):

calibre, version 2.1.0
ERROR: Error: Error communicating with device

database disk image is malformed

Traceback (most recent call last):
File "site-packages/calibre/gui2/device.py", line 86, in run
File "site-packages/calibre/gui2/device.py", line 501, in _books
File "/var/folders/vz/zhdqchxj0xv1fb7x_f2_x7nr0000gn/T/calibre_2.1.0_tmp_KumMOu/XwYli7_ios_local_db/Marvin_overlays.py", line 285, in books
File "/var/folders/vz/zhdqchxj0xv1fb7x_f2_x7nr0000gn/T/calibre_2.1.0_tmp_KumMOu/XwYli7_ios_local_db/Marvin_overlays.py", line 2352, in _restore_from_snapshot
File "/var/folders/vz/zhdqchxj0xv1fb7x_f2_x7nr0000gn/T/calibre_2.1.0_tmp_KumMOu/XwYli7_ios_local_db/Marvin_overlays.py", line 2328, in _validate_mainDb_profile
File "/var/folders/vz/zhdqchxj0xv1fb7x_f2_x7nr0000gn/T/calibre_2.1.0_tmp_KumMOu/XwYli7_ios_local_db/Marvin_overlays.py", line 1579, in _compare_mainDb_profiles
File "/var/folders/vz/zhdqchxj0xv1fb7x_f2_x7nr0000gn/T/calibre_2.1.0_tmp_KumMOu/XwYli7_ios_local_db/Marvin_overlays.py", line 2109, in _profile_db
DatabaseError: database disk image is malformed

When I then reinstall calibre 1.48 using the new plugins, I quickly get an "error communicating with the device message," with the following error report:

calibre, version 1.48.0
ERROR: Error: Error communicating with device

database disk image is malformed

Traceback (most recent call last):
File "site-packages/calibre/gui2/device.py", line 86, in run
File "site-packages/calibre/gui2/device.py", line 490, in _books
File "/var/folders/vz/zhdqchxj0xv1fb7x_f2_x7nr0000gn/T/calibre_1.48.0_tmp_bNQ4bz/FVVl3R_ios_local_db/Marvin_overlays.py", line 285, in books
File "/var/folders/vz/zhdqchxj0xv1fb7x_f2_x7nr0000gn/T/calibre_1.48.0_tmp_bNQ4bz/FVVl3R_ios_local_db/Marvin_overlays.py", line 2391, in _restore_from_snapshot
DatabaseError: database disk image is malformed

I hope this helps. Now I have to go back into Time Machine to find the old plug-ins again.

Last edited by WJCronon; 09-02-2014 at 08:14 PM.
WJCronon is offline   Reply With Quote
Old 09-02-2014, 09:33 PM   #72
davidfor
Grand Sorcerer
davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.
 
Posts: 12,446
Karma: 18869148
Join Date: Jul 2011
Location: Sydney, Australia
Device: Kobo: Touch, Glo, Aura H2O, Glo HD
WJCronan: I am reading the code correctly, the error is happening when trying to read a database. The database should be the one inside the calibre configuration directory in "plugins/iOS_reader_applications_resources" called "booklist.db". Try deleting that again.

If that doesn't fix it, you need to enable debugging in the plugin options and run calibre in debug mode. Then post the complete debug log.
davidfor is offline   Reply With Quote
Old 09-02-2014, 09:35 PM   #73
hokusbloke
Junior Member
hokusbloke began at the beginning.
 
Posts: 7
Karma: 10
Join Date: Sep 2014
Device: iPad
iOS Reader App doesn't work...just updated

Here's the problem:

calibre, version 2.1.0
ERROR: Unhandled exception: <b>ImportError</b>:No module named PyQt4

calibre 2.1 isfrozen: True is64bit: True
Darwin-13.3.0-x86_64-i386-64bit Darwin ('64bit', '')
('Darwin', '13.3.0', 'Darwin Kernel Version 13.3.0: Tue Jun 3 21:27:35 PDT 2014; root:xnu-2422.110.17~1/RELEASE_X86_64')
Python 2.7.8
OSX: ('10.9.4', ('', '', ''), 'x86_64')
Successfully initialized third party plugins: Marvin XD && iOS reader applications
Traceback (most recent call last):
File "site-packages/calibre/gui2/dialogs/plugin_updater.py", line 789, in _configure_clicked
File "site-packages/calibre/customize/__init__.py", line 152, in do_user_config
File "calibre_plugins.ios_reader_apps.__init__", line 493, in config_widget
File "site-packages/calibre/customize/zipplugin.py", line 179, in load_module
File "calibre_plugins.ios_reader_apps.config", line 26, in <module>
File "/Users/hokusbloke/Library/Preferences/calibre/plugins/iOS_reader_applications_resources/widgets/main_ui.py", line 10, in <module>
from PyQt4 import QtCore, QtGui
ImportError: No module named PyQt4

After all the trouble with the Marvin Plugin there seems to be a new issue with this one as well.....what's the fix???
hokusbloke is offline   Reply With Quote
Old 09-02-2014, 09:42 PM   #74
hokusbloke
Junior Member
hokusbloke began at the beginning.
 
Posts: 7
Karma: 10
Join Date: Sep 2014
Device: iPad
Here's another plugin error message I get

calibre, version 2.1.0
ERROR: Unhandled exception: <b>ImportError</b>:cannot import name ConfigWidget

calibre 2.1 isfrozen: True is64bit: True
Darwin-13.3.0-x86_64-i386-64bit Darwin ('64bit', '')
('Darwin', '13.3.0', 'Darwin Kernel Version 13.3.0: Tue Jun 3 21:27:35 PDT 2014; root:xnu-2422.110.17~1/RELEASE_X86_64')
Python 2.7.8
OSX: ('10.9.4', ('', '', ''), 'x86_64')
Successfully initialized third party plugins: Marvin XD && iOS reader applications
Traceback (most recent call last):
File "site-packages/calibre/gui2/preferences/plugins.py", line 292, in customize_plugin
File "site-packages/calibre/gui2/preferences/plugins.py", line 370, in modify_plugin
File "site-packages/calibre/customize/__init__.py", line 152, in do_user_config
File "calibre_plugins.ios_reader_apps.__init__", line 493, in config_widget
ImportError: cannot import name ConfigWidget
hokusbloke is offline   Reply With Quote
Old 09-02-2014, 10:23 PM   #75
davidfor
Grand Sorcerer
davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.
 
Posts: 12,446
Karma: 18869148
Join Date: Jul 2011
Location: Sydney, Australia
Device: Kobo: Touch, Glo, Aura H2O, Glo HD
Quote:
Originally Posted by hokusbloke View Post
calibre, version 2.1.0
ERROR: Unhandled exception: <b>ImportError</b>:cannot import name ConfigWidget

calibre 2.1 isfrozen: True is64bit: True
Darwin-13.3.0-x86_64-i386-64bit Darwin ('64bit', '')
('Darwin', '13.3.0', 'Darwin Kernel Version 13.3.0: Tue Jun 3 21:27:35 PDT 2014; root:xnu-2422.110.17~1/RELEASE_X86_64')
Python 2.7.8
OSX: ('10.9.4', ('', '', ''), 'x86_64')
Successfully initialized third party plugins: Marvin XD && iOS reader applications
Traceback (most recent call last):
File "site-packages/calibre/gui2/preferences/plugins.py", line 292, in customize_plugin
File "site-packages/calibre/gui2/preferences/plugins.py", line 370, in modify_plugin
File "site-packages/calibre/customize/__init__.py", line 152, in do_user_config
File "calibre_plugins.ios_reader_apps.__init__", line 493, in config_widget
ImportError: cannot import name ConfigWidget
That looks like it happened because you swapped between 1.48 and 2.1.0. The first time you use the plugin after installing or upgrading, it generates the files for the UI. But, the generation is done to the environment being used. So, swapping between calibre 1.48 and 2.1.0 while using the same profile will cause this. Delete "plugins/iOS_reader_applications_resources/widgets" and try again. If you are using the Marvin plugin, also delete "plugins/Marvin_XD_resources/dialogs". Both of these are in the calibre configuration directory.
davidfor is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[Device Plugin] iOS reader applications (closed) GRiker Plugins 182 06-15-2014 05:00 PM
iOS Reader Application Plugin Guinan Plugins 1 03-30-2014 08:18 PM
Getting Books onto your iOS device with iTunes kyteflyer Apple Devices 9 01-30-2013 02:50 PM
[Device Plugin] Kindle 2, 3, 4, Touch Device Interface MBP Update Mod cryzed Plugins 7 10-28-2012 04:58 PM


All times are GMT -4. The time now is 01:30 PM.


MobileRead.com is a privately owned, operated and funded community.