Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Plugins

Notices

Reply
 
Thread Tools Search this Thread
Old 12-21-2016, 08:31 AM   #601
HowardBrazee
Zealot
HowardBrazee began at the beginning.
 
HowardBrazee's Avatar
 
Posts: 110
Karma: 10
Join Date: Oct 2010
Location: Lafayette, CO
Device: iPad
I never got Calibre to automatically load to any of my IOS readers. But that's OK. If it only worked with Marvin, I would still be dragging the books to other readers as I like having my full library for each reader (and have multiple readers open at all times with books I am reading).
HowardBrazee is offline   Reply With Quote
Advert
Old 01-31-2017, 10:39 AM   #602
crashnburn
Zealot
crashnburn is a marvel to beholdcrashnburn is a marvel to beholdcrashnburn is a marvel to beholdcrashnburn is a marvel to beholdcrashnburn is a marvel to beholdcrashnburn is a marvel to beholdcrashnburn is a marvel to beholdcrashnburn is a marvel to beholdcrashnburn is a marvel to beholdcrashnburn is a marvel to beholdcrashnburn is a marvel to behold
 
Posts: 115
Karma: 11990
Join Date: Jul 2009
Device: iPad1 iOS 5.1.1b, iPhone 4
Quote:
Originally Posted by davidfor View Post
The plugin failed to initialise because the iOS device was connected. Hence calibre couldn't display it as an installed plugin. When you opened calibre without the iOS device connected, it could initialise and was displayed.

In any case, it doesn't matter. The plugin does not work with any iOS version since 8.3. So, it doesn't matter if the plugin is displayed or not. If you can fix it, you will make a lot of people happy.
Actually I until sometime during 2016 I was able to use Calibre with iOS 9.0.2 - But Jailbroken with tweaks installed. But, I was using this with Old Version of Marvin (Red) on an iPad 2 with Jailbroken iOS 9.0.2.

Only recently due to an Itunes upgrade (for my phone with iOS 10) did it seem to have messed/ broken.

I'd still prefer to use the old iPad 2 for reading if there was some way around.

From an older post:
Quote:
I am still on Marvin 2.5.4 on iOS 9.0.2 on iPad 2 (recent up to this one from iPad1, given by a cousin as my iPad 1 was lost/ stolen last year) - which works with Calibre via the driver etc for ePubs.

I am wondering if this works with 2.8.5?

Last edited by crashnburn; 01-31-2017 at 10:45 AM.
crashnburn is offline   Reply With Quote
Old 01-31-2017, 10:40 AM   #603
crashnburn
Zealot
crashnburn is a marvel to beholdcrashnburn is a marvel to beholdcrashnburn is a marvel to beholdcrashnburn is a marvel to beholdcrashnburn is a marvel to beholdcrashnburn is a marvel to beholdcrashnburn is a marvel to beholdcrashnburn is a marvel to beholdcrashnburn is a marvel to beholdcrashnburn is a marvel to beholdcrashnburn is a marvel to behold
 
Posts: 115
Karma: 11990
Join Date: Jul 2009
Device: iPad1 iOS 5.1.1b, iPhone 4
Quote:
Originally Posted by HowardBrazee View Post
I never got Calibre to automatically load to any of my IOS readers. But that's OK. If it only worked with Marvin, I would still be dragging the books to other readers as I like having my full library for each reader (and have multiple readers open at all times with books I am reading).
Curious. Do share more on this thought please. Thanks.
crashnburn is offline   Reply With Quote
Old 06-19-2017, 09:23 AM   #604
Frenchdummy
Enthusiast
Frenchdummy can illuminate an eclipseFrenchdummy can illuminate an eclipseFrenchdummy can illuminate an eclipseFrenchdummy can illuminate an eclipseFrenchdummy can illuminate an eclipseFrenchdummy can illuminate an eclipseFrenchdummy can illuminate an eclipseFrenchdummy can illuminate an eclipseFrenchdummy can illuminate an eclipseFrenchdummy can illuminate an eclipseFrenchdummy can illuminate an eclipse
 
Posts: 27
Karma: 8300
Join Date: Apr 2013
Location: France (Bar Le Duc)
Device: 2 Kobo glo, iMac, iphone, ipad
iOS and Calibre 3

Hello, I return in the forum to see the evolutions of Calibre and / or its plugins for a reading on :
  • iPad, iPhone and software that once seemed promising (Marvin (3 apps)).
  • 2 old kobo glo I can't update, and a David4 plugin that I have a lot of trouble understanding.

A summary would be very useful for me because of my French language.
  1. I realize the multiplicity of plug-ins and the amazing disappearance of the ones I had already installed and sometimes used before version 3 of calibre.
  2. Unfortunately, I do not have the skills of a developer.
  3. Is a big donation @DavidGoyal redistributed to plugin authors?
  4. Where to find a group dedicated to the translations of some useful plugins
Frenchdummy is offline   Reply With Quote
Old 06-19-2017, 10:55 AM   #605
davidfor
Grand Sorcerer
davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.
 
Posts: 12,446
Karma: 18869148
Join Date: Jul 2011
Location: Sydney, Australia
Device: Kobo: Touch, Glo, Aura H2O, Glo HD
Quote:
Originally Posted by Frenchdummy View Post
  • 2 old kobo glo I can't update, and a David4 plugin that I have a lot of trouble understanding.
If you have problems with a Kobo device, ask about them in the Kobo forum. If you have a problem with a plugin, ask in the thread for the plugin.
davidfor is offline   Reply With Quote
Advert
Old 06-22-2017, 01:17 AM   #606
daysparrow
Junior Member
daysparrow began at the beginning.
 
daysparrow's Avatar
 
Posts: 3
Karma: 10
Join Date: Dec 2012
Location: Austin, TX
Device: Kindle Kybrd, Asus Trnsfrmr TF700T: Moon+ Rdr Pro, & iPad Mini: Marvin
I just updated to Calibre 3.0.0 for MacOS. I use the MarvinXD and iOS Reader plugins. Once I updated Calibre and opened the program, a msg popped up informing me that MarvinXD required the iOS Reader plugin (which had previously been installed and configured) in order to work. So I went to the plugin menu and attempted to install iOS Reader applications again and got the following error which it told me to paste here.

Quote:
calibre, version 3.0.0
ERROR: Install plugin failed: A problem occurred while installing this plugin. This plugin will now be uninstalled. Please post the error message in details below into the forum thread for this plugin and restart calibre.

Traceback (most recent call last):
File "site-packages/calibre/gui2/dialogs/plugin_updater.py", line 726, in _install_clicked
File "site-packages/calibre/customize/ui.py", line 464, in add_plugin
File "site-packages/calibre/customize/ui.py", line 668, in initialize_plugin
InvalidPlugin: Initialization of plugin Traceback (most recent call last):
File "site-packages/calibre/customize/ui.py", line 662, in initialize_plugin
File "calibre_plugins.ios_reader_apps.__init__", line 898, in initialize
File "site-packages/calibre/devices/idevice/libimobiledevice.py", line 214, in __init__
File "site-packages/calibre/devices/idevice/libimobiledevice.py", line 460, in load_library
File "lib/python2.7/ctypes/__init__.py", line 440, in LoadLibrary
File "lib/python2.7/ctypes/__init__.py", line 362, in __init__
OSError: dlopen(/Applications/calibre.app/Contents/Frameworks/libimobiledevice.5.dylib, 6): image not found
failed with traceback:
Traceback (most recent call last):
File "site-packages/calibre/customize/ui.py", line 662, in initialize_plugin
File "calibre_plugins.ios_reader_apps.__init__", line 898, in initialize
File "site-packages/calibre/devices/idevice/libimobiledevice.py", line 214, in __init__
File "site-packages/calibre/devices/idevice/libimobiledevice.py", line 460, in load_library
File "lib/python2.7/ctypes/__init__.py", line 440, in LoadLibrary
File "lib/python2.7/ctypes/__init__.py", line 362, in __init__
OSError: dlopen(/Applications/calibre.app/Contents/Frameworks/libimobiledevice.5.dylib, 6): image not found
Please advise. Thank you.
daysparrow is offline   Reply With Quote
Old 06-22-2017, 02:39 AM   #607
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 31,135
Karma: 7777777
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
That particular error will be fixed in the next release, but, as far as I know the MArvin and IOS plugins stopepd working a long time ago, when Apple closed up access to its devices. You should just uninstall those plugins.
kovidgoyal is online now   Reply With Quote
Old 07-03-2017, 02:04 PM   #608
daysparrow
Junior Member
daysparrow began at the beginning.
 
daysparrow's Avatar
 
Posts: 3
Karma: 10
Join Date: Dec 2012
Location: Austin, TX
Device: Kindle Kybrd, Asus Trnsfrmr TF700T: Moon+ Rdr Pro, & iPad Mini: Marvin
Quote:
Originally Posted by kovidgoyal View Post
That particular error will be fixed in the next release, but, as far as I know the MArvin and IOS plugins stopepd working a long time ago, when Apple closed up access to its devices. You should just uninstall those plugins.
Thanks. I've gone back to using the content server to download books to Marvin.
daysparrow is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[Device Plugin] iOS reader applications (closed) GRiker Plugins 182 06-15-2014 05:00 PM
iOS Reader Application Plugin Guinan Plugins 1 03-30-2014 08:18 PM
Getting Books onto your iOS device with iTunes kyteflyer Apple Devices 9 01-30-2013 02:50 PM
[Device Plugin] Kindle 2, 3, 4, Touch Device Interface MBP Update Mod cryzed Plugins 7 10-28-2012 04:58 PM


All times are GMT -4. The time now is 01:31 PM.


MobileRead.com is a privately owned, operated and funded community.