Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 08-26-2018, 09:57 AM   #1
frankly
Junior Member
frankly began at the beginning.
 
Posts: 3
Karma: 10
Join Date: Aug 2018
Device: Kindle DX
How to disable Calibre autostart on Kindle plugin

Hello,
I am running Calibre on Linux (Mint 18.3). Whenever I plug my Kindle into my computer, Calibre starts automatically. This seems to be the default behaviour. Now, I find that rather annoying, as I often plug my Kindle in simply to recharge it. So I'd like to disable this autostart feature. As this is very basic functionality, there should be an option somewhere in Preferences to turn this setting off. However, I haven't been able to find it. Searching the Internet has also turned up nothing.
So I hope someone here knows the answer. How can I keep Calibre from autostarting on plugin events? Help would be appreciated.
Thanks in advance
frankly
frankly is offline   Reply With Quote
Old 08-26-2018, 12:38 PM   #2
theducks
Well trained by Cats
theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.
 
theducks's Avatar
 
Posts: 22,244
Karma: 22136456
Join Date: Aug 2009
Location: (The original) Silicon Valley, USA
Device: K4NT, Galaxy Tab A
You could set Calibre to IGNORE the device (can be done when attached),
BUT
that is rather severe, if you want to later use Calibre with that device

If Calibre is not running, there is no prob.
If Calibre is running, simply use Eject device on the Device Icon. (I think Calibre ignore a second devices attempt to connect, if another is in use)

PC USB ports are current limited (500mA). A real charger is faster and almost required for many Tablet style devices.
theducks is offline   Reply With Quote
Old 08-26-2018, 02:35 PM   #3
frankly
Junior Member
frankly began at the beginning.
 
Posts: 3
Karma: 10
Join Date: Aug 2018
Device: Kindle DX
Hey theducks,
thanks for the answer. Having Calibre ignore my Kindle is not a solution, though. I really only use Calibre to organize my Kindle collection. I just don't want it to start automatically every time I plug the thing in. Usually, this is no problem. The program I use to download pictures off my camera, does also autostart when I plug the camera in. But I can easily disable this behaviour in the preferences, if I want too. I just thought, there must be a similarly simple solution in Calibre, where you can just toggle autostart on or off inside the settings.
Btw, you're probably right about charging devices over the computer. But I really don't mind, if it takes a little bit longer. I have the thing running a lot of the time anyway. So I simply plug my Kindle into an empty USB slot and let it recharge while I'm working.
Anyway, thx for the advice.
frankly is offline   Reply With Quote
Old 08-26-2018, 09:08 PM   #4
davidfor
Grand Sorcerer
davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.davidfor ought to be getting tired of karma fortunes by now.
 
Posts: 15,459
Karma: 25374390
Join Date: Jul 2011
Location: Sydney, Australia
Device: Kobo:Touch,Glo,Aura H2O,Glo HD,Aura ONE,Clara HD,Forma;tolino epos
@Frankly: This isn't something that calibre is doing. When you install calibre it does not set itself up as the default action for when the device is inserted. If this is happening, then it is something in the OS. I have no idea how this would be configured in Mint.
davidfor is online now   Reply With Quote
Old 08-26-2018, 09:42 PM   #5
BetterRed
null operator
BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.
 
Posts: 11,266
Karma: 10572868
Join Date: Mar 2012
Location: Sydney Australia
Device: none
If the OP is running the Nemo file manager there's a setting in Preferences->Behaviour->Media Handling that may need disabling/changing, other file wranglers will have something similar. They're the equivalent of the dreaded Windows AutoPlay settings.

BR
BetterRed is offline   Reply With Quote
Old 08-26-2018, 11:02 PM   #6
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 33,597
Karma: 10209526
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
calibre most definitely does not askthe OS to start it on device plugin. If your OS is doing that, then something else told it to do so, you will need to track that down and disable it.
kovidgoyal is online now   Reply With Quote
Old 08-27-2018, 01:23 AM   #7
theducks
Well trained by Cats
theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.
 
theducks's Avatar
 
Posts: 22,244
Karma: 22136456
Join Date: Aug 2009
Location: (The original) Silicon Valley, USA
Device: K4NT, Galaxy Tab A
Sorry, I misunderstood your problem. I thought Calibre was already RUNNING
Kovid is correct. It has to be the OS got told what to do upon connecting a device.
theducks is offline   Reply With Quote
Old 08-30-2018, 06:17 PM   #8
frankly
Junior Member
frankly began at the beginning.
 
Posts: 3
Karma: 10
Join Date: Aug 2018
Device: Kindle DX
BetterRed,
your tip actually did the trick. I knew about Nemo's Media Handling setting, of course. But I somehow never noticed that you could also configure the behaviour for ebook readers in there. I just switched from "Open with calibre" to "Do nothing" and it worked as I wanted.
So thanks again everyone in the thread for taking the time, problem solved!
frankly is offline   Reply With Quote
Reply

Tags
calibre, kindle, linux

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kindle KDK PNG support + autostart? phatmanace Kindle Developer's Corner 2 09-14-2013 03:52 PM
What is the latest Kindle Plugin for Calibre? maurices5000 Kindle Formats 1 08-17-2013 01:16 PM
KIndle collections Calibre plugin atp Library Management 0 02-21-2012 08:26 PM
disable builtin plugin soleilos Plugins 3 08-13-2011 10:49 AM
Ubuntu: Autostart Calibre if connecting Kindle SteffenH Calibre 0 09-05-2010 05:22 PM


All times are GMT -4. The time now is 12:17 AM.


MobileRead.com is a privately owned, operated and funded community.