Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Server

Notices

Reply
 
Thread Tools Search this Thread
Old 05-04-2024, 06:16 PM   #1
iofjueahuhfexx
Junior Member
iofjueahuhfexx began at the beginning.
 
Posts: 3
Karma: 10
Join Date: May 2024
Device: none
Instalation and setup dificulties

when installing on ubuntu linux server i keep geting this error, is there a way for me to fix this issue, I also have no idea on how to set calibre up after it has been correctly installed

Failed to import PyQt module: PyQt6.QtWidgets with error: libGLX.so.0: cannot open shared object file: No such file or directory

Traceback (most recent call last):

File "runpy.py", line 198, in _run_module_as_main

File "runpy.py", line 88, in _run_code

File "site.py", line 47, in <module>

File "site.py", line 43, in main

File "calibre/gui_launch.py", line 73, in calibre

File "bypy-importer.py", line 279, in exec_module

File "calibre/gui2/__init__.py", line 15, in <module>

ImportError: cannot import name 'QApplication' from 'qt.core' (/opt/calibre/lib/calibre-extensions/python-lib.bypy.frozen/qt/core.pyc)
iofjueahuhfexx is offline   Reply With Quote
Old 05-04-2024, 09:08 PM   #2
DNSB
Bibliophagist
DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.
 
DNSB's Avatar
 
Posts: 36,990
Karma: 148318166
Join Date: Jul 2010
Location: Vancouver
Device: Kobo Sage, Libra Colour, Lenovo M8 FHD, Paperwhite 4, Tolino epos
Are you installing calibre from the command line found at calibre - Download for Linux or are you using a repository or FlatPak version?
DNSB is offline   Reply With Quote
Advert
Old 05-04-2024, 09:10 PM   #3
iofjueahuhfexx
Junior Member
iofjueahuhfexx began at the beginning.
 
Posts: 3
Karma: 10
Join Date: May 2024
Device: none
I am installing calibre from the download for Linux page
iofjueahuhfexx is offline   Reply With Quote
Old 05-04-2024, 10:06 PM   #4
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 44,034
Karma: 22669822
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
You are missing libglx read the first line of the error message you posted
kovidgoyal is offline   Reply With Quote
Old 05-05-2024, 08:26 AM   #5
iofjueahuhfexx
Junior Member
iofjueahuhfexx began at the beginning.
 
Posts: 3
Karma: 10
Join Date: May 2024
Device: none
I fixed the libGLX.s error but i now have these errors


qt.qpa.plugin: From 6.5.0, xcb-cursor0 or libxcb-cursor0 is needed to load the Qt xcb platform plugin.
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: vnc, wayland-egl, offscreen, minimal, eglfs, wayland, linuxfb, vkkhrdisplay, minimalegl, xcb.

Aborted (core dumped)
iofjueahuhfexx is offline   Reply With Quote
Advert
Old 05-05-2024, 12:25 PM   #6
DNSB
Bibliophagist
DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.DNSB ought to be getting tired of karma fortunes by now.
 
DNSB's Avatar
 
Posts: 36,990
Karma: 148318166
Join Date: Jul 2010
Location: Vancouver
Device: Kobo Sage, Libra Colour, Lenovo M8 FHD, Paperwhite 4, Tolino epos
Looking at the calibre Linux install page, there is a item under notes:

Quote:
If you get an error Could not load the Qt platform plugin xcb you are missing some needed X11-XCB libraries, such as libxcb-cursor0 or libxcb-xinerama0, for details see here.
Where here is is a link to a Mobileread thread: Calibre 5.0.1 Could not load the Qt platform plugin "xcb" FIXED
DNSB is offline   Reply With Quote
Old 06-17-2024, 12:35 AM   #7
xeroiv
Junior Member
xeroiv began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Jun 2024
Device: none
Quote:
Originally Posted by iofjueahuhfexx View Post
I fixed the libGLX.s error but i now have these errors


qt.qpa.plugin: From 6.5.0, xcb-cursor0 or libxcb-cursor0 is needed to load the Qt xcb platform plugin.
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: vnc, wayland-egl, offscreen, minimal, eglfs, wayland, linuxfb, vkkhrdisplay, minimalegl, xcb.

Aborted (core dumped)
I am having trouble getting past this point in the install as well. When I run the python installer script it has a xdg-desktop-menu error that no writable system menu directory is found. I have a suspicion that this is due to trying to run the installer as root, but wanted some advice on how to proceed.
xeroiv is offline   Reply With Quote
Old 06-17-2024, 06:22 PM   #8
dunhill
Guru
dunhill ought to be getting tired of karma fortunes by now.dunhill ought to be getting tired of karma fortunes by now.dunhill ought to be getting tired of karma fortunes by now.dunhill ought to be getting tired of karma fortunes by now.dunhill ought to be getting tired of karma fortunes by now.dunhill ought to be getting tired of karma fortunes by now.dunhill ought to be getting tired of karma fortunes by now.dunhill ought to be getting tired of karma fortunes by now.dunhill ought to be getting tired of karma fortunes by now.dunhill ought to be getting tired of karma fortunes by now.dunhill ought to be getting tired of karma fortunes by now.
 
dunhill's Avatar
 
Posts: 735
Karma: 228142
Join Date: Sep 2017
Location: Argentina
Device: moon+ reader, kindle paperwhite
Quote:
Originally Posted by iofjueahuhfexx View Post
I fixed the libGLX.s error but i now have these errors


qt.qpa.plugin: From 6.5.0, xcb-cursor0 or libxcb-cursor0 is needed to load the Qt xcb platform plugin.
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: vnc, wayland-egl, offscreen, minimal, eglfs, wayland, linuxfb, vkkhrdisplay, minimalegl, xcb.

Aborted (core dumped)

sudo apt install libxcb-cursor0
dunhill is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
A problem after "Find history" plugin instalation ichnilatis KOReader 3 09-19-2021 11:20 AM
Instalation of additional keyboard ichnilatis PocketBook 2 10-08-2020 07:30 AM
Plugin doesn't finish instalation kiaraSe Calibre 21 04-13-2018 09:15 PM
help with new Calibre instalation BAD18 Devices 1 12-29-2015 09:21 PM
PRS-950 Reader Library instalation, mp3 player, and folder questions grogthegreat Sony Reader 21 01-01-2011 11:34 AM


All times are GMT -4. The time now is 09:10 PM.


MobileRead.com is a privately owned, operated and funded community.