Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Amazon Kindle

Notices

Reply
 
Thread Tools Search this Thread
Old 03-14-2023, 07:08 AM   #1
luser
Junior Member
luser began at the beginning.
 
Posts: 2
Karma: 10
Join Date: May 2010
Device: Elonex 511EB
PW5 stuck on "Power On" initial screen

Hello all! I thought I was incredibly lucky to find a PW5 at a car boot sale this past weekend very cheaply; the seller told me the screen was frozen. Having experienced this before, I thought it would be an easy fix... alas, not so. The device is frozen on the initial "Power On" screen the device ships with.

So far I have tried the following with no success:
  • 40 second and 5 minute resets (unplugged, plugged into the wall, plugged into computer)
  • Leaving the Kindle to charge for 3 days undisturbed
  • Plugging the Kindle into a variety of computers with numerous data cables (Windows 11 and MacOS)
  • Tried the various USB driver tricks to get the PC to recognise the Kindle (reinstalling app, reassigning drive letter, turning off USB suspend)

Two things currently stump me: the behaviour when resetting the Kindle and what happens when connecting the Kindle to my computer.

When I am resetting the Kindle the backlight turns on as though it is working, the eInk display does not change, and the charge light alternates two long green flashes and five short orange flashes.

When the Kindle is connected to my PC, a greyed out drive letter can be seen and clicking on it invites me to insert a disk into my USB device. Windows Device Manager sees the Kindle as both a storage and portable device, and Disk Manager sees the Kindle as a device with zero partitions and 0MB of space. MacOS does not detect my Kindle when plugged in.

I am not averse to opening the device up and tinkering but I was wondering if there is anything else I could try that is non-invasive first. Has anyone else experienced this issue?
luser is offline   Reply With Quote
Reply

Tags
bricked, pw5

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kindle Voyage can't proceed past the initial "tree" screen njt Kindle Developer's Corner 9 05-10-2016 12:34 PM
M92 stuck on "Low Battery, Please Charge" screen FinancialWar Onyx Boox 30 09-30-2012 03:48 PM
Library doesn't work, eInk side stuck with "Home" screen andr2k enTourage eDGe 4 08-04-2012 08:37 AM
Touch Nook STR stuck on "Rooted Forever" screen rosy621 Nook Developer's Corner 18 01-29-2012 06:16 AM


All times are GMT -4. The time now is 06:48 PM.


MobileRead.com is a privately owned, operated and funded community.