Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 12-18-2017, 01:40 PM   #1
RobertBB
Junior Member
RobertBB began at the beginning.
 
RobertBB's Avatar
 
Posts: 3
Karma: 10
Join Date: Dec 2017
Device: Android Phone
Standalone server stopped working after latest update

Hi.
For many years now I have run the standalone content server as a service using NSSM, so the server starts every time my Windows Server starts.
Then, after updating to v.3.14, the service starts the content server, but I can no longer access it from my laptop. This is on the same internal network.
If I stop the service, and start the server from within Calibre, everything works great, but as soon as I stop it, and start the standalone server, the web page is no longer working.
What has happened to the Standalone Content Server after the update?
The name of the exe is the same as it has always been, so why has it suddenly stopped working?
Hope someone can help me.

Regards
RobertBB
RobertBB is offline   Reply With Quote
Old 12-18-2017, 03:27 PM   #2
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 33,749
Karma: 10215946
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
https://calibre-ebook.com/new-in/twelve

All the command line arguments to calibre-server.exe have changed. https://manual.calibre-ebook.com/gen...re-server.html
kovidgoyal is offline   Reply With Quote
Advert
Old 12-18-2017, 05:11 PM   #3
RobertBB
Junior Member
RobertBB began at the beginning.
 
RobertBB's Avatar
 
Posts: 3
Karma: 10
Join Date: Dec 2017
Device: Android Phone
Thanks for your reply.
I actually found out what the problem is, while I waited for a reply
Looks to me that the new standalone server is not reading the settings from the server settings inside calibre, so when I set the port to be 8081, the standalone server still listen on 8080.
So all I need to know now is how to make the standalone content server listen on port 8081?
As I said, I use nssm to make the standalone server start as a service, so if you have any tips for me it would be highly appreciated.
RobertBB is offline   Reply With Quote
Old 12-18-2017, 05:23 PM   #4
PeterT
Grand Sorcerer
PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.
 
PeterT's Avatar
 
Posts: 10,395
Karma: 60950013
Join Date: Nov 2007
Location: Toronto
Device: Nexus 7, Clara, Touch, Tolino EPOS
As the page that Kovid linked to says, --port specifies the port to listen on.
PeterT is offline   Reply With Quote
Old 12-18-2017, 05:43 PM   #5
RobertBB
Junior Member
RobertBB began at the beginning.
 
RobertBB's Avatar
 
Posts: 3
Karma: 10
Join Date: Dec 2017
Device: Android Phone
Thanks PeterT that did the trick. I totally overlooked the --port in the list. Guess I'm getting old
I put the --port 8081 in the arguments entry in NSSM, and now everything is back to normal.
Thanks again :-)
RobertBB is offline   Reply With Quote
Advert
Reply

Tags
content server

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Content Server Stopped Working Amalthia Calibre 4 10-20-2013 05:01 AM
Metadata update not working since latest update... Rickkins Library Management 4 10-04-2011 04:12 AM
Content server stopped working on Stanza on my iPhone mudsharkbytes Devices 20 04-16-2011 05:26 AM
e-reader input stopped working after latest update roddemp enTourage Archive 3 11-26-2010 03:19 PM
Fetch Metadata from Server function stopped working Lesley8844 Calibre 16 09-17-2010 11:22 AM


All times are GMT -4. The time now is 03:54 PM.


MobileRead.com is a privately owned, operated and funded community.