Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Sigil > Plugins

Notices

Reply
 
Thread Tools Search this Thread
Old 06-22-2016, 05:01 AM   #16
Doitsu
Wizard
Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.
 
Doitsu's Avatar
 
Posts: 4,350
Karma: 14316543
Join Date: Dec 2010
Device: Kindle PW2
I attached a new version with updated configuration and stylesheet files provided by roger64.
To take full advantage of the stylesheet you'll need to download and embed the Linux Libertine fonts.
Of course, you can replace both files with your own customized versions.

BTW, the new version allows you to embed files, e.g. fonts or images files. These files need to be copied to the plugin resources folder. (You can also define a different folder via the resource_dir plugin preference settings.)

The following plugin preference values can set:

Code:
{
  "add_resources": true,
  "resource_dir": "C:/Resources",
  "output_format": "epub3",
  "ibooks_xml": true,
  "initialdir": "C:/Users/User/Downloads"
}
(Even though this plugin is bundled with the epub3-enabled Writer2LaTeX 1.5.2 alpha version, you can of course replace the .jar file with the stable version. Obviously, you won't be able to generate ePub3 files with it.)

BTW, if you use the "output_format": "epub3", option, you'll get the following epubcheck warning:

Code:
WARNING(HTM-014a): XHTML Content Document file name 'OEBPS/Text/chapter.html' should have the extension '.xhtml'.
Simply select all .html files in the Book Browser and rename them to .xhtml.

Technical note: If you don't use the bundled interpreter, you'll need to install the bs4 and lxml Python libraries.
Doitsu is offline   Reply With Quote
Old 03-12-2018, 09:32 AM   #17
Doitsu
Wizard
Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.
 
Doitsu's Avatar
 
Posts: 4,350
Karma: 14316543
Join Date: Dec 2010
Device: Kindle PW2
Since the Writer2LaTeX author has released a new beta version, I've updated the plugin.
(Unless you use the plugin to generate epub3 files, you can ignore this update, because it mostly fixes epub3 bugs and some bugs related to output formats other than epub2.)
Doitsu is offline   Reply With Quote
Advert
Old 04-21-2018, 11:33 PM   #18
manon123
Member
manon123 began at the beginning.
 
Posts: 18
Karma: 10
Join Date: Nov 2014
Location: Belgium
Device: Kobo glo
I can't use it.
I've some errors with Python.
I tryed python 3 and 3.6 : nothing to do, always the same error

Last edited by manon123; 04-21-2018 at 11:37 PM.
manon123 is offline   Reply With Quote
Old 04-22-2018, 03:20 AM   #19
Doitsu
Wizard
Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.
 
Doitsu's Avatar
 
Posts: 4,350
Karma: 14316543
Join Date: Dec 2010
Device: Kindle PW2
Quote:
Originally Posted by manon123 View Post
I can't use it.
I've some errors with Python.
1. What's your Linux distribution?
2. Did you build Sigil from source or did you install an Ubuntu/Debian package?

It looks like your system is missing the Python Tk library, which should have been automatically installed with Sigil.
If you have a Ubuntu-based distro, you'll need to install python3-tk. You also might want to check that the following Ubuntu packages are installed:

python3-pyqt5
python3-lxml
python-bs4
Doitsu is offline   Reply With Quote
Old 04-22-2018, 07:51 AM   #20
manon123
Member
manon123 began at the beginning.
 
Posts: 18
Karma: 10
Join Date: Nov 2014
Location: Belgium
Device: Kobo glo
Hi Doitsu,

My Linux Distribution in Archlinux.
I've installed Sigil from the AUR repository (Sigil is'nt present in the repositories of Archlinux).

In Arch repositories, python3-pyqt5, python3-lxml, python-bs4 doesn't exist.
Yaourt -Ss give me back : nothing.

But, I've found it in the Archlinux's Wiki : the library is simply named : tk

So, with a
Code:
sudo pacman -S tk
, my problem is resolved.

Sorry for my English, I don't speak it fluently

Thank you for your answer.

Last edited by manon123; 04-22-2018 at 07:56 AM.
manon123 is offline   Reply With Quote
Advert
Old 04-22-2018, 10:11 AM   #21
DiapDealer
Grand Sorcerer
DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.
 
DiapDealer's Avatar
 
Posts: 19,361
Karma: 99455064
Join Date: Jan 2010
Device: Nexus 7, Kindle Fire HD
For the record: Sigil is definitely available in the standard Arch repos. It's in Community.
https://www.archlinux.org/packages/c.../x86_64/sigil/

You may also want to install python-pyqt5 from Arch Extra. More and more Sigil plugins make use of PyQt5.

Python3 is the default on Arch. So its various packages are just python-*, not python3-*.

Last edited by DiapDealer; 04-22-2018 at 10:13 AM.
DiapDealer is online now   Reply With Quote
Old 04-23-2018, 01:32 PM   #22
manon123
Member
manon123 began at the beginning.
 
Posts: 18
Karma: 10
Join Date: Nov 2014
Location: Belgium
Device: Kobo glo
Thanks a lot for your help.
Everything is working fine now. Indeed, looking for all the dependencies of the package, I was able to install the two missing packages.
manon123 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[FileType Plugin] YVES Bible Plugin ClashTheBunny Plugins 24 07-21-2018 11:11 AM
[GUI Plugin] KindleUnpack - The Plugin DiapDealer Plugins 412 04-24-2018 07:07 PM
Plugin not customizable: Plugin: HTML Output does not need customization flyingfoxlee Conversion 2 02-24-2012 03:24 AM
[GUI Plugin] Plugin Updater **Deprecated** kiwidude Plugins 159 06-19-2011 01:27 PM
New Plugin Type Idea: Library Plugin cgranade Plugins 3 09-15-2010 01:11 PM


All times are GMT -4. The time now is 11:18 PM.


MobileRead.com is a privately owned, operated and funded community.