Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Android Devices > enTourage eDGe > enTourage Archive


Thread Tools Search this Thread
Old 04-27-2011, 12:01 PM   #1
Edge User
Terminal Emulator oddity

I decided to reward myself for two smoke-free weeks with an hour of playing with my new Pocket Edge (running Ermine) this morning. As I'm a sort of linux-y geek, I started by browsing through the file system using the Terminal Emulator (Dev Tools -> Terminal Emulator) with an eye toward entering 'busybox ls -alR > /MEDIA/USB0/some-file-name" to make a full file system listing that I could transfer to my PC.

It took me a while to find the "<", "|", and ">" keys on the soft keyboard, but eventually I did. What surprised me was that I couldn't manage to input any digits at all. The digits worked fine in Notepad, so it seems to be a Terminal Emulator "feature."

I next tried a USB keyboard. Most of its keys worked as expected, and entering digits into Terminal Emulator worked fine. Those pesky "<" and ">" characters were not on top of the ',' and '.' keys -- they've moved to ALT-B and ALT-N respectively. Surprisingly, the HOME key took me to the home screen and both the END and F4 keys rotated the screen clockwise (skipping the upside-down orientation) with each press. The F1 key gave me the application menu and the F3 key took me to the Contacts app.

So ... I can type the command I want with a USB keyboard, but would have to disconnect it and shove in a USB drive really fast if I want it to work . . .

Thus I have a question for you all: Can anybody get numbers "typed" on the soft keyboard accepted by Terminal Emulator? If so, are you using a big Edge? a Pocket? Running Ermine? Dingo? If not, do you care?

Thanks for taking the time to check.
Old 04-27-2011, 01:17 PM   #2
Edge User
Confirmed on my PE (ermine). No numbers on the soft keyboard. Couldn't get it to switch to another input method either (I've got DioPen and Grafitti on mine)

Originally Posted by twichy View Post
So ... I can type the command I want with a USB keyboard, but would have to disconnect it and shove in a USB drive really fast if I want it to work . . .
Umm... unless you're actually The Flash's secret identity, you may want to send that file to either of the SD cards and copy it to the USB drive later.....
Old 04-27-2011, 02:06 PM   #3
Edge User
I installed Better Terminal Emulator Magic from AndAppStore, and that worked with the numeric keys fine.
Old 04-27-2011, 02:50 PM   #4
Edge User
Twichy, congratulations on 2 smoke-free weeks!!

That is really hard -- I know! I had to move away from everyone and everything I associated with cigarettes in order to finally, completely, quit. And many many years later I still sometimes have cravings. Most of the time, though, the smell sickens me now, so that helps!

Excellent reward system you've got for yourself!!
Old 04-27-2011, 03:00 PM   #5
Edge User
Interestingly, Better Terminal Emulator Magic has a *different* quirk. I was not able to get the enter key to work from the alpha portion of the keyboard, but it did work when I switched into the numeric!
Old 05-01-2011, 11:51 AM   #6
Edge User
Thanks for looking into this for me, folks. I'll have to investigate some of the alternate keyboards on the market in a couple of weeks -- good to know that at least one will (quirkily) work.

Oh, and @5thWiggle, seems that Terminal app doesn't have permission to write to /sdcard (or any other place in on-board memory that I could find). I don't have a mini-sd plugged in yet, so I don't know about that. I ran out of time while trying to convince Terminal to talk to /media/USB0.

@Filark -- thanks for your best wishes. Having a PE waiting for me is a good motivator.

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DR800 rxvt (terminal emulator) for DR800 GregorRichards iRex 13 01-04-2011 06:56 AM
Oddity Gunnerp245 Calibre 8 11-14-2010 11:25 AM
[Libre] Audiobook Oddity Xanthe Ectaco jetBook 4 05-12-2010 10:03 PM
Page number oddity julia103 Sony Reader 4 02-11-2009 10:49 PM

All times are GMT -4. The time now is 07:54 PM. is a privately owned, operated and funded community.