Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Plugins

Notices

Reply
 
Thread Tools Search this Thread
Old 12-14-2017, 09:24 AM   #16
DaltonST
Deviser
DaltonST is the One.DaltonST is the One.DaltonST is the One.DaltonST is the One.DaltonST is the One.DaltonST is the One.DaltonST is the One.DaltonST is the One.DaltonST is the One.DaltonST is the One.DaltonST is the One.
 
DaltonST's Avatar
 
Posts: 1,508
Karma: 101298
Join Date: Aug 2013
Location: Texas
Device: 8" Win10 Tablet w/Calibre64
Quote:
Originally Posted by Gary_M_Mugford View Post
You're not wrong. I surrender. Thanks for taking the time to create this. GM

NOTE: And we both know Kovid will respond somewhat ... negatively ... to this request given it's ... lack of common need.

It is a common need as of 2016 when he added "plain text" and "short text" as "virtual datatypes" to Calibre. However, he still thinks of them just as "comments", which is the "official" datatype. That is one of the consequences of not using 3d-normal form database design with Custom Columns. Further, his previously stated logic for not adding them to Bulk Metadata Edit (BME) conflicts with having INT, FLOAT and BOOL datatypes supported. His logic of not supporting "plain text" and "short text" is that they are "book dependent". Guess what; so are INT, FLOAT and BOOL. If he is being intellectually honest, he should not allow #pages or #read_already to be set simultaneously for a group of books in BME. However, he has the final say in the matter. Hence, my GUI Tool.



DaltonST
DaltonST is offline   Reply With Quote
Old 04-26-2019, 12:41 PM   #17
DaltonST
Deviser
DaltonST is the One.DaltonST is the One.DaltonST is the One.DaltonST is the One.DaltonST is the One.DaltonST is the One.DaltonST is the One.DaltonST is the One.DaltonST is the One.DaltonST is the One.DaltonST is the One.
 
DaltonST's Avatar
 
Posts: 1,508
Karma: 101298
Join Date: Aug 2013
Location: Texas
Device: 8" Win10 Tablet w/Calibre64
Version 1.0.1 - Python 3 compatibility.

Version 1.0.1 - 2019-04-26 Python 3 compatibility.

Minimum Calibre version is now 3.41.3. Obviously, upgrade Calibre first.


DaltonST
DaltonST is offline   Reply With Quote
Old 05-01-2019, 10:02 PM   #18
jessfury
Junior Member
jessfury began at the beginning.
 
Posts: 2
Karma: 10
Join Date: May 2019
Device: Samsung Galaxy Tab A
Error with update

This error came up when I was trying to update a plugin.


calibre, version 3.40.1
ERROR: Install plugin failed: A problem occurred while installing this plugin. This plugin will now be uninstalled. Please post the error message in details below into the forum thread for this plugin and restart calibre.

Traceback (most recent call last):
File "site-packages\calibre\gui2\dialogs\plugin_updater.py", line 726, in _install_clicked
File "site-packages\calibre\customize\ui.py", line 472, in add_plugin
File "site-packages\calibre\customize\ui.py", line 61, in load_plugin
File "site-packages\calibre\customize\zipplugin.py", line 220, in load
InvalidPlugin: The plugin at C:\Users\jessf\AppData\Local\Temp\calibre_jut54u\y kkkd2.zip needs a version of calibre >= 3.41.3
jessfury is offline   Reply With Quote
Old 05-01-2019, 10:13 PM   #19
jessfury
Junior Member
jessfury began at the beginning.
 
Posts: 2
Karma: 10
Join Date: May 2019
Device: Samsung Galaxy Tab A
Sorry think it was just taking time to get the new version of Calibre going first.
jessfury is offline   Reply With Quote
Old 05-01-2019, 10:13 PM   #20
TheFlyingBadger
Junior Member
TheFlyingBadger began at the beginning.
 
Posts: 2
Karma: 10
Join Date: Apr 2019
Device: Kindle Paperweight
Quote:
Originally Posted by jessfury View Post
InvalidPlugin: The plugin at C:\Users\jessf\AppData\Local\Temp\calibre_jut54u\y kkkd2.zip needs a version of calibre >= 3.41.3

the clue was in the error message (and the post immediately prior to yours).

Quote:
Originally Posted by DaltonST View Post
Minimum Calibre version is now 3.41.3. Obviously, upgrade Calibre first.

PEBKAC
TheFlyingBadger is offline   Reply With Quote
Reply

Tags
automation, copy to library, library, move to library

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[GUI Plugin] Library Codes DaltonST Plugins 159 07-17-2019 11:56 PM
[GUI Plugin] Consolidate All Library Metadata (CALM) DaltonST Plugins 196 07-08-2019 03:20 PM
[GUI Plugin] KindleUnpack - The Plugin DiapDealer Plugins 412 04-24-2018 06:07 PM
[GUI Plugin] Save Virtual Libraries To Column (GUI) chaley Plugins 8 09-24-2017 09:01 PM
[GUI Plugin] Plugin Updater **Deprecated** kiwidude Plugins 159 06-19-2011 12:27 PM


All times are GMT -4. The time now is 12:12 AM.


MobileRead.com is a privately owned, operated and funded community.