Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Development

Notices

Reply
 
Thread Tools Search this Thread
Old 03-28-2016, 05:04 AM   #1
farcus
Junior Member
farcus began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Mar 2016
Device: Kindle Keyboard
Calibre to support QT 5.6

My linux distro has moved to QT 5.6.0
Since that time Calibre will not run. I believe Calibre requires QT 5.5 or lower.
Are we likely to see an update to Calibre in the near future to support QT 5.6.0?
farcus is offline   Reply With Quote
Old 03-28-2016, 06:32 AM   #2
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 33,724
Karma: 10215826
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
Just use the binary calibre install, it comes with its own Qt.

Although I have to say that I have calibre running on my linux dev machine with Qt 5.6 with no problems. Most likely, your distro maintainers forgot to recompile their calibre package, or they neglected to provide the qt-webkit dependency.

Last edited by kovidgoyal; 03-28-2016 at 06:43 AM.
kovidgoyal is online now   Reply With Quote
Old 03-28-2016, 08:55 AM   #3
eschwartz
Ex-Helpdesk Junkie
eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.
 
eschwartz's Avatar
 
Posts: 19,247
Karma: 83049305
Join Date: Nov 2012
Location: The Beaten Path, USA, Roundworld, This Side of Infinity
Device: Kindle Touch fw5.3.7 (Wifi only)
I run Arch Linux which just moved to Qt 5.6, and my calibre from git was not recompiled (yet) -- so far, no problems on any front.
eschwartz is offline   Reply With Quote
Old 03-28-2016, 09:28 AM   #4
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 33,724
Karma: 10215826
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
For me, the headless plugin required a recompile on arch -- without that, worker processes that use Qt were crashing. I suggest you do the same, to be safe.

Not to mention that Qt designer was crashing on startup -- I had to nuke the various designer plugins in /usr/lib/qt/plugins/designer/ to fix that.

And Qt Assistant appears to be missing the documentation for QWebEngine.

Moving 5.6 from testing seems to have been a bit premature.
kovidgoyal is online now   Reply With Quote
Old 03-28-2016, 11:44 AM   #5
eschwartz
Ex-Helpdesk Junkie
eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.
 
eschwartz's Avatar
 
Posts: 19,247
Karma: 83049305
Join Date: Nov 2012
Location: The Beaten Path, USA, Roundworld, This Side of Infinity
Device: Kindle Touch fw5.3.7 (Wifi only)
"Yet". I actually wanted to do something quickly first, so I was too lazy... I figured worst comes to worst, it will crash and prove I need to recompile it.


Qt Designer crashing -- I saw a thread on the Arch forums: https://bbs.archlinux.org/viewtopic.php?id=210622
Qt5.6 deprecated Qt WebKit *and* Qt Quick 1 -- well, apparently Arch doesn't package qt5-quick1 anymore so when you `pacman -Syu` you end up with an outdated abandoned and incompatible qt5-quick1.
If you need it it is in the AUR now...
eschwartz is offline   Reply With Quote
Old 03-28-2016, 11:46 AM   #6
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 33,724
Karma: 10215826
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
I dont need it I was just lazy about tracking down which plugin was causing designer to crash -- I just nuked them all as I dont need any of them.
kovidgoyal is online now   Reply With Quote
Old 04-04-2016, 02:48 PM   #7
KevinH
Wizard
KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.
 
Posts: 3,108
Karma: 1931746
Join Date: Nov 2009
Device: many
@eschwartz

Have most linux distributions decided to re-insert Qt webkit source into their Qt 5.6 package or just Arch?

And is there a src rpm (old Redhat person here) or some other source package (or spec file or list of patches, etc) that will show exactly how they integrated Qt Webkit source with the official Qt 5.6 source and what build options they have changed?

Also do linux distributions for Qt 5.6 enable mp3 and mp4 support when they build QWebEngine (these are disabled in official Qt source builds and must be re-enabled by passing a build option)?

I may have to start building my own Qt 5.6 (with webkit put back) and was wondering how difficult that is and what build options are typically used by Linux distributions, so we have some idea of what we can expect to work "out-of-the-box" for Linux users of Qt 5.6

Thanks,

KevinH
KevinH is online now   Reply With Quote
Old 04-04-2016, 05:02 PM   #8
eschwartz
Ex-Helpdesk Junkie
eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.
 
eschwartz's Avatar
 
Posts: 19,247
Karma: 83049305
Join Date: Nov 2012
Location: The Beaten Path, USA, Roundworld, This Side of Infinity
Device: Kindle Touch fw5.3.7 (Wifi only)
On the QtWebKit front, it appears every distro is resolved to continue providing it.


Regarding QtWebEngine...
Arch Linux enables use_proprietary_codecs
So does Gentoo via a USE flag -- although Gentoo has not updated Qt to 5.6.0 yet, so I looked at the Qt testing overlays.

On the other hand, it sounds like Debian and Redhat are in a real snit about it.
I cannot find any Debian QtWebEngine package at all, and it doesn't appear Fedora enables use_proprietary_codecs.

Both seem to object because of licensing crap. It reminds me why I prefer Arch Linux in the first place. Debian and their "Social Contract" are far more interested in making some sort of cleverly inscrutable political statement than having working software.
eschwartz is offline   Reply With Quote
Old 04-05-2016, 11:19 AM   #9
jackie_w
Wizard
jackie_w ought to be getting tired of karma fortunes by now.jackie_w ought to be getting tired of karma fortunes by now.jackie_w ought to be getting tired of karma fortunes by now.jackie_w ought to be getting tired of karma fortunes by now.jackie_w ought to be getting tired of karma fortunes by now.jackie_w ought to be getting tired of karma fortunes by now.jackie_w ought to be getting tired of karma fortunes by now.jackie_w ought to be getting tired of karma fortunes by now.jackie_w ought to be getting tired of karma fortunes by now.jackie_w ought to be getting tired of karma fortunes by now.jackie_w ought to be getting tired of karma fortunes by now.
 
Posts: 4,636
Karma: 11226921
Join Date: Sep 2009
Location: UK
Device: Sony:PRS-350, Kobo:Aura6"/H2O/GloHD/KA1/ClaraHD/Forma
Sorry if this is a dumb question ... if "Qt5.6 has deprecated Qt WebKit" does that also mean a knock-on effect in PyQt5?

A couple of my plugins currently use
Code:
from PyQt5.QtWebKitWidgets import QWebView, QWebPage
from PyQt5.QtWebKit import QWebSettings
Will I have to make do without these widgets in the near future? I really hope not.
jackie_w is offline   Reply With Quote
Old 04-05-2016, 11:27 AM   #10
eschwartz
Ex-Helpdesk Junkie
eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.
 
eschwartz's Avatar
 
Posts: 19,247
Karma: 83049305
Join Date: Nov 2012
Location: The Beaten Path, USA, Roundworld, This Side of Infinity
Device: Kindle Touch fw5.3.7 (Wifi only)
If and when the calibre codebase migrates from QtWebKit to QtWebEngine, plugins will need to be updated -- but I expect there will be a notice in the plugins subforum to let people know.

Even though it was deprecated, for now calibre still includes it (and PyQt5 isn't dropping support either ) -- deprecated doesn't mean gone, and core calibre depends on the same functionality.
eschwartz is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DHTML support in calibre? DawnO Calibre 2 09-03-2015 05:12 PM
Calibre support $$ sylvainrodrigue Calibre 24 08-18-2015 08:01 PM
Support for Calibre shabie Calibre 3 02-12-2015 06:15 AM
Calibre support of new Kindle 3 chilady1 Calibre 7 01-15-2011 05:36 PM
Is Calibre going to support Nook? fishhawk101 Calibre 1 12-10-2009 05:38 AM


All times are GMT -4. The time now is 10:38 AM.


MobileRead.com is a privately owned, operated and funded community.