Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Sigil

Notices

Reply
 
Thread Tools Search this Thread
Old 04-05-2017, 05:29 AM   #1
harryg123
Banned
harryg123 began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Jan 2017
Device: calibre, kindle paperwhite
LinuxMint 18.1 How to downgrade Sigil from 9.x to 8.2

The "improvements" in Sigil 9.x are a hindrance for me, such as the modal window for metadata, its new interface, and the current propensity of Sigil to convert all of my existing html entities to actual utf-8 code, and then doubling them in the process. (For example in an existing web page there could be the Pali word pa˝˝ā, which was entered in the original html as "paññ& #257;" Or a left double curly quote as $ldquo; )

These sometimes end up as "pa˝˝˝˝ā" or " ôô ".

Rather than report a bug, I'd just as soon luddite myself back to a version that works just fine for my needs.

Can't find an answer on the net. Now trying to copy the various files in /usr/bin ... in my old Mint 17.0 partition to the partition containing 18.1.

But what's the 'right' way to devolve to a previous version in Linux?

BTW the sigil is now in the repository, but just the wrong version (for me).


-Harry
harryg123 is offline   Reply With Quote
Advert
Old 04-05-2017, 06:38 AM   #2
Doitsu
Wizard
Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.Doitsu ought to be getting tired of karma fortunes by now.
 
Doitsu's Avatar
 
Posts: 3,805
Karma: 9827814
Join Date: Dec 2010
Device: Kindle PW2
Quote:
Originally Posted by harryg123 View Post
[...] the current propensity of Sigil to convert all of my existing html entities to actual utf-8 code[...]
You can define a list of entities to be preserved via:

Edit > Preferences > Preserve Entities

Quote:
Originally Posted by harryg123 View Post
[...] and then doubling them in the process.
That's actually a libxml2 bug. For more information, see this post.
Doitsu is offline   Reply With Quote
Old 04-05-2017, 06:49 AM   #3
DiapDealer
Grand Sorcerer
DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.
 
DiapDealer's Avatar
 
Posts: 16,399
Karma: 85885620
Join Date: Jan 2010
Device: Nexus 7, Kindle Fire HD
As Doitsu mentioned, the entity doubling is a known bug caused by your system's version of libxml2, so there's no need to report it anyway. And downgrading Sigil won't fix the issue on that particular machine (because the problem is not with Sigil). So if you're interested in working around the issue, there's a few ways to go about it:

1) A few threads up (in the sticky section) there's a thread titled "Linux-only libxml2 bug that affects Sigil on newer systems" that contains instructions for installing a patched version of libxml2 to your existing Sigil install.

2) You could also try the unofficial Linux installer package (also found in the sticky thread section). It includes a patched version of libxml2.

3) You could build Sigil yourself. There's instructions in the docs folder of the source that tell how to build your own patched version of libxml2 along side of Sigil.

If you still wish to downgrade Sigil, I could tell you exactly how to remove 0.9.x, but I'd need to know how you installed it in the first place. To get the older version, you'd probably need to grab the source and build it yourself (instructions are in the docs folder).

Last edited by DiapDealer; 04-05-2017 at 06:52 AM.
DiapDealer is offline   Reply With Quote
Reply

Tags
downgrade sigil

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual Boot Linuxmint/XP Library sharing nomad062 Library Management 9 01-07-2017 06:22 PM
Sigil on Nook vs Sigil on Kobo vs Sigil on iBook rosshalde Sigil 12 11-13-2014 09:34 AM
K4 Is it possible to downgrade to f.w. 3.4? Waylander Kindle Developer's Corner 3 11-28-2013 07:09 AM
Touch I Want To Downgrade To 1.9.14 MorganM Kobo Reader 5 08-02-2012 04:15 AM
Downgrade from 1.29 to 1.21 jmseight iRiver Story 1 04-28-2012 10:58 AM


All times are GMT -4. The time now is 09:42 PM.


MobileRead.com is a privately owned, operated and funded community.