Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Devices

Notices

Reply
 
Thread Tools Search this Thread
Old 11-03-2019, 12:01 AM   #1
smikesmith
Junior Member
smikesmith began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Nov 2019
Device: Kindle Fire HD
Installation of 4.2.0

Installing new version over older version on Ubuntu 14.04:

Using python executable: /usr/bin/python3
2019-11-02 22:44:29 URL:https://download.calibre-ebook.com/linux-installer.sh [31888/31888] -> "-" [1]
Installing to /opt/calibre
Downloading tarball signature securely...
Will download and install calibre-4.2.0-x86_64.txz
Downloading calibre-4.2.0-x86_64.txz
100% [================================================== ====================]
Downloaded 100218948 bytes
Checking downloaded file integrity...
Extracting files to /opt/calibre ...
Extracting application files...
Traceback (most recent call last):
File "site.py", line 75, in main
File "site-packages/calibre/__init__.py", line 23, in <module>
File "site-packages/calibre/startup.py", line 204, in <module>
File "site-packages/calibre/utils/icu.py", line 30, in <module>
RuntimeError: Failed to load icu with error: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/calibre/lib/libicui18n.so.64)
Run "calibre" to start calibre


What's it telling me? I can install the previous version and it works again...
smikesmith is offline   Reply With Quote
Old 11-03-2019, 12:24 AM   #2
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 35,452
Karma: 12734961
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
As is noted on the linux download page, you need GLIBC 2.18 or higher
and libstdc++.so.6.0.21 (from gcc 5.4.0) or higher to run calibre. This
is approximately three year old software. If your distro does not
provide it, then you should stick with calibre 3.48 until it does.

Instructions on how to downgrade calibre are on the Linux download page
https://calibre-ebook.com/download_linux
kovidgoyal is offline   Reply With Quote
Reply

Tags
install fails

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Calibre installation gets "Another installation is in progress" davidmichaelkarr Devices 2 12-29-2018 05:28 PM
Moving from Proper Installation to Portable Installation Dfaure Calibre 1 01-02-2017 01:41 PM
Moving from Portable Installation to Proper Installation Klif Calibre 2 08-28-2013 10:34 AM
Welcome/Installation mikelv EPUBReader 1 11-18-2009 11:41 AM
Installation FizzyWater Calibre 5 12-08-2008 04:21 PM


All times are GMT -4. The time now is 09:28 PM.


MobileRead.com is a privately owned, operated and funded community.