Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Amazon Kindle > Kindle Developer's Corner

Notices

Reply
 
Thread Tools Search this Thread
Old 03-06-2020, 02:53 PM   #2776
destinonor
Junior Member
destinonor began at the beginning.
 
Posts: 4
Karma: 10
Join Date: Dec 2014
Device: pocketbook 2
@hius07
many thanks for the hint. I'll try to downgrade to 5.12.3 or force an upgrade with 5.12.4 (current FW version) to see if I get 007 error as well and proceed as on given post. I'll report later here.

nice weekend.
destinonor is offline   Reply With Quote
Old 03-13-2020, 07:18 PM   #2777
Vicente
Junior Member
Vicente began at the beginning.
 
Posts: 7
Karma: 10
Join Date: Aug 2015
Location: Spain
Device: Paperwhite 2
Solved

Quote:
Originally Posted by NiLuJe View Post
Okay, as promised earlier, here's an early winter break present .

PSA: All downloads have been moved to the Snapshots thread! (Under the "K5 JailBreak HotFix" listing).

If you've just successfully ran any iteration of a Factory JailBreak, this is your next step .
Alternatively, if you happened to be running a live, but outdated version of this JailBreak when you got a >= 5.6.x update, this package should get you back on track.

Download the latest package from the Snapshots thread, under the "K5 JailBreak HotFix" listing, and unpack it.
Copy the Update_jailbreak_hotfix_1.15.N_install.bin file to the root directory of your Kindle.

Now, eject & unplug your Kindle, and go to [HOME] -> [MENU] > Settings -> [MENU] > Update Your Kindle. If the update is successful, you're golden. If it fails, it probably means you weren't properly jailbroken before the update, in which case, you're still screwed.

----

If you're coming straight from the 5.6.5 JB or the Factory Downgrade threads and you completely skipped the first post of *this* thread, be aware that on FW >= 5.5.x (i.e., you), using MRPI is REQUIRED to install every other custom packages!
Thank you very much this version "JailBreak-1.16.N-FW-5.x-hotfix.zip" worked for me to fix this error:
"This device is not authorized as a test Kindle by the developer of this item"

Kindle Paperwhite 2 - Firmware 5.6.5


I did a Jailbreak tutorial, in Spanish, with images for this firmware version some time ago, with permission, I put here the link in case anyone needs it.
I hope it is not considered spam
Vicente is offline   Reply With Quote
Advert
Old 03-19-2020, 03:20 PM   #2778
Fstab
Member
Fstab began at the beginning.
 
Posts: 18
Karma: 10
Join Date: Oct 2017
Device: PW
Hi,

Sorry to ask, I have read the README, but don't understand what I need to install.

I am currently using a working jailbreak (kindle-jailbreak-1.14.N) on my Kindle Paperwhite 1 (5th generation), and I want to update it to the last 1.16.N.
My Kindle Paperwhite 1 is currently on FW 5.6.1.1 (I did update my Kindle after applying the jailbreak).

What do I need to install?
- Update_jailbreak_bridge_1.16.N_install.bin
or
- Update_jailbreak_hotfix_1.16.N_install.bin
or
- Something else?

Thank you.
Fstab is offline   Reply With Quote
Old 03-19-2020, 03:24 PM   #2779
NiLuJe
BLAM!
NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.
 
NiLuJe's Avatar
 
Posts: 10,276
Karma: 17931787
Join Date: Jun 2010
Location: Paris, France
Device: Kindle 2i, 3g, 4, 5w, PW & PW2; Kobo H2O & Forma
@Fstab:

Both of those are technically the exact same thing, they only differ in how they can be installed.

* bridge *must* be installed via MRPI
* hotfix *must* be installed via UYK

So, yes, you do want to use one of those. I'd go the MRPI way, because you can batch it with whatever else you want to update.
NiLuJe is offline   Reply With Quote
Old 03-19-2020, 03:42 PM   #2780
hius07
Fanatic
hius07 ought to be getting tired of karma fortunes by now.hius07 ought to be getting tired of karma fortunes by now.hius07 ought to be getting tired of karma fortunes by now.hius07 ought to be getting tired of karma fortunes by now.hius07 ought to be getting tired of karma fortunes by now.hius07 ought to be getting tired of karma fortunes by now.hius07 ought to be getting tired of karma fortunes by now.hius07 ought to be getting tired of karma fortunes by now.hius07 ought to be getting tired of karma fortunes by now.hius07 ought to be getting tired of karma fortunes by now.hius07 ought to be getting tired of karma fortunes by now.
 
Posts: 564
Karma: 1506417
Join Date: Sep 2014
Location: Ukraine
Device: Kindle PW2, PW3
What are the reasons to update working jb? No more firmware updates expected.
hius07 is offline   Reply With Quote
Advert
Old 03-19-2020, 04:18 PM   #2781
Fstab
Member
Fstab began at the beginning.
 
Posts: 18
Karma: 10
Join Date: Oct 2017
Device: PW
Quote:
Originally Posted by NiLuJe View Post
@Fstab:

Both of those are technically the exact same thing, they only differ in how they can be installed.

* bridge *must* be installed via MRPI
* hotfix *must* be installed via UYK

So, yes, you do want to use one of those. I'd go the MRPI way, because you can batch it with whatever else you want to update.
Thanks. And no need to downgrade the firmware version again?

Quote:
Originally Posted by hius07 View Post
What are the reasons to update working jb? No more firmware updates expected.
Not a good reason.
I want to give the Kindle to my son, but I notice an error to open freshly transferred PDF from Calibre. When opening them on the Kindle, I get an error (application error, the chosen application did not start, try again).

I did the jailbreak near three years ago, and I don't remember if there is some specific use, so I wanted to try to update all (jailbreak, KUAL, mrinstaller, koreader) and see if the error is still here. It is not easy for me, because I have really not much time aside from work these days.
Fstab is offline   Reply With Quote
Old 03-19-2020, 04:58 PM   #2782
NiLuJe
BLAM!
NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.
 
NiLuJe's Avatar
 
Posts: 10,276
Karma: 17931787
Join Date: Jun 2010
Location: Paris, France
Device: Kindle 2i, 3g, 4, 5w, PW & PW2; Kobo H2O & Forma
I'd kinda glossed over the model name, but @hius07 is right .

And the JB itself is completely inert, so it's unlikely to affect anything else than what it's designed to, which has nothing to do with how PDFs are handled (or not).
NiLuJe is offline   Reply With Quote
Old 03-20-2020, 01:54 AM   #2783
Fstab
Member
Fstab began at the beginning.
 
Posts: 18
Karma: 10
Join Date: Oct 2017
Device: PW
Ok, noted, thank you.
Fstab is offline   Reply With Quote
Old 05-12-2020, 08:29 AM   #2784
Le_Zouave
Junior Member
Le_Zouave began at the beginning.
 
Posts: 4
Karma: 10
Join Date: May 2020
Device: PW2 (9017)
Hello, I managed to find a PW2 (9017) with FW 5.4.3.2.
I came from https://wiki.mobileread.com/wiki/5_x_Jailbreak
So I did a reset and I launched this jailbreak (it took me some time to realize that it was the content of a zip inside the tar.xz that I had to unzip). So I get the ***jailbreak***.
After that getting mrpi or KUAL fail. For mrpi, when I type ;log mrpi, there is nothing. For KUAL, I have the icon but when I launch I have "The selected application could not be started. Please try again". I rebooted for MKK to be active, but still the same.
So I restarted the whole process, I even downgraded the firmware, even if it's the same FW version, it successfully wrote the initial firmware.
I lauched the jailbreak, got the ***jailbreak***. Then again, mrpi or kual fail. That mean that I can't launch the dummy test too.
Le_Zouave is offline   Reply With Quote
Old 05-12-2020, 12:05 PM   #2785
NiLuJe
BLAM!
NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.
 
NiLuJe's Avatar
 
Posts: 10,276
Karma: 17931787
Join Date: Jun 2010
Location: Paris, France
Device: Kindle 2i, 3g, 4, 5w, PW & PW2; Kobo H2O & Forma
@Le_Zouave: Cross-ref with the sticky, which is likely less convoluted than whatever old stuff is on the Wiki.
NiLuJe is offline   Reply With Quote
Old 05-12-2020, 03:14 PM   #2786
Le_Zouave
Junior Member
Le_Zouave began at the beginning.
 
Posts: 4
Karma: 10
Join Date: May 2020
Device: PW2 (9017)
@NiLuJe, thank you very much, that sticky is clearer.
After a factory downgrade :
- main-htmlviewer.tar.gz do reboot the kindle and create the document "you are jailbroken"
- Merchant.zip do freeze and then create the document "you are jailbroken"
- kindle-5.4-jailbreak.zip show ****jailbroken****, when I reboot for a brief instant I have written JB MKK something at the splash screen.

First two method, there is only two folders, ".active_content_sandbox" and "documents". For the third method, I got new folders, ".active-content-data", "mkk" and "rp".

Still, in all 3 methods, when I put the bin for the hotfix, the update button is greyed out and the bin disapeared when I plug again on my PC.

And both KUAL azw2 fail to launch whatever method I choose.

I made a factory downgrade each time (and ;log mrpi do nothing).

I still wonder, if the "you are jailbroken" document is a proof that I'm jaibroken as I can read it (and cannot be red if I'm not jailbroken) or if it's just a proof that the process did something.
Le_Zouave is offline   Reply With Quote
Old 05-12-2020, 04:33 PM   #2787
NiLuJe
BLAM!
NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.
 
NiLuJe's Avatar
 
Posts: 10,276
Karma: 17931787
Join Date: Jun 2010
Location: Paris, France
Device: Kindle 2i, 3g, 4, 5w, PW & PW2; Kobo H2O & Forma
The hotfix is only packaged for FW 5.5.0+, so all is well.

If you want to make extra-sure stuff is bullet-proof before possibly updating to a non-braindead version, install the *bridge* via MRPI (EDIT: Or possibly UYK on such an old FW).

Last edited by NiLuJe; 05-12-2020 at 04:36 PM.
NiLuJe is offline   Reply With Quote
Old 05-12-2020, 06:06 PM   #2788
Le_Zouave
Junior Member
Le_Zouave began at the beginning.
 
Posts: 4
Karma: 10
Join Date: May 2020
Device: PW2 (9017)
Quote:
Originally Posted by NiLuJe View Post
The hotfix is only packaged for FW 5.5.0+, so all is well.

If you want to make extra-sure stuff is bullet-proof before possibly updating to a non-braindead version, install the *bridge* via MRPI (EDIT: Or possibly UYK on such an old FW).
Thank you very much, it's working now.
So for the bridge, it did the same than the hotfix, so I didn't had any proof that it was installed.
As I was still really afraid to update, I updated to 5.6.5 so I could still downgrade or use the jailbreak that is specific to 5.6.5.
And with great joy, I've seen "bridge+" during reboot after the update.
I put KUAL in document : it work!
I put mrinstaller : kual can launch it and it launched the dummy test.

For information, I did it over the kindle.5.4.jailbreak.zip method (if it can serve other PW2 users).

The fact that you have to use an old FW to jailbreak but the jailbreak can't work on old firmware is very misleading.
Le_Zouave is offline   Reply With Quote
Old 05-12-2020, 06:52 PM   #2789
Le_Zouave
Junior Member
Le_Zouave began at the beginning.
 
Posts: 4
Karma: 10
Join Date: May 2020
Device: PW2 (9017)
Merci beaucoup! it worked!
So I tried to install the bridge as the hotfix and it did the same thing, the update still greyed out and the bin got deleted automaticaly.
So I updated to 5.6.5 so I can still downgrade the firmware or use the jailbreak made for 5.6.5.
And with great joy, I've seen briefly bridge+ at reboot after update.
So I put KUAL azw2 : it worked, then mrinstaller and the dummy test worked!
Le_Zouave is offline   Reply With Quote
Old 05-12-2020, 07:32 PM   #2790
NiLuJe
BLAM!
NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.NiLuJe ought to be getting tired of karma fortunes by now.
 
NiLuJe's Avatar
 
Posts: 10,276
Karma: 17931787
Join Date: Jun 2010
Location: Paris, France
Device: Kindle 2i, 3g, 4, 5w, PW & PW2; Kobo H2O & Forma
Yeah, the PW1 & PW2 are in a bit of a weird place because of the range of FW versions they can run and the various methods available to attack those versions :s.
NiLuJe is offline   Reply With Quote
Reply

Tags
5.1.0, 5.2.0, jailbreak, kindle touch hacks, paperwhite, touch

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kindle Touch 5.0 Jailbreak yifanlu Kindle Developer's Corner 246 01-03-2013 04:57 PM
Is a Kindle Touch for a PaperWhite a good trade? route66 Amazon Kindle 7 09-29-2012 03:21 PM
Kindle Touch with 'Paperwhite' backlit display JoHunt Amazon Kindle 2 08-31-2012 04:33 AM
[Kindle Touch] Firmware 5.1.0 and jailbreak ixtab Kindle Developer's Corner 85 06-28-2012 04:43 AM
How to Kindle touch - jailbreak, screensaver morgun Kindle Developer's Corner 3 05-21-2012 06:39 PM


All times are GMT -4. The time now is 09:31 PM.


MobileRead.com is a privately owned, operated and funded community.