Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Sigil

Notices

Reply
 
Thread Tools Search this Thread
Old 04-07-2024, 06:31 PM   #31
st_albert
Guru
st_albert gives new meaning to the word 'superlative.'st_albert gives new meaning to the word 'superlative.'st_albert gives new meaning to the word 'superlative.'st_albert gives new meaning to the word 'superlative.'st_albert gives new meaning to the word 'superlative.'st_albert gives new meaning to the word 'superlative.'st_albert gives new meaning to the word 'superlative.'st_albert gives new meaning to the word 'superlative.'st_albert gives new meaning to the word 'superlative.'st_albert gives new meaning to the word 'superlative.'st_albert gives new meaning to the word 'superlative.'
 
Posts: 696
Karma: 150000
Join Date: Feb 2010
Device: none
Building Sigil on (old) Kubuntu 23.10 (Mantic Minotaur)

First of all, Thanks to you developers for all the work you do.
I have one comment related to building Sigil on Kubuntu 23.10, which still uses Qt 5.15.10, and might apply to the next version of Kubuntu shortly to be released, 24.04, and then another question requesting your advice. So here goes:

My system is Kubuntu 23.10 (Mantic Minotaur) and the system installed Qt is 5.15.10 as specified above.

When building Sigil 2.1.0, following the instructions in ~/sigil-2.1.0/docs/Building_on_Linux_older.md, as I always do, I executed the instructions to install the required and optional system dependencies. All required and optional packages had already been installed.
However, cmake failed because libqt5svg-dev was not installed. After I installed it, everything worked as expected. So maybe that package should also be listed in the instructions.

Second question: Given that the next upgrade of (K)ubuntu to 24.04, which is a long term support release, still seems to include Qt 5.15.x as far as I know (only looking at pre-Beta builds, but no hint that the final release will be 6.x that I can see), would you recommend going ahead and installing Qt6x, (which is in the repositories now), or just waiting until it finally shows up in the distribution?

Thanks again for your work!
Albert
st_albert is offline   Reply With Quote
Old 04-07-2024, 07:28 PM   #32
KevinH
Sigil Developer
KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.
 
Posts: 7,874
Karma: 5449552
Join Date: Nov 2009
Device: many
Quote:
Originally Posted by st_albert View Post
However, cmake failed because libqt5svg-dev was not installed. After I installed it, everything worked as expected. So maybe that package should also be listed in the instructions.
Yes QtSvg was a very recent addition as a requirement for Sigil. You are right we should add it to the build docs.


Quote:
Second question: Given that the next upgrade of (K)ubuntu to 24.04, which is a long term support release, still seems to include Qt 5.15.x as far as I know (only looking at pre-Beta builds, but no hint that the final release will be 6.x that I can see), would you recommend going ahead and installing Qt6x, (which is in the repositories now), or just waiting until it finally shows up in the distribution?
I personally recommend going with Qt6 if at all possible. As Q5.15 is quite old and fixes are being delayed for over a year, and support for new platforms will not be backported to Qt5.15 anymore.

In addition, I no longer make Qt5 based releases, so it is not tested as much as Qt6 releases.

We think Qt 6.6.2 or Qt 6.6.3 are really quite stable. So if they are available to you, I would go that way.
KevinH is offline   Reply With Quote
Old 04-07-2024, 08:42 PM   #33
DiapDealer
Grand Sorcerer
DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.
 
DiapDealer's Avatar
 
Posts: 27,689
Karma: 196159104
Join Date: Jan 2010
Device: Nexus 7, Kindle Fire HD
Also note in our sticky post in July of last year: https://www.mobileread.com/forums/sh...d.php?t=355274

Quote:
We understand that this change may leave users of older Linux, Mac, and Windows machines behind. So we plan to keep the Sigil and PageEdit source code buildable using Qt5 on older platforms for at least the next year, but leave producing those release binaries up to interested parties.
That one year window is quickly closing. We're obviously not going purposely break Qt5 compatibility come July (and we'll try to fix any simple oversights that accidentally break building with qt5 if we can). But make no mistake: there will come a day when keeping the latest tagged versions of Sigil/PageEdit's code base compatible with both Qt5 and Qt6 will be more trouble than it's worth.
DiapDealer is offline   Reply With Quote
Old 04-08-2024, 04:51 PM   #34
st_albert
Guru
st_albert gives new meaning to the word 'superlative.'st_albert gives new meaning to the word 'superlative.'st_albert gives new meaning to the word 'superlative.'st_albert gives new meaning to the word 'superlative.'st_albert gives new meaning to the word 'superlative.'st_albert gives new meaning to the word 'superlative.'st_albert gives new meaning to the word 'superlative.'st_albert gives new meaning to the word 'superlative.'st_albert gives new meaning to the word 'superlative.'st_albert gives new meaning to the word 'superlative.'st_albert gives new meaning to the word 'superlative.'
 
Posts: 696
Karma: 150000
Join Date: Feb 2010
Device: none
Quote:
Originally Posted by KevinH View Post
I personally recommend going with Qt6 if at all possible. As Q5.15 is quite old and fixes are being delayed for over a year, and support for new platforms will not be backported to Qt5.15 anymore.
Thanks, KevinH and DiapDealer, for your advice and encouragement. It was an interesting challenge figuring out all the bits and pieces of Qt6 that were needed to keep cmake happy, but I now have both Sigil and PageEdit up and running on Qt 6.4.2, not to mention a new skill: reading between the lines of cmake's error messages (which are very helpful, don't get me wrong).



Albert
st_albert is offline   Reply With Quote
Old 04-08-2024, 08:56 PM   #35
KevinH
Sigil Developer
KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.KevinH ought to be getting tired of karma fortunes by now.
 
Posts: 7,874
Karma: 5449552
Join Date: Nov 2009
Device: many
Glad to hear you have it working!
KevinH is offline   Reply With Quote
Old 06-12-2024, 04:17 PM   #36
graycyn
Wizard
graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.
 
Posts: 1,540
Karma: 11250344
Join Date: Aug 2010
Location: NE Oregon
Device: Kobo Sage, Forma, Pocketbook Era, Kindle Oasis 2
Any issues with just installing v2.1.0 over Sigil v1.70 or should I uninstall the old first?
graycyn is offline   Reply With Quote
Old 06-12-2024, 05:12 PM   #37
DiapDealer
Grand Sorcerer
DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.
 
DiapDealer's Avatar
 
Posts: 27,689
Karma: 196159104
Join Date: Jan 2010
Device: Nexus 7, Kindle Fire HD
There wouldn't be any problem installing over top, but I usually recommend uninstalling the old version first on Windows. Mostly for neatness. Some older libraries might not be removed if newer ones are being installed. I've never had it cause any problems--i just don't like old, unused files lying about taking up space. Regardless of which way you go, existing plugins and preferences will be retained (that's provided you use the uninstaller and don't manually delete anything).

Last edited by DiapDealer; 06-12-2024 at 05:18 PM.
DiapDealer is offline   Reply With Quote
Old 06-12-2024, 06:10 PM   #38
graycyn
Wizard
graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.
 
Posts: 1,540
Karma: 11250344
Join Date: Aug 2010
Location: NE Oregon
Device: Kobo Sage, Forma, Pocketbook Era, Kindle Oasis 2
Quote:
Originally Posted by DiapDealer View Post
There wouldn't be any problem installing over top, but I usually recommend uninstalling the old version first on Windows. Mostly for neatness. Some older libraries might not be removed if newer ones are being installed. I've never had it cause any problems--i just don't like old, unused files lying about taking up space. Regardless of which way you go, existing plugins and preferences will be retained (that's provided you use the uninstaller and don't manually delete anything).
Works for me, getting on it. I tend to be horrid at keeping Sigil updated on a regular basis, but it seems time, LOL!
graycyn is offline   Reply With Quote
Old 06-12-2024, 06:30 PM   #39
DiapDealer
Grand Sorcerer
DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.DiapDealer ought to be getting tired of karma fortunes by now.
 
DiapDealer's Avatar
 
Posts: 27,689
Karma: 196159104
Join Date: Jan 2010
Device: Nexus 7, Kindle Fire HD
Quote:
Originally Posted by graycyn View Post
Works for me, getting on it. I tend to be horrid at keeping Sigil updated on a regular basis, but it seems time, LOL!
Note that moving from 1.7 to 2.1.x will result in your ini files being migrated to v6 versions for Qt6, but the originals will be retained should you need/want to roll back.
DiapDealer is offline   Reply With Quote
Old 06-21-2024, 02:27 PM   #40
graycyn
Wizard
graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.graycyn ought to be getting tired of karma fortunes by now.
 
Posts: 1,540
Karma: 11250344
Join Date: Aug 2010
Location: NE Oregon
Device: Kobo Sage, Forma, Pocketbook Era, Kindle Oasis 2
Quote:
Originally Posted by DiapDealer View Post
Note that moving from 1.7 to 2.1.x will result in your ini files being migrated to v6 versions for Qt6, but the originals will be retained should you need/want to roll back.
Updated this AM, all seems well so far! Thanks for your advice and help!
graycyn is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sigil-1.5.1 Released DiapDealer Sigil 27 04-15-2021 10:27 AM
Sigil-0.9.8 Released DiapDealer Sigil 58 05-07-2017 04:56 PM
Sigil-0.9.1 Released KevinH Sigil 36 12-04-2015 03:00 PM
Sigil-0.8.900 released for testing - Wait for Sigil-0.8.901 KevinH Sigil 106 10-04-2015 10:41 AM
Sigil 0.7.4 Released user_none Sigil 47 01-05-2014 02:31 PM


All times are GMT -4. The time now is 02:11 AM.


MobileRead.com is a privately owned, operated and funded community.