Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Server

Notices

Reply
 
Thread Tools Search this Thread
Old 02-01-2019, 01:06 PM   #1
wanni11
Junior Member
wanni11 began at the beginning.
 
Posts: 2
Karma: 10
Join Date: Feb 2019
Device: Pockebook
(Solved) Ubuntu 18.10 & Letsencrypt SSL config for content server

I needed some while to finally get Calibre working over SSL. Not sure this is something special to Ubuntu 18.10, but this was the problem:

I added as ssl paths:

/etc/letsencrypt/live/www.mydomain.com/fullcert.pem
/etc/letsencrypt/live/www.mydomain.com/privkey.pem

Starting the server always produced the error "permission denied". Tried to change access rights, but did help.

So I copied the certificates to /opt/calibre and changed the paths accordingly.

Then trying to start again an error, this time "file does not exist".

Needed a while to realize that in /etc/letsencrypt/live only symbolic links reside, not the file itself. And it looks like Calibre server cannot handle symbolic links for certificates.

The real files are in /etc/letsencrpyt/archive

After I copied those to /opt/calibre the service starts now without issue :-)

And I have a proper SSL connection outside my network.

So after I got this working from inside the Calibre app I created as well the calibre-server.service file so it starts with system boot using the same as above. And works as well.

As I'm very new to Linux/Ubuntu I might have done it in the first case wrong. But for other novice this might help.
wanni11 is offline   Reply With Quote
Old 03-05-2019, 12:39 PM   #2
rfilmyer
Junior Member
rfilmyer began at the beginning.
 
Posts: 7
Karma: 10
Join Date: Oct 2018
Device: Android/Moon+ Reader
I just put the service behind a reverse proxy using nginx (although you can use apache), especially since I have other stuff running on this server.
If you're already running another web server for something, it might be easier to go this way, since your certificates might be already hooked up to nginx. (and LE handshakes are a lot easier to configure with nginx than with calibre)
rfilmyer is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
installing Calibre content server 3 on ubuntu server 16_04 khyox Calibre 22 01-06-2018 11:34 PM
Calibre with SSL, Content Server not loading aCIDsLAM Calibre 15 06-26-2017 03:16 AM
Content server on ubuntu 12.04 headless server ImageMagick: libltdl.so.7 Cool Javelin Calibre 5 04-08-2015 02:20 AM
[Solved] Calibre Content Server Problem Jacdeb6009 Devices 2 11-01-2013 11:03 AM
SSL and content server timoco Calibre 2 04-13-2011 10:42 AM


All times are GMT -4. The time now is 02:05 AM.


MobileRead.com is a privately owned, operated and funded community.