Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Sony Reader

Notices

Reply
 
Thread Tools Search this Thread
Old 06-20-2012, 04:08 PM   #1
HeXenEoN
Member
HeXenEoN began at the beginning.
 
HeXenEoN's Avatar
 
Posts: 15
Karma: 10
Join Date: Jun 2012
Location: No Man's Land, Neverland
Device: Amazon Kindle 3 Keyboard, Sony PRS T1
Exclamation Unable to reroot the device after restoration


unable to reroot my sony PRS-T1

After successfully rooting with porkupan's Minimal Root package restored the device to factory firmware using the restore package (porkupan's).

Now I tried to root the device again but the device isn't recognizing the root as it go back to the sony reader home after root procedure. also tried SD recovery of both uboot & porkupan but the problem persists..

Later found that some trace of root still resides in the device, when i connect to PC it shows android symbol in the top left of reader. Also it enters into USB debugging mode..

need some help to 100% restoration of factory firmware...

HeXenEoN is offline   Reply With Quote
Old 06-25-2012, 11:36 AM   #2
MCSmarties
Enthusiast
MCSmarties has much to be proud ofMCSmarties has much to be proud ofMCSmarties has much to be proud ofMCSmarties has much to be proud ofMCSmarties has much to be proud ofMCSmarties has much to be proud ofMCSmarties has much to be proud ofMCSmarties has much to be proud ofMCSmarties has much to be proud ofMCSmarties has much to be proud ofMCSmarties has much to be proud of
 
Posts: 45
Karma: 27066
Join Date: Jun 2012
Location: Pittsburgh, PA
Device: Sony PRS-T1
Hi HeXen,

I ran into a similar problem. I have one suggestion: maybe you used the wrong restore package for your firmware?

I have the newest firmware 1.0.04.12210 on mine. When I tried to run porkupan's restore-set.zip it sort of borked my reader - didn't quite remove the rupor root, but didn't leave it intact either.

After much sweating, I found that there is a different restore-set for this firmware. Once I applied restore-set-1.0.04.12210.zip (get it here), I was back to normal.
MCSmarties is offline   Reply With Quote
Advert
Old 06-25-2012, 12:23 PM   #3
HeXenEoN
Member
HeXenEoN began at the beginning.
 
HeXenEoN's Avatar
 
Posts: 15
Karma: 10
Join Date: Jun 2012
Location: No Man's Land, Neverland
Device: Amazon Kindle 3 Keyboard, Sony PRS T1
Quote:
Originally Posted by MCSmarties View Post
Hi HeXen,

I ran into a similar problem. I have one suggestion: maybe you used the wrong restore package for your firmware?

I have the newest firmware 1.0.04.12210 on mine. When I tried to run porkupan's restore-set.zip it sort of borked my reader - didn't quite remove the rupor root, but didn't leave it intact either.

After much sweating, I found that there is a different restore-set for this firmware. Once I applied restore-set-1.0.04.12210.zip (get it here), I was back to normal.
Thank you.. I will give it a try...
HeXenEoN is offline   Reply With Quote
Old 06-25-2012, 03:34 PM   #4
HeXenEoN
Member
HeXenEoN began at the beginning.
 
HeXenEoN's Avatar
 
Posts: 15
Karma: 10
Join Date: Jun 2012
Location: No Man's Land, Neverland
Device: Amazon Kindle 3 Keyboard, Sony PRS T1
@MCSmarties
I too have same firmware version, so applied the restore-set-1.0.04.12210.zip but the results were same as before, not 100% restoration.. when connecting USB the USB debugging mode still appears, I am sure that is not a feature from factory firmware, correct me if I am wrong...

To mention I before tried the SD restoration package of both Uboot and porkupan but stuck with a infinite loop procedure...

I will try to sort what technical wrong was in ma case...
HeXenEoN is offline   Reply With Quote
Old 06-26-2012, 11:46 AM   #5
uboot
Evangelist
uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.uboot seems famous, but is in fact legendary.
 
Posts: 423
Karma: 75216
Join Date: Nov 2011
Location: old europe
Device: Kobo Mini
debugging mode is not restored by restore set, because this is set inside the kernel / root fs partition. you have to apply "disable adb package"
uboot is offline   Reply With Quote
Advert
Old 06-26-2012, 01:20 PM   #6
HeXenEoN
Member
HeXenEoN began at the beginning.
 
HeXenEoN's Avatar
 
Posts: 15
Karma: 10
Join Date: Jun 2012
Location: No Man's Land, Neverland
Device: Amazon Kindle 3 Keyboard, Sony PRS T1
Thumbs up

Quote:
Originally Posted by uboot View Post
debugging mode is not restored by restore set, because this is set inside the kernel / root fs partition. you have to apply "disable adb package"
Thanks for the information....
HeXenEoN is offline   Reply With Quote
Old 07-05-2012, 03:05 AM   #7
Sanglan
Junior Member
Sanglan began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Jul 2012
Device: Sony T1
Bricked it...

Hey Uboot,

I tried a couple of things to restore my T1 in order to reroot with the AMR, but nothing seemed to work. Tried a few different SD rescue sets, but accidentally tried one for firmware 1.03 instead of 1.04.

Now when I turn the device on, it fills to 100% but does nothing else, no flashing lights either. I got the SD out, so that's not it.

Not really sure what to do next... since I can't get another SD rescue to work either.

Hope you can help me, thanks a lot!
Sanglan is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Aldiko/ADE DRM Issues 'Unable to authorise Device' fenric10 Kobo Tablets 10 02-06-2012 08:29 AM
603 Serial number out of range & unable to register the device Arash.M PocketBook 3 03-02-2011 08:54 AM
We are unable to update your device's database. Syncing cannot be completed. talios Kobo Reader 1 12-10-2010 04:16 AM
"28, No space left on device" - memory card, unable to fill it! jrr Calibre 4 11-11-2010 05:47 PM
Unable to authorize device with Sony Atagahi Sony Reader 7 11-15-2009 12:48 AM


All times are GMT -4. The time now is 03:42 AM.


MobileRead.com is a privately owned, operated and funded community.