Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Reading and Management

Notices

Reply
 
Thread Tools Search this Thread
Old 12-22-2016, 03:14 PM   #16
stumped
Guru
stumped is not required to obey the law of gravity.stumped is not required to obey the law of gravity.stumped is not required to obey the law of gravity.stumped is not required to obey the law of gravity.stumped is not required to obey the law of gravity.stumped is not required to obey the law of gravity.stumped is not required to obey the law of gravity.stumped is not required to obey the law of gravity.stumped is not required to obey the law of gravity.stumped is not required to obey the law of gravity.stumped is not required to obey the law of gravity.
 
Posts: 619
Karma: 144382
Join Date: May 2016
Device: Samsung tab s , fire HDX 8.9, fire hd 8
So was my library updating it's overdrive platform my trigger do you think, or is that just coincidence. I know the library changed as it looks different and my bookmarks were all broken. But I am not sure if the bug struck on my first checkout after that update, or if I had previously checked out ok from the new site with the old ade
stumped is offline   Reply With Quote
Advert
Old 12-22-2016, 03:55 PM   #17
AnemicOak
Bookaholic
AnemicOak ought to be getting tired of karma fortunes by now.AnemicOak ought to be getting tired of karma fortunes by now.AnemicOak ought to be getting tired of karma fortunes by now.AnemicOak ought to be getting tired of karma fortunes by now.AnemicOak ought to be getting tired of karma fortunes by now.AnemicOak ought to be getting tired of karma fortunes by now.AnemicOak ought to be getting tired of karma fortunes by now.AnemicOak ought to be getting tired of karma fortunes by now.AnemicOak ought to be getting tired of karma fortunes by now.AnemicOak ought to be getting tired of karma fortunes by now.AnemicOak ought to be getting tired of karma fortunes by now.
 
AnemicOak's Avatar
 
Posts: 13,881
Karma: 51274671
Join Date: Oct 2007
Location: Minnesota
Device: iPad Mini 4, HDX 8.9, AuraHD, NookHD+, Kindle 2,3,T, Opus, iPhone 6, +
I think coincidence? Some libraries have been running the "new" OD for months and this problem seems to have sprung up for everyone at the same time. I know mine had already switched (fairly recently) and I had checked out/downloaded books on the new before the problems started.
AnemicOak is offline   Reply With Quote
Old 12-22-2016, 06:01 PM   #18
bookaho!ic
Addict
bookaho!ic ought to be getting tired of karma fortunes by now.bookaho!ic ought to be getting tired of karma fortunes by now.bookaho!ic ought to be getting tired of karma fortunes by now.bookaho!ic ought to be getting tired of karma fortunes by now.bookaho!ic ought to be getting tired of karma fortunes by now.bookaho!ic ought to be getting tired of karma fortunes by now.bookaho!ic ought to be getting tired of karma fortunes by now.bookaho!ic ought to be getting tired of karma fortunes by now.bookaho!ic ought to be getting tired of karma fortunes by now.bookaho!ic ought to be getting tired of karma fortunes by now.bookaho!ic ought to be getting tired of karma fortunes by now.
 
bookaho!ic's Avatar
 
Posts: 312
Karma: 1278650
Join Date: Feb 2013
Location: UK
Device: kobo Aura
Pleased i stumbled upon this thread - i downloaded 6 books for the holidays from the library and got the error - growled at the pc lol then went on here, had avoided going up from 1.72 but have installed 2.01 and have now put them on my kobo.

God i love this site

merry xmas everyone
bookaho!ic is offline   Reply With Quote
Old 12-22-2016, 10:30 PM   #19
JSWolf
Resident Curmudgeon
JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.
 
JSWolf's Avatar
 
Posts: 50,111
Karma: 43266947
Join Date: Nov 2006
Location: Roslindale, Massachusetts
Device: Kobo Aura H2O, Sony PRS-650, Sony PRS-T1, nook STR, iPad 4, iPhone 5
Quote:
Originally Posted by stumped View Post
it is worse than that- if you upgrade beyond 2.01 e.g. I had 2.06, that version is also broken.

I worry that it is a total fluke that one version only - 2.01 - still works when those that came before AND after do not
I dunno about ade v3 & don't plan to be a guinea pig

has anyone been able to get an explanation of this fiasco from Adobe or Overdrive - as to why they between them broke library book checkouts, because their softwares stopped playing nice with each other. or are they both blaming Windows ???
v2.067532 is a lower number than v2.0.1.78765. You have to get the decimal points correct. It is not 2.01 which is a lower number than 2.06.
JSWolf is online now   Reply With Quote
Old 12-22-2016, 10:33 PM   #20
JSWolf
Resident Curmudgeon
JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.
 
JSWolf's Avatar
 
Posts: 50,111
Karma: 43266947
Join Date: Nov 2006
Location: Roslindale, Massachusetts
Device: Kobo Aura H2O, Sony PRS-650, Sony PRS-T1, nook STR, iPad 4, iPhone 5
Quote:
Originally Posted by bookaho!ic View Post
Pleased i stumbled upon this thread - i downloaded 6 books for the holidays from the library and got the error - growled at the pc lol then went on here, had avoided going up from 1.72 but have installed 2.01 and have now put them on my kobo.

God i love this site

merry xmas everyone
It is not 2.01. It is 2.0.1. Please don't confuse the version numbers with a missing decimal point. You say 2.01 and others will go look for that when it doesn't exist.
JSWolf is online now   Reply With Quote
Advert
Old 12-23-2016, 02:33 AM   #21
stumped
Guru
stumped is not required to obey the law of gravity.stumped is not required to obey the law of gravity.stumped is not required to obey the law of gravity.stumped is not required to obey the law of gravity.stumped is not required to obey the law of gravity.stumped is not required to obey the law of gravity.stumped is not required to obey the law of gravity.stumped is not required to obey the law of gravity.stumped is not required to obey the law of gravity.stumped is not required to obey the law of gravity.stumped is not required to obey the law of gravity.
 
Posts: 619
Karma: 144382
Join Date: May 2016
Device: Samsung tab s , fire HDX 8.9, fire hd 8
is does not help that the installer for both 2.0.1. and 2.0.6... is called ADE_2.0_Installer.exe

and their release numbering system is crazy

Anyone else would go n.n or n.n.n at best. anything else is a build number

The world is not so short of number's that they cannot work within 2.0.1 to 2.9.9 , which accommodates 99 different releases - how many do they need ?
should a link to the correct 2.0 installer go in a sticky, for others to find
stumped is offline   Reply With Quote
Old 12-23-2016, 06:19 AM   #22
bookaho!ic
Addict
bookaho!ic ought to be getting tired of karma fortunes by now.bookaho!ic ought to be getting tired of karma fortunes by now.bookaho!ic ought to be getting tired of karma fortunes by now.bookaho!ic ought to be getting tired of karma fortunes by now.bookaho!ic ought to be getting tired of karma fortunes by now.bookaho!ic ought to be getting tired of karma fortunes by now.bookaho!ic ought to be getting tired of karma fortunes by now.bookaho!ic ought to be getting tired of karma fortunes by now.bookaho!ic ought to be getting tired of karma fortunes by now.bookaho!ic ought to be getting tired of karma fortunes by now.bookaho!ic ought to be getting tired of karma fortunes by now.
 
bookaho!ic's Avatar
 
Posts: 312
Karma: 1278650
Join Date: Feb 2013
Location: UK
Device: kobo Aura
Quote:
Originally Posted by JSWolf View Post
It is not 2.01. It is 2.0.1. Please don't confuse the version numbers with a missing decimal point. You say 2.01 and others will go look for that when it doesn't exist.
oops sorry
bookaho!ic is offline   Reply With Quote
Old 01-01-2017, 12:36 PM   #23
kataclysm
Junior Member
kataclysm began at the beginning.
 
Posts: 4
Karma: 10
Join Date: Jul 2016
Device: Kindle Paperwhite 1
If you are a Linux user reading this thread and were happily running ADE 1.7.x under Wine, you are probably now getting error 2038 whenever you try to download a checked-out book.

You will have to start running ADE 2.0.1 instead. After a couple weeks of trying and tweaking all conceivable settings with Winetricks, I've concluded that Wine will not play well with 2.0.1, so I have actually had to install Windows 7 in a virtual box (virt-manager) to be able to run ADE 2.0.1.

You'll be able to check out books again this way, it will just cost you a minimum of 20GB of HDD space.
kataclysm is offline   Reply With Quote
Old 01-02-2017, 07:36 AM   #24
JSWolf
Resident Curmudgeon
JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.
 
JSWolf's Avatar
 
Posts: 50,111
Karma: 43266947
Join Date: Nov 2006
Location: Roslindale, Massachusetts
Device: Kobo Aura H2O, Sony PRS-650, Sony PRS-T1, nook STR, iPad 4, iPhone 5
Quote:
Originally Posted by kataclysm View Post
If you are a Linux user reading this thread and were happily running ADE 1.7.x under Wine, you are probably now getting error 2038 whenever you try to download a checked-out book.

You will have to start running ADE 2.0.1 instead. After a couple weeks of trying and tweaking all conceivable settings with Winetricks, I've concluded that Wine will not play well with 2.0.1, so I have actually had to install Windows 7 in a virtual box (virt-manager) to be able to run ADE 2.0.1.

You'll be able to check out books again this way, it will just cost you a minimum of 20GB of HDD space.
As I've always said, Windows works best for dealing with eBooks.
JSWolf is online now   Reply With Quote
Old 01-04-2017, 04:48 PM   #25
theducks
Well trained by Cats
theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.
 
theducks's Avatar
 
Posts: 21,021
Karma: 20776314
Join Date: Aug 2009
Location: (The original) Silicon Valley, USA
Device: K4NT, Galaxy Tab 2(RIP)
Quote:
Originally Posted by stumped View Post
i only have a 2nd class honours degree in maths but I am convinced that 2.067532 > 2.0187657

what a silly version numbering system.

the question remains as to why only that version works
Version systems have almost always used TEXT and not Numeric systems
the Period is a separator, not a decimal point
Major . Minor . (really minor) patch level
theducks is offline   Reply With Quote
Old 01-14-2017, 11:42 AM   #26
Ankh
Guru
Ankh ought to be getting tired of karma fortunes by now.Ankh ought to be getting tired of karma fortunes by now.Ankh ought to be getting tired of karma fortunes by now.Ankh ought to be getting tired of karma fortunes by now.Ankh ought to be getting tired of karma fortunes by now.Ankh ought to be getting tired of karma fortunes by now.Ankh ought to be getting tired of karma fortunes by now.Ankh ought to be getting tired of karma fortunes by now.Ankh ought to be getting tired of karma fortunes by now.Ankh ought to be getting tired of karma fortunes by now.Ankh ought to be getting tired of karma fortunes by now.
 
Ankh's Avatar
 
Posts: 714
Karma: 2003751
Join Date: Oct 2008
Location: Ottawa, ON
Device: Kobo Glo HD
Quote:
Originally Posted by kataclysm View Post
If you are a Linux user reading this thread and were happily running ADE 1.7.x under Wine, you are probably now getting error 2038 whenever you try to download a checked-out book.

You will have to start running ADE 2.0.1 instead. After a couple weeks of trying and tweaking all conceivable settings with Winetricks, I've concluded that Wine will not play well with 2.0.1, so I have actually had to install Windows 7 in a virtual box (virt-manager) to be able to run ADE 2.0.1.

You'll be able to check out books again this way, it will just cost you a minimum of 20GB of HDD space.
Ubuntu 16.10 amd64 here. It was a pain, but 2.0.1 works under wine.

I used winehq ppa: https://wiki.winehq.org/Ubuntu

I erased all wine components from my home folder:
Code:
rm -rf $HOME/.wine
rm -f $HOME/.config/menus/applications-merged/*wine*
rm -rf $HOME/.local/share/applications/wine
rm -f $HOME/.local/share/desktop-directories/*wine*
rm -f $HOME/.local/share/icons/*wine*
My old wine prefix was 64 bit and any attempt to install dotnet to a prefix other than default failed me. Then I did what is not suggested, created a default ~/.wine prefix as win32:
Code:
WINEPREFIX=~/.wine WINEARCH=win32 wineboot
Then follow to the letter Anastasius Focht's post here:
https://appdb.winehq.org/objectManag...sion&iId=27978

doing:
Code:
winetricks -q dotnet35sp1
winetricks -q windowscodecs
winetricks -q corefonts
Got a deadlock situation during dotnet35 installation, removed everything and started again. But it eventually succedeed. Installation of latest ADE 2.0.1 from Adobe's download page mentioned in this thread then worked.
Ankh is offline   Reply With Quote
Old 02-05-2017, 11:05 PM   #27
Geremia
Connoisseur
Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.
 
Posts: 89
Karma: 8778
Join Date: Oct 2012
Device: Calibre
Quote:
Originally Posted by Ankh View Post
Installation of latest ADE 2.0.1 from Adobe's download page mentioned in this thread then worked.
Thanks, but when I open ACSM books, I get this error with your method:
Code:
License Server Communication Problem
E_ADEPT_DOCUMENT_TOO_SHORT
Geremia is offline   Reply With Quote
Old 02-06-2017, 02:32 PM   #28
Geremia
Connoisseur
Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.
 
Posts: 89
Karma: 8778
Join Date: Oct 2012
Device: Calibre
I'm thinking error #2038 has something to do with ADE possibly not supporting TLS, which is a newer technology than SSL.

For example, the URL that ADE fails connecting to for my particular ACSM file is of this form:
Code:
13a0790921b0eed053bf-13a0790921b0eed053bfaf9e6b555ccd.ssl.cf2.rackcdn.com (104.100.192.27)
According to Qualys SSL Lab's SSL server test, this HTTPS URL doesn't support any SSL version all; it only supports TLS 1.0 or above.

This explains how I can download the ebook using the given URL in my browser and be able to open it up in ADE, but ADE itself doesn't download it, because the version I use in WINE under Linux is from 2010, long before mainstream adoption of TLS.

Last edited by Geremia; 02-06-2017 at 02:44 PM.
Geremia is offline   Reply With Quote
Old 02-06-2017, 05:46 PM   #29
JSWolf
Resident Curmudgeon
JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.
 
JSWolf's Avatar
 
Posts: 50,111
Karma: 43266947
Join Date: Nov 2006
Location: Roslindale, Massachusetts
Device: Kobo Aura H2O, Sony PRS-650, Sony PRS-T1, nook STR, iPad 4, iPhone 5
Do you have Windows? if you do, install ADE 2.0.1 and be happy that it works.
JSWolf is online now   Reply With Quote
Old 02-06-2017, 08:37 PM   #30
Geremia
Connoisseur
Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.Geremia shines like a glazed doughnut.
 
Posts: 89
Karma: 8778
Join Date: Oct 2012
Device: Calibre
Quote:
Originally Posted by JSWolf View Post
Do you have Windows? if you do, install ADE 2.0.1 and be happy that it works.
Yeah, I should try it. And if I get a network error, there must be a problem with my account or network.

UPDATE: I had to resort to using a Windows Vagrant box with VirtualBox. ADE 2.0.1 worked there.

Last edited by Geremia; 02-08-2017 at 11:18 AM.
Geremia is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mini Not able to download books to ADE Jher Kobo Reader 3 08-12-2013 08:29 PM
ADE Error # 2038 GraciousMe General Discussions 2 12-08-2012 03:19 PM
Do I need to install ADE to download Library books. JayB Sony Reader 5 06-13-2011 06:52 PM
Can I borrow books from library without ADE? jerrry94087 Barnes & Noble NOOK 24 06-12-2011 10:05 PM
PRS-300 ADE Epub books from library khintul Sony Reader 5 12-23-2010 11:46 AM


All times are GMT -4. The time now is 12:52 PM.


MobileRead.com is a privately owned, operated and funded community.