Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Windows Devices

Notices

Reply
 
Thread Tools Search this Thread
Old 06-23-2017, 04:01 PM   #1
CmplxAdSys
Enthusiast
CmplxAdSys began at the beginning.
 
Posts: 25
Karma: 10
Join Date: Jul 2015
Device: Kobo Aura H20
Associating New File Types with MS Reader or Edge

Hi,

tl;dr version: I have a PDF file whose extension I changed to .originalpdf. How can I associate that new extension with either Microsoft Reader's app or Microsoft Edge so that it opens automatically? I tried using the "How do you want to open this file?" dialogue box, but neither comes up.

Longer version: in order to clean up my Calibre library, I created a new extension for original PDFs called .originalpdf to distinguish those from cropped PDFs I transfer to my e-reader. That way, I can keep both file types under a single Calibre listing.

However, I'm having trouble associating this new file type with either Microsoft Edge or Reader, since both don't have standard .exe files I can point to. The former's a Windows Store app, and the latter is a system app. Thus, it's hard for me to use the standard methods I know if to associate this file type with a PDF reader.

I got around this on my laptop by using Adobe Reader which is easily found and associated, but I strongly prefer to use Edge or Reader on my tablet.

Any idea how to associate this file type (which is just a PDF with the file extension changed) with Edge or Reader?

Thanks in advance.
CmplxAdSys is offline   Reply With Quote
Advert
Old 06-24-2017, 12:00 PM   #2
DaleDe
Grand Sorcerer
DaleDe ought to be getting tired of karma fortunes by now.DaleDe ought to be getting tired of karma fortunes by now.DaleDe ought to be getting tired of karma fortunes by now.DaleDe ought to be getting tired of karma fortunes by now.DaleDe ought to be getting tired of karma fortunes by now.DaleDe ought to be getting tired of karma fortunes by now.DaleDe ought to be getting tired of karma fortunes by now.DaleDe ought to be getting tired of karma fortunes by now.DaleDe ought to be getting tired of karma fortunes by now.DaleDe ought to be getting tired of karma fortunes by now.DaleDe ought to be getting tired of karma fortunes by now.
 
DaleDe's Avatar
 
Posts: 10,728
Karma: 11200000
Join Date: Aug 2007
Location: Grass Valley, CA
Device: EB 1150, EZ Reader, Literati, iPad 2 & Air 2
Generally you just tap on the file and you will be offered a menu to choose the app you want and there is a checkbox to make this the default.
DaleDe is offline   Reply With Quote
Old 06-25-2017, 10:54 PM   #3
CmplxAdSys
Enthusiast
CmplxAdSys began at the beginning.
 
Posts: 25
Karma: 10
Join Date: Jul 2015
Device: Kobo Aura H20
Yep, I'm offered that menu. The problem is that MS Reader or Edge are not offered as options on it.

If I navigate to the exe file for Reader, I get an error message saying that the app needs to be activated in an app wrapper. And when I associate Edge with it, nothing happens when I double click on the file with the modified file extension.
CmplxAdSys is offline   Reply With Quote
Old 07-07-2017, 01:51 AM   #4
nancyrobert2011
Junior Member
nancyrobert2011 began at the beginning.
 
Posts: 4
Karma: 10
Join Date: May 2015
Device: none
Try this:

Using the Settings app

Open Settings. Click on Apps.
Click on Default apps.

Note: If you're still running the Windows 10 Anniversary Update, the path is Settings > System > Default apps.
Click the Choose default apps by file type link.



Scroll down and find .pdf (PDF File), and click the button on the right side, which is likely to read "Microsoft Edge."
Select your app from the list to set it as the new default.



Click the Switch anyway link to confirm the change.
nancyrobert2011 is offline   Reply With Quote
Old 07-14-2017, 12:47 AM   #5
CmplxAdSys
Enthusiast
CmplxAdSys began at the beginning.
 
Posts: 25
Karma: 10
Join Date: Jul 2015
Device: Kobo Aura H20
Quote:
Originally Posted by nancyrobert2011 View Post
Try this:

Using the Settings app

Open Settings. Click on Apps.
Click on Default apps.

Note: If you're still running the Windows 10 Anniversary Update, the path is Settings > System > Default apps.
Click the Choose default apps by file type link.



Scroll down and find .pdf (PDF File), and click the button on the right side, which is likely to read "Microsoft Edge."
Select your app from the list to set it as the new default.



Click the Switch anyway link to confirm the change.
Thanks, but doesn't work. I used the process you described to scroll down to the ".orignalpdf" file type, but the only options that appear to me are desktop programs (e.g. Adobe Acrobat Reader) or "look for an app in the Store". The latter yields no results.

So I'm afraid I can't associate Edge or Reader or any other Windows Store apps with this file type using the method you described.
CmplxAdSys is offline   Reply With Quote
Old 08-16-2017, 04:10 AM   #6
sb1370
Member
sb1370 began at the beginning.
 
Posts: 19
Karma: 10
Join Date: Nov 2015
Device: Kobo H2O
Try the attached registry entry.
Attached Files
File Type: zip associate ext.zip (355 Bytes, 21 views)
sb1370 is offline   Reply With Quote
Reply

Tags
calibre, file extension, microsoft reader, pdf, windows 10

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Associating external "index" file with book fncll Library Management 2 12-03-2014 06:06 PM
Mobi2Mobi File types for Mobi2Mobi Muppet Rat Kindle Formats 2 11-27-2013 01:41 AM
Proliferation of file types.... carpetmojo Conversion 8 11-10-2013 02:42 AM
Other file types and 2.3.2 davidfor Kobo Reader 4 01-16-2013 04:52 PM
how to set an alternate reader as default for some file types? zed88 Calibre 3 04-21-2011 04:21 PM


All times are GMT -4. The time now is 12:55 PM.


MobileRead.com is a privately owned, operated and funded community.