Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Related Tools

Notices

Reply
 
Thread Tools Search this Thread
Old 05-26-2017, 05:29 PM   #1576
Calibius
Junior Member
Calibius began at the beginning.
 
Posts: 7
Karma: 10
Join Date: May 2017
Device: Kindle paperwhite 3
Well that's good! With basic auth working it should be fairly simple to setup the per user configs!

Also know that with the alternate filematch in you config_local.php file you need to set the secure fetch.php option. I'm posting from my phone at the moment, so I can't send you the exact option, and you shouldn't worry about it until everything else is working. But that filematch option opens fetch.php to being insecure and you can access it to potentially download files et centers without authentication

Last edited by Calibius; 05-26-2017 at 05:33 PM.
Calibius is offline   Reply With Quote
Advert
Old 05-26-2017, 05:45 PM   #1577
MontyJ
Groupie
MontyJ began at the beginning.
 
Posts: 163
Karma: 10
Join Date: Jul 2012
Device: Kindle
Quote:
Originally Posted by Calibius View Post
Well that's good! With basic auth working it should be fairly simple to setup the per user configs!

Also know that with the alternate filematch in you config_local.php file you need to set the secure fetch.php option. I'm posting from my phone at the moment, so I can't send you the exact option, and you shouldn't worry about it until everything else is working. But that filematch option opens fetch.php to being insecure and you can access it to potentially download files et centers without authentication
Ok, good to know!

Next step was to add the send email option. Here is the entry I made in config_local.cfg:
Code:
    $config['cops_mail_configuration'] = array( "smtp.host"     => "smtp.gmail.com",
                                                "smtp.username" => "myacct@gmail.com",
                                                "smtp.password" => "mygmailpassword",
                                                "smtp.secure"   => "ssl",
                                                "address.from"  => "myhotmailacct");
I think I did this before and it worked, but it doesn't hurt to get extra eyes on it!
MontyJ is offline   Reply With Quote
Old 05-26-2017, 05:57 PM   #1578
mariosipad
Addict
mariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watch
 
Posts: 390
Karma: 10738
Join Date: Nov 2012
Device: iPad & iPhone with Marvin & Kobo Glo HD
@MontyJ

My e-mail entry looks like:
Code:
     $config['cops_mail_configuration'] = array( "smtp.host"     => "smtp.gmail.com",
                                                 "smtp.username" => "myacct@gmail.com",
                                                 "smtp.password" => "mypasswd",
                                                 "smtp.secure"   => "ssl",
                                                 "address.from"  => "myacct@gmail.com",
						 "subject"       => "Sent by COPS : "
                                                 );
Why use hotmail as "address.from"?
mariosipad is offline   Reply With Quote
Old 05-26-2017, 06:03 PM   #1579
mariosipad
Addict
mariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watch
 
Posts: 390
Karma: 10738
Join Date: Nov 2012
Device: iPad & iPhone with Marvin & Kobo Glo HD
Quote:
Originally Posted by Calibius View Post
Also know that with the alternate filematch in you config_local.php file you need to set the secure fetch.php option. I'm posting from my phone at the moment, so I can't send you the exact option, and you shouldn't worry about it until everything else is working. But that filematch option opens fetch.php to being insecure and you can access it to potentially download files et centers without authentication
There is no such option in my config_default.php / config_local.php.
Or are you referring to:
Code:
    /*
     * If you use a Sony eReader or Aldiko you can't download ebooks if your catalog
     * is password protected. A simple workaround is to leave fetch.php not protected (see .htaccess).
     * But In that case your COPS installation is not completely safe.
     * Setting this parameter to "1" ensure that nobody can access fetch.php before accessing
     * index.php or feed.php first.
     * BEWARE : Do not touch this if you're not using password, not using PRS-TX or not using Aldiko.
     */
    $config ['cops_fetch_protect'] = '0';
I never needed nor used that setting.

Last edited by mariosipad; 05-26-2017 at 06:07 PM.
mariosipad is offline   Reply With Quote
Old 05-26-2017, 06:27 PM   #1580
Calibius
Junior Member
Calibius began at the beginning.
 
Posts: 7
Karma: 10
Join Date: May 2017
Device: Kindle paperwhite 3
Of course, I believe you're correct. I don't know where I pulled that from. Haha. I got confused. I really thought I read something about that but I guess I'm crazy.

Edit: I actually did find that in .htaccess in a comment before the filesmatch block at the bottom. I knew I wasn't completely crazy. Monty only needs it if he uses the modified filematch, which he said he requires for it to work for him. Thus, you wouldn't need to worry about the config setting.

Last edited by Calibius; 05-26-2017 at 06:37 PM.
Calibius is offline   Reply With Quote
Old 05-26-2017, 06:33 PM   #1581
MontyJ
Groupie
MontyJ began at the beginning.
 
Posts: 163
Karma: 10
Join Date: Jul 2012
Device: Kindle
Quote:
Originally Posted by mariosipad View Post
@MontyJ

My e-mail entry looks like:
Code:
     $config['cops_mail_configuration'] = array( "smtp.host"     => "smtp.gmail.com",
                                                 "smtp.username" => "myacct@gmail.com",
                                                 "smtp.password" => "mypasswd",
                                                 "smtp.secure"   => "ssl",
                                                 "address.from"  => "myacct@gmail.com",
						 "subject"       => "Sent by COPS : "
                                                 );
Why use hotmail as "address.from"?
Gmail is a non-standard email address for the members of my forum/group. Given they are an, shall we say, 'older' demographic, it could confuse them. They are used to seeing the Hotmail email address.
MontyJ is offline   Reply With Quote
Old 05-26-2017, 06:35 PM   #1582
mariosipad
Addict
mariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watch
 
Posts: 390
Karma: 10738
Join Date: Nov 2012
Device: iPad & iPhone with Marvin & Kobo Glo HD
Quote:
Originally Posted by Calibius View Post
Of course, I believe you're correct. I don't know where I pulled that from. Haha. I got confused. I really thought I read something about that but I guess I'm crazy.
I would not dare to confirm your statement about your mental health.

However, if you use <FilesMatch "(index|feed)\.php"> in .htaccess that would mean that fetch.php is not password protected. Not good.
mariosipad is offline   Reply With Quote
Old 05-26-2017, 06:37 PM   #1583
MontyJ
Groupie
MontyJ began at the beginning.
 
Posts: 163
Karma: 10
Join Date: Jul 2012
Device: Kindle
Quote:
Originally Posted by mariosipad View Post
There is no such option in my config_default.php / config_local.php.
Or are you referring to:
Code:
    /*
     * If you use a Sony eReader or Aldiko you can't download ebooks if your catalog
     * is password protected. A simple workaround is to leave fetch.php not protected (see .htaccess).
     * But In that case your COPS installation is not completely safe.
     * Setting this parameter to "1" ensure that nobody can access fetch.php before accessing
     * index.php or feed.php first.
     * BEWARE : Do not touch this if you're not using password, not using PRS-TX or not using Aldiko.
     */
    $config ['cops_fetch_protect'] = '0';
I never needed nor used that setting.
But I am using password, so should I change it?

I should have added I turned on Pagekite and this all working through the web as well, not just locally!

By the way, the email thing is working; I just had a book sent to my Kindle Paperwhite. It does show up as a "Doc" format. No clue why that is but it opens like a normal .mobi file, so no complaints so far!

Last edited by MontyJ; 05-26-2017 at 06:42 PM. Reason: update
MontyJ is offline   Reply With Quote
Old 05-26-2017, 06:39 PM   #1584
Calibius
Junior Member
Calibius began at the beginning.
 
Posts: 7
Karma: 10
Join Date: May 2017
Device: Kindle paperwhite 3
Quote:
Originally Posted by mariosipad View Post
I would not dare to confirm your statement about your mental health.

However, if you use <FilesMatch "(index|feed)\.php"> in .htaccess that would mean that fetch.php is not password protected. Not good.
Haha. That's what I thought I had said! Maybe I just didn't clarify what I meant very well.
Calibius is offline   Reply With Quote
Old 05-26-2017, 06:39 PM   #1585
mariosipad
Addict
mariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watch
 
Posts: 390
Karma: 10738
Join Date: Nov 2012
Device: iPad & iPhone with Marvin & Kobo Glo HD
Maybe not now, maybe later if everything works. ;-)
mariosipad is offline   Reply With Quote
Old 06-06-2017, 10:56 AM   #1586
mariosipad
Addict
mariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watch
 
Posts: 390
Karma: 10738
Join Date: Nov 2012
Device: iPad & iPhone with Marvin & Kobo Glo HD
To prepare for the upcoming launch of Debian Stretch and to see if COPS still works with the new Debian version I decided to try to install COPS from the github source (git clone) on a fresh install of stretch.

What i did (add sudo or su where needed. to test I just use root ):
Code:
apt-get install apache2 php7.0 git
apt-get install php7.0-gd php7.0-sqlite3 php7.0-json php7.0-intl
systemctl restart apache2
cd /var/www/html
git clone https://github.com/seblucas/cops
cd cops
wget https://getcomposer.org/composer.phar
php composer.phar global require "fxp/composer-asset-plugin:~1.1"
php composer.phar install --no-dev --optimize-autoloader
With this last line I ran into the following problem / error:
Code:
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested PHP extension ext-xml * is missing from your system. Install or enable PHP's xml extension.
  Problem 2
    - The requested PHP extension ext-mbstring * is missing from your system. Install or enable PHP's mbstring extension.
  Problem 3
    - Installation request for seblucas/php-epub-meta 1.0.0 -> satisfiable by seblucas/php-epub-meta[1.0.0].
    - seblucas/php-epub-meta 1.0.0 requires ext-xml * -> the requested PHP extension xml is missing from your system.
This was easily resolved by:
Code:
apt-get install php7.0-xml php7.0-mbstring php7.0-zip
As far as I can remember this was not needed on Debian Jessie. (Jessie does not know/need these packages for php5.)

I just thought I document it here for future reference.
mariosipad is offline   Reply With Quote
Old 06-16-2017, 05:19 PM   #1587
superturrican
Junior Member
superturrican began at the beginning.
 
Posts: 9
Karma: 10
Join Date: Aug 2016
Device: Kobo Touch
Does Calibre 3.0 introduce any changes to the database format it uses that might break compatibility with COPS?
superturrican is offline   Reply With Quote
Old 06-16-2017, 10:52 PM   #1588
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 30,851
Karma: 7728435
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
THere are no changes to the database format.
kovidgoyal is offline   Reply With Quote
Old 06-22-2017, 12:54 PM   #1589
dscottf
Member
dscottf began at the beginning.
 
Posts: 13
Karma: 10
Join Date: Oct 2003
Device: Palm Tungsten T
Monocle reader trigger

way back in 1.0.0RC1 - 20140404 Monocle was added:
"Added an embedded Epub Reader based on Monocle. Thanks to all the beta testers."

my question is:
the vast majority of my books (and they all all in both epub and mobi format) do not show the reader icon. Some do, but I cannot figure out what the difference is. Undoubtedly some formatting difference (almost all were converted in Calibre over the years).

What triggers the embedded reader icon?
dscottf is offline   Reply With Quote
Old 06-22-2017, 01:41 PM   #1590
mariosipad
Addict
mariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watchmariosipad is clearly one to watch
 
Posts: 390
Karma: 10738
Join Date: Nov 2012
Device: iPad & iPhone with Marvin & Kobo Glo HD
@dscottf

I just tested on my ebooks if it still works, and it does (with everyone of the epub files I tried = 10+).
It works only with epub files (It's an epub reader after all).

Can you give an example of an epub where it does not work? (Maybe make your own epub in calibre out of some random text?)
mariosipad is offline   Reply With Quote
Reply

Tags
calibre opds, dns, kobo aura, synology

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[Old Thread] Android FBreader and Calibre OPDS server question kalex Calibre 5 12-24-2015 10:16 PM
PHP+Apache web server for calibre ... chaley Related Tools 254 04-28-2014 08:18 PM
External OPDS catalogue in Calibre bolton Calibre 1 09-05-2012 06:14 AM
Calibre OPDS server with windows apps? nickdma Related Tools 9 02-02-2011 03:09 PM
Calibre Command Line usage with PHP artoros Related Tools 13 07-01-2010 09:57 AM


All times are GMT -4. The time now is 03:09 AM.


MobileRead.com is a privately owned, operated and funded community.