Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 05-18-2018, 07:40 PM   #1
fredex
Member
fredex began at the beginning.
 
Posts: 16
Karma: 10
Join Date: Aug 2014
Device: none
3.23 gives SSL error at install

Centos-7.5 attempting to install Calibre 3.23 gives this error:

Downloading tarball signature securely...
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "<string>", line 775, in script_launch
File "<string>", line 732, in main
File "<string>", line 678, in run_installer
File "<string>", line 648, in download_and_extract
File "<string>", line 640, in get_tarball_info
File "<string>", line 597, in get_https_resource_securely
File "<string>", line 505, in __init__
File "/usr/lib64/python3.3/http/client.py", line 1186, in __init__
context.load_cert_chain(cert_file, key_file)
ssl.SSLError: [SSL] PEM lib (_ssl.c:2138)

The very first time I installed Calibre I had to do the "manual" install, but ever since, until today, the normal install has worked fine.

today, with that failure, the manual install still works. but even after that, trying the "normal" install still fails.

I'm open to suggestions, and thanks in advance!

Fred
fredex is offline   Reply With Quote
Advert
Old 05-18-2018, 09:46 PM   #2
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 32,929
Karma: 10034422
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
This is most likely caused by a broken http_proxy. Make sure the env vars http_proxy and https_proxy are unset.
kovidgoyal is offline   Reply With Quote
Old 05-20-2018, 07:16 PM   #3
fredex
Member
fredex began at the beginning.
 
Posts: 16
Karma: 10
Join Date: Aug 2014
Device: none
Kovid, thanks for the reply.

there are no environment variables containing either http, https, or proxy.

Any more ideas?

this system was just updated to latest Centos Linux, what do you suppose something in the updates broke this?

it has python 2.7.5. what Python modules should I have, that if they became broken might relate to this?

Anything else I can check?
fredex is offline   Reply With Quote
Old 05-20-2018, 11:38 PM   #4
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 32,929
Karma: 10034422
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
python 2.7.5 is insecure, you need at least 2.7.9 that has various SSL related fixes. It may be that red hat has backported the fixes and not done it correctly, I wouldn't know. In any case, you can always manually download the tarball and have the installer use that, see the download page for instructions.
kovidgoyal is offline   Reply With Quote
Old 05-21-2018, 12:40 PM   #5
fredex
Member
fredex began at the beginning.
 
Posts: 16
Karma: 10
Join Date: Aug 2014
Device: none
Kovid, thanks again for the reply.

As a test, I created a new VM and installed Centos-7 in it and ran yum update to make sure it was up to date.

installing 3.23 in that system seems to work fine, so something is weird on my main desktop system. but I have no clue how to figure it out.

I note that the installer says it is using python3, which seems strange, but is that what it should do? the system where it fails does have python3 installed (but not very many components). it has python3, python3-libs and python3-setuptools.

Any further thoughts will be welcome.

thanks again!

Fred
fredex is offline   Reply With Quote
Old 05-21-2018, 01:10 PM   #6
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 32,929
Karma: 10034422
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
python3 is fine. the installer works with either python3 or python 2.

I'm afraid I dont have any more insight to offer. Something is messed up with either th python on your system or the openssl libs. Sadly, OpenSSL is such a poorly architected library that trying to figure out what that might be is no simple task.
kovidgoyal is offline   Reply With Quote
Old 05-21-2018, 01:34 PM   #7
fredex
Member
fredex began at the beginning.
 
Posts: 16
Karma: 10
Join Date: Aug 2014
Device: none
Kovid:

Since I don't remember specifically installing those python3 modules, I tried removing them, and it turns out that nothing on the system depends on those packages! So I removed 'em and voiila! Calibre 3.23 installs just fine!

it is possible that something installed outside the yum/rpm system requires these, but if so I imagine I'll find it out in time. In the meantime, I'm good.

Fred
fredex is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SSL: CERTIFICATE_VERIFY_FAILED Error Bengb Library Management 10 07-24-2017 11:56 AM
SSL Error Connecting on Mac OSX JimmXinu Calibre 7 01-30-2016 12:17 PM
Error on new install 0.6.48 sjohnson717 Calibre 1 04-18-2010 12:55 PM
6.18 install error weedfreak Calibre 1 10-17-2009 12:26 PM
4.8.3 Install error D1ffuse Calibre 1 08-31-2008 05:36 AM


All times are GMT -4. The time now is 09:45 AM.


MobileRead.com is a privately owned, operated and funded community.