Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Devices

Notices

Reply
 
Thread Tools Search this Thread
Old 12-18-2014, 03:22 AM   #1
Fiat_Lux
Addict
Fiat_Lux ought to be getting tired of karma fortunes by now.Fiat_Lux ought to be getting tired of karma fortunes by now.Fiat_Lux ought to be getting tired of karma fortunes by now.Fiat_Lux ought to be getting tired of karma fortunes by now.Fiat_Lux ought to be getting tired of karma fortunes by now.Fiat_Lux ought to be getting tired of karma fortunes by now.Fiat_Lux ought to be getting tired of karma fortunes by now.Fiat_Lux ought to be getting tired of karma fortunes by now.Fiat_Lux ought to be getting tired of karma fortunes by now.Fiat_Lux ought to be getting tired of karma fortunes by now.Fiat_Lux ought to be getting tired of karma fortunes by now.
 
Fiat_Lux's Avatar
 
Posts: 287
Karma: 3625918
Join Date: Jan 2012
Location: Gimel
Device: tablets
Upgrade wierdness

Not worth filing a bug report.

Xubuntu 14.10
Python 2.7.8
Python 3.4.2

Upon upgrading to Calibre 2.12.0 from Calibre 2.8.0.
Quote:
sudo -v && wget -nv -O- https://raw.githubusercontent.com/ko...x-installer.py | sudo python -c "import sys; main=lambda:sys.stderr.write('Download failed\n'); exec(sys.stdin.read()); main()"
That fails with an error message
Quote:
2014-12-18 07:16:47 URL:https://raw.githubusercontent.com/ko...x-installer.py [25789/25789] -> "-" [1]
Installing to /opt/calibre
Downloading tarball signature securely...
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "<string>", line 652, in main
File "<string>", line 624, in download_and_extract
File "<string>", line 616, in get_tarball_info
File "<string>", line 575, in get_https_resource_securely
File "<string>", line 479, in __init__
TypeError: __init__() got an unexpected keyword argument 'context'
The fix is to replace python with python3.

Quote:
sudo -v && wget -nv -O- https://raw.githubusercontent.com/ko...x-installer.py | sudo python3 -c "import sys; main=lambda:sys.stderr.write('Download failed\n'); exec(sys.stdin.read()); main()"
Fiat_Lux is offline   Reply With Quote
Old 12-18-2014, 03:33 AM   #2
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 36,095
Karma: 15014853
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
Whoever maintains your distros python needs to realize that backporting only some changes from 2.7.9 to 2.7.8 is a bad idea. Either upgrade to 2.7.9 or dont. They have apparently backported the changes to the ssl module, but not the corresponding changes to the httplib module. Sigh.

I really, really wish linux distros would just stop messing with upstream packages, they simply dont have the resources for it.
kovidgoyal is offline   Reply With Quote
Advert
Old 05-03-2015, 01:25 AM   #3
Fiat_Lux
Addict
Fiat_Lux ought to be getting tired of karma fortunes by now.Fiat_Lux ought to be getting tired of karma fortunes by now.Fiat_Lux ought to be getting tired of karma fortunes by now.Fiat_Lux ought to be getting tired of karma fortunes by now.Fiat_Lux ought to be getting tired of karma fortunes by now.Fiat_Lux ought to be getting tired of karma fortunes by now.Fiat_Lux ought to be getting tired of karma fortunes by now.Fiat_Lux ought to be getting tired of karma fortunes by now.Fiat_Lux ought to be getting tired of karma fortunes by now.Fiat_Lux ought to be getting tired of karma fortunes by now.Fiat_Lux ought to be getting tired of karma fortunes by now.
 
Fiat_Lux's Avatar
 
Posts: 287
Karma: 3625918
Join Date: Jan 2012
Location: Gimel
Device: tablets
Quote:
Originally Posted by kovidgoyal View Post
I really, really wish linux distros would just stop messing with upstream packages, they simply don't have the resources for it.
Does the shell script used for Linux change, when Calibre is updated?

If it doesn't, then I'll run it as a weekly cron job, with that python3 correction.
Fiat_Lux is offline   Reply With Quote
Old 05-03-2015, 01:37 AM   #4
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 36,095
Karma: 15014853
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
That command is constant, it automatically fetches the most upto date version of the install script.
kovidgoyal is offline   Reply With Quote
Old 05-04-2015, 02:30 AM   #5
eschwartz
Ex-Helpdesk Junkie
eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.
 
eschwartz's Avatar
 
Posts: 19,358
Karma: 83238367
Join Date: Nov 2012
Location: The Beaten Path, USA, Roundworld, This Side of Infinity
Device: Kindle Touch fw5.3.7 (Wifi only)
You might also want to see my autoupdate scripts inthe related tools subforum. Main feature -- checking if there is actually an update available. Also comes with a systemd timer.
eschwartz is offline   Reply With Quote
Advert
Reply

Tags
calibre upgrade, python

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Why can’t I complete the Kobo Touch firmware upgrade or Desktop upgrade? DarrellAtKobo Kobo Reader 31 08-31-2012 11:45 PM
0.8.2 upgrade still shows 0.8.2 upgrade needed Under the Covers Calibre 4 05-21-2011 03:38 PM
No matter how many times I upgrade to 1.4 it still asks me to upgrade djorkboy Kobo Reader 6 09-06-2010 01:36 AM
Don't upgrade your iPhone 3GS to iOS4, DO upgrade your iPad Bookbee Apple Devices 19 07-30-2010 11:10 AM
HanLin V3 can use bebook upgrade package to upgrade it? geely HanLin eBook 3 11-21-2008 10:24 AM


All times are GMT -4. The time now is 09:42 AM.


MobileRead.com is a privately owned, operated and funded community.