Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Amazon Kindle > Kindle Developer's Corner

Notices

Reply
 
Thread Tools Search this Thread
Old 09-05-2019, 07:55 PM   #151
dd23
Junior Member
dd23 began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Sep 2019
Device: PW3
Don't forget to update your MRPI!

Story time! Maybe it's useful for someone.

I got my PW3 in 2015 and decided to jailbreak it in 2016 cause I wanted the book cover screensaver. Worked just fine back then and in the process (or maybe later?) I also installed KUAL and MRPI.
I updated the firmware for my PW3 regularly and reinstalled KUAL, python and the screen saver every time.
At some point (starting with firmware 5.9.2 on the PW3) KUAL didn't survive the updates anymore and needed to be reinstalled with ;log mrpi. Fair enough, one more step but that's also easy.

Then came 2019 and I ran into the issue that packages couldn't be installed and were destroyed by MRPI. I installed the jailbreak hotfix and everything went back to normal.
(I did not check the logs back then, but I saw now that the problem was: Failed to parse package)

Today I updated to firmware 5.12.1 but wasn't able to install any packages cause they were destroyed by MRPI. Even the hotfix did not help. I almost panicked and thought that the new firmware had somehow removed or damaged the jailbreak.
I checked the MRPI logs and saw that the newest entry said Failed to extract package. However, the more surprising part was the line before, that contained [MRPI r13359]. MRPI was still the same old version I installed in October 2016! Downloading the newest MRPI version and unzipping it on my kindle was easy. Et voila, problem solved, packages installed

TL;DR: Update your MRPI!

Also: Thanks a lot NiLuJe and everyone else involved for your hard word and continuous dedication you put into the tools that you provide here for free. Really, !
dd23 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISSUE: There is a problem with this Windows Installer package Eggplantus Calibre 5 04-14-2013 09:40 AM
0.8.4 new installer too slow JSWolf Calibre 6 06-04-2011 11:29 AM
Changes to Installer??? kgn Calibre 29 01-23-2011 10:40 AM
Invalid Windows Installer Package (7.4) Sydney's Mom Calibre 4 01-15-2011 01:28 PM
iLiad So ... any chance for an installer-package for FBReader 10? X. Trapnel iRex Developer's Corner 3 06-04-2009 08:32 PM


All times are GMT -4. The time now is 07:00 PM.


MobileRead.com is a privately owned, operated and funded community.