Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Readers > Sony Reader

Notices

Reply
 
Thread Tools Search this Thread
Old 08-26-2018, 03:44 PM   #1
mangawy
Junior Member
mangawy began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Aug 2018
Device: Sony PRS T1
Reader does not work anymore

Hello,
I wanted to root my PRS-T1 to Android because the default reader does not properly display formulas and math notations which I need most. I did two stupid mistakes: first I installed a rupor image for an earlier version of the firmware and the reader won't start anymore but I could get into recovery mode and I tried the rescue SD card but it didn't work. I tried to copy an image using win32imagewriter to the settings partition and after this the ereader is nothing but a piece of plastic. It responds to nothing, it's not detected by windows disk management or device manager. LED won't light when connected to computer USB port and windows won't show any sign that a new device is inserted. The one and only thing it does is that the red LED lights up if I connect it to wall charger. Soft resetting doesn't work. Hard resetting is not possible because the screen is frozen on the "opening book..." and won't change it no matter what...

The file I wrote to the settings partition through win32imagewriter is "C:\Users\go\Downloads\PRST1_SETTING partition\sdb7_SETTING.bin", I got it from the backup/restore thread somewhere but I have feeling it was the wrong file

Please help me solve this probelm, ideally I would like to have android on my ereader if possible. Otherwise I will be happy to have working like before.

Thank you in advance.
mangawy is offline   Reply With Quote
Old 08-27-2018, 09:10 AM   #2
Sing Sing
Member
Sing Sing doesn't litterSing Sing doesn't litter
 
Posts: 17
Karma: 196
Join Date: Aug 2018
Device: none
Hi,

If you can boot rupor-rescue, then we can help you with some commands to restore backups of any partitions you have modified. Sounds like you might already have tried, but it's worth trying again. Overwriting the SETTING partition shouldn't make it completely unrecoverable. Unless the SETTING image was written to the wrong place, like the start of the eMMC.

You can download it here if you don't have it already:
http://sonyfmngr.sourceforge.net/Rel...upor-rescue.7z
Unpack it to an SD card, and insert it into the T1. If you can't get the T1 to reboot, then press the reset button at the bottom with a pen or something. They recommend avoiding pencils in case they snap off. Nothing appears to happen, but then press the power button and then hold HOME + MENU, and hopefully you'll see the progress bar start to move. Once the progress bar is full, you can let go of the buttons and access the T1 with a terminal emulator like minicom or PuTTY.

It that doesn't work, then I'm stuck I'm afraid. If it does work OTOH, then let us know which version of the firmware you had originally, so we can find suitable backup images for you to restore.
Sing Sing is offline   Reply With Quote
Advert
Old 08-27-2018, 09:59 AM   #3
mangawy
Junior Member
mangawy began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Aug 2018
Device: Sony PRS T1
Quote:
Originally Posted by Sing Sing View Post
Hi,

If you can boot rupor-rescue, then we can help you with some commands to restore backups of any partitions you have modified. Sounds like you might already have tried, but it's worth trying again. Overwriting the SETTING partition shouldn't make it completely unrecoverable. Unless the SETTING image was written to the wrong place, like the start of the eMMC.

You can download it here if you don't have it already:
http://sonyfmngr.sourceforge.net/Rel...upor-rescue.7z
Unpack it to an SD card, and insert it into the T1. If you can't get the T1 to reboot, then press the reset button at the bottom with a pen or something. They recommend avoiding pencils in case they snap off. Nothing appears to happen, but then press the power button and then hold HOME + MENU, and hopefully you'll see the progress bar start to move. Once the progress bar is full, you can let go of the buttons and access the T1 with a terminal emulator like minicom or PuTTY.

It that doesn't work, then I'm stuck I'm afraid. If it does work OTOH, then let us know which version of the firmware you had originally, so we can find suitable backup images for you to restore.
Thank you for your swift reply. The link you provided does not work, but I think I have one of the rescue files, does it have to be a specific version?

I am afraid I did something wrong writing to the SETTINGS partition, I checked the partition size and the file size before writing to it and the file was few hundred bytes longer, I thought I would get an error or so if that would be a problem but it caused the ereader not to work any more.

I tried resetting + POWER_HOME_MENU several times and nothing change at all. I even downloaded some disk partitioning tools and of course it doesn't see it because windows does not see any device inserted.

Is there a more low-level solution? like something that would make windows recognize the device then re-partition it?

Thank you again
mangawy is offline   Reply With Quote
Old 08-27-2018, 10:51 AM   #4
Sing Sing
Member
Sing Sing doesn't litterSing Sing doesn't litter
 
Posts: 17
Karma: 196
Join Date: Aug 2018
Device: none
Sorry I copied the link from the wiki without checking it. Here's one that works:
https://projects.mobileread.com/read...scue/20121208/

Try to boot it and access the T1's shell with PuTTY.

Damage to SETTING shouldn't be fatal, that's partition 7. For Windows to see any USB device, the T1 has to boot up and load it's linux kernel, for that it needs the first part of the eMMC to be intact, up to and including partition 1. It also needs a root filesystem, which is what rupor-rescue is on the SD-card.

So if you do get it to boot, don't repartition it with Windows tools. If you damage the boot loader or the first partition you won't be able to get the device back.

If you can't get rupor rescue to boot, then maybe you wrote the SETTING image to the first part of the eMMC, in which case the boot loader is already damaged.
Sing Sing is offline   Reply With Quote
Old 08-30-2018, 05:53 AM   #5
mangawy
Junior Member
mangawy began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Aug 2018
Device: Sony PRS T1
Quote:
Originally Posted by Sing Sing View Post
Sorry I copied the link from the wiki without checking it. Here's one that works:
https://projects.mobileread.com/read...scue/20121208/

Try to boot it and access the T1's shell with PuTTY.

Damage to SETTING shouldn't be fatal, that's partition 7. For Windows to see any USB device, the T1 has to boot up and load it's linux kernel, for that it needs the first part of the eMMC to be intact, up to and including partition 1. It also needs a root filesystem, which is what rupor-rescue is on the SD-card.

So if you do get it to boot, don't repartition it with Windows tools. If you damage the boot loader or the first partition you won't be able to get the device back.

If you can't get rupor rescue to boot, then maybe you wrote the SETTING image to the first part of the eMMC, in which case the boot loader is already damaged.

Thank you once more. I can't get it to boot. I tried everything and all button combinations. I am sure the drive name was SETTINGS when I wrote the image file to it. And actually it was not an image file, it was a bin file.

Apparently I destroyed it. One question for curiosity, when T1 developers at sony are getting it ready for the first time ever, when they get the internal memory for the first time, how do they partition it and add boot loader and root software to it, any idea?
mangawy is offline   Reply With Quote
Advert
Old 08-31-2018, 04:42 AM   #6
Sing Sing
Member
Sing Sing doesn't litterSing Sing doesn't litter
 
Posts: 17
Karma: 196
Join Date: Aug 2018
Device: none
Hi,

So when you press reset, then press the power button, your don't see anything? No flashing amber light, or progress bar moving on the screen?

For programming in the factory, there are eMMC programmers that can program the eMMC chips before they are assembled into the machine, e.g.:
https://www.xeltek.com/resources/tec...k-programmers/

There should also be a JTAG header somewhere on the main board, which can be used for repair work and debugging.
Sing Sing is offline   Reply With Quote
Old 08-31-2018, 05:10 AM   #7
mangawy
Junior Member
mangawy began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Aug 2018
Device: Sony PRS T1
Quote:
Originally Posted by Sing Sing View Post
Hi,

So when you press reset, then press the power button, your don't see anything? No flashing amber light, or progress bar moving on the screen?

For programming in the factory, there are eMMC programmers that can program the eMMC chips before they are assembled into the machine, e.g.:
https://www.xeltek.com/resources/tec...k-programmers/

There should also be a JTAG header somewhere on the main board, which can be used for repair work and debugging.
Thank you again for your reply. reset + power button does nothing at all, no flashing light, no change in screen...etc. It's stuck on the "opening book..." thing since I wrote this post.

Thank you for the link
mangawy is offline   Reply With Quote
Old 08-31-2018, 05:50 AM   #8
Sing Sing
Member
Sing Sing doesn't litterSing Sing doesn't litter
 
Posts: 17
Karma: 196
Join Date: Aug 2018
Device: none
Hi,

It does sound dead, I'm afraid. Sorry I couldn't be more help.

I'll let you know if I think of anything else.
Sing Sing is offline   Reply With Quote
Old 08-31-2018, 05:51 AM   #9
mangawy
Junior Member
mangawy began at the beginning.
 
Posts: 5
Karma: 10
Join Date: Aug 2018
Device: Sony PRS T1
Quote:
Originally Posted by Sing Sing View Post
Hi,

It does sound dead, I'm afraid. Sorry I couldn't be more help.

I'll let you know if I think of anything else.
Unfortunately yes

Thank you a lot for helping me so far.

Have a nice weekend.
mangawy is offline   Reply With Quote
Reply

Tags
ereader, firmware flash, prs t1, sony

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The Economist recipe does not work anymore johndeer25 Recipes 33 04-21-2017 09:48 AM
EcoGeek recipe does not work anymore hola!claude Recipes 0 11-18-2014 05:19 AM
Video in epub does not work on iPad3 anymore georg3200 Apple Devices 0 12-03-2012 09:30 AM
PRS-T1 Recovery Mode doesn't work anymore bookp Sony Reader Dev Corner 2 07-13-2012 07:13 PM
Can't get Calibre to Work Anymore KarenMarie Calibre 7 03-25-2012 11:58 PM


All times are GMT -4. The time now is 06:28 PM.


MobileRead.com is a privately owned, operated and funded community.