Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre

Notices

Reply
 
Thread Tools Search this Thread
Old 04-08-2015, 01:00 AM   #16
JSWolf
Resident Curmudgeon
JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.JSWolf ought to be getting tired of karma fortunes by now.
 
JSWolf's Avatar
 
Posts: 49,717
Karma: 43112815
Join Date: Nov 2006
Location: Roslindale, Massachusetts
Device: Kobo Aura H2O, Sony PRS-650, Sony PRS-T1, nook STR, iPad 4, iPhone 5
Doesn't matter what the OP says and what the technical aspects are. Because Kovid has said...

Quote:
Originally Posted by kovidgoyal View Post
More and more places in calibre are going to start using stuff not available in XP.
And that means that even if you do get some recent version Calibre working, eventually, that won't ever work and my suggested upgrade will HAVE to happen. So just give it up and just tell the XP users to upgrade. It's the only way to keep from losing the fight/battle/war.
JSWolf is offline   Reply With Quote
Advert
Old 04-08-2015, 08:11 PM   #17
Matth79
Zealot
Matth79 ought to be getting tired of karma fortunes by now.Matth79 ought to be getting tired of karma fortunes by now.Matth79 ought to be getting tired of karma fortunes by now.Matth79 ought to be getting tired of karma fortunes by now.Matth79 ought to be getting tired of karma fortunes by now.Matth79 ought to be getting tired of karma fortunes by now.Matth79 ought to be getting tired of karma fortunes by now.Matth79 ought to be getting tired of karma fortunes by now.Matth79 ought to be getting tired of karma fortunes by now.Matth79 ought to be getting tired of karma fortunes by now.Matth79 ought to be getting tired of karma fortunes by now.
 
Posts: 122
Karma: 502620
Join Date: Jan 2012
Device: Kobo Touch
Would the Linux version run under Cooperative Linux or Portable Ubuntu Remix - two somewhat outdated versions which allow Linux to be run from Windows, without needing a virtualbox - got to be lighter solution than a full scale vitualbox, if you don't wish to dual boot.
Matth79 is offline   Reply With Quote
Old 04-08-2015, 08:29 PM   #18
eschwartz
Ex-Helpdesk Junkie
eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.
 
eschwartz's Avatar
 
Posts: 19,223
Karma: 83049275
Join Date: Nov 2012
Location: The Beaten Path, USA, Roundworld, This Side of Infinity
Device: Kindle Touch fw5.3.7 (Wifi only)
I don't see why not*, colinux is bog-standard linux once you ignore the whole cooperative thing , but I prefer dual booting. Actually, I only boot up to WinXP if I need to use Adobe Digital Editions, which is rare because I finally got it to play nice with WINE. I think it has been months since I booted Windows.

For all intents and purposes, linux is my only OS.


* -- keep in mind you do still have to run an up to date linux. calibre on linux doesn't have many dependencies, but it does require a reasonably new glibc. Horribly outdated ubuntu remixes might not have that.
colinux should be able to run newer linuxes though...

Last edited by eschwartz; 04-08-2015 at 08:32 PM.
eschwartz is offline   Reply With Quote
Old 08-06-2015, 02:24 PM   #19
oldyellr
Evangelist
oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.
 
Posts: 464
Karma: 26106
Join Date: Nov 2011
Location: Canada
Device: Kobo Vox
Wow, I just came across this thread. Earlier today I found that a certain user installed plugin wasn't doing its job and I wondered if I should update the Calibre 2.0 I have on my XP machine or look for a later version of the plugin. That's when Google told me I should have version 1.48 (but there was never any warning each time I had updated). The instructions said to un-install the current version and install 1.48. But I didn't want to try that in case I lost all my books. (Meanwhile, I did remove the obsolete plugin and installed the latest one, which works.)

So, what exactly won't work in Calibre 2.0 on Windows XP? Works fine for me and it has never crashed. I'm thinking, if it ain't broke, don't fix it. I'll just refrain from updating if prompted and leave it at 2.0.
oldyellr is offline   Reply With Quote
Old 08-06-2015, 02:36 PM   #20
eschwartz
Ex-Helpdesk Junkie
eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.
 
eschwartz's Avatar
 
Posts: 19,223
Karma: 83049275
Join Date: Nov 2012
Location: The Beaten Path, USA, Roundworld, This Side of Infinity
Device: Kindle Touch fw5.3.7 (Wifi only)
Qt5 may or may not work, regardless of which 2.x version of calibre you try. It's working for you? Good, you're lucky.

The installer was modified to refuse installation on Windows XP, and the application binaries were modified to refuse to start -- this happened after 2.0.0 was released and crashed numerous computers. Yes, the original v2.0.0 will still allow itself to be installed, ,it wasn't pulled from circulation. We try not to advertise that, since it isn't a good idea to depend on it.


As for downgrading calibre -- your library will not be affected. The database schema is the only thing at risk, and it hasn't been upgraded in a long time.
(Actually, that's not true. It was upgraded in a very minor way just yesterday -- but even now it is still backwards-compatible.)
eschwartz is offline   Reply With Quote
Advert
Old 08-06-2015, 03:06 PM   #21
oldyellr
Evangelist
oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.
 
Posts: 464
Karma: 26106
Join Date: Nov 2011
Location: Canada
Device: Kobo Vox
My Calibre just says 2.0, nothing more. Okay, I'm afraid I don't know what Qt5 is. I only use Calibre to convert some books from one format to another and occasionally that plugin of which we will not speak if I have a library book that will expire before I can finish it.

So how would I uninstall 2.0 to install 1.48? I don't see an uninstall. If I use Windows Add Remove Programs, are you sure it won't remove everything? I'd rather not take the chance unless 2.0 starts crashing or something.
oldyellr is offline   Reply With Quote
Old 08-06-2015, 03:26 PM   #22
theducks
Well trained by Cats
theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.theducks ought to be getting tired of karma fortunes by now.
 
theducks's Avatar
 
Posts: 20,888
Karma: 20350468
Join Date: Aug 2009
Location: (The original) Silicon Valley, USA
Device: K4NT, Galaxy Tab 2(RIP)
Quote:
Originally Posted by oldyellr View Post
My Calibre just says 2.0, nothing more. Okay, I'm afraid I don't know what Qt5 is. I only use Calibre to convert some books from one format to another and occasionally that plugin of which we will not speak if I have a library book that will expire before I can finish it.

So how would I uninstall 2.0 to install 1.48? I don't see an uninstall. If I use Windows Add Remove Programs, are you sure it won't remove everything? I'd rather not take the chance unless 2.0 starts crashing or something.
If 2.0 is stable, leave it alone.
QT5 is not a standalone fix for any version.
QT5 became a PART of Calibre a bit later (it fixed some issues calibre had been fighting).
Many PI were updated to ALSO work with QT5, while leaving QT4 support. Some newer PI make use of things in QT5 , that do not exist/work in QT4


If you do not use special (not generic) programs with XP, Linux Mint will run modern Calibre on XP grade hardware (in most cases)
Download and Burn a Live DVD of Mint Cinnamon .
Boot the DVD and give it a test spin without changing your existing system (do not choose install) to see if you can deal with the differences.

If you already use Firefox, Open/Libre office you are already ahead
Don't like it: 1) Try a different Distro 2)bin the DVD and suffer the defeat of XP
theducks is offline   Reply With Quote
Old 08-06-2015, 06:11 PM   #23
eschwartz
Ex-Helpdesk Junkie
eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.
 
eschwartz's Avatar
 
Posts: 19,223
Karma: 83049275
Join Date: Nov 2012
Location: The Beaten Path, USA, Roundworld, This Side of Infinity
Device: Kindle Touch fw5.3.7 (Wifi only)
QT is just the graphical toolkit, as I said in the OP. It is used for assembling the User Interface, and is embedded within calibre. I doubt you have ever thought about Firefox and Google Chrome using Gtk2 either.

These are just of interest for development.




If calibre v2.0.0 works for you, you can probably just leave it alone.
Or simply re-install the older version to be extra-extra sure. Uninstalling the currently-installed version works too.

Uninstalling calibre does NOT delete your library, nor does it wipe your settings.
eschwartz is offline   Reply With Quote
Old 08-17-2015, 08:37 AM   #24
5STARS
Junior Member
5STARS began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Aug 2015
Device: none
New to calibre, and thanks for this information, because I put Ver 1.48 onto an older XP based laptop I use when trying out new stuff that I'm not overly rushing to advance skills & utilize at optimum levels right off the bat.

At first run though I did get an immediate pop-up UPDATE to Version 2.35 dialogue box.
I thought this was a little odd, given what I've read in all these threads about what a waste of time it is to attempt to run any newer versions of Calibre - And, just prior to the installation, I had accidentally downloaded an inappropriate version for my machine & immediately during installation was informed that before an attempt to install that version I would need to have .net framework at least 2.0 installed.

Well, out of sheer curiousity can someone please tell me how it is that Calibre can determine my compatibility in that respect (the .net issue) but it offered at the Ver 1.48 to update to 2.35.

Isn't there contradiction here ? ? It seems so.

Anyway, in that same pop-up dialogue box (which appears dropping into view like a splash screen during the first run of the newly installed app) the installer did have a checkbox to allow/deny auto-update seeking which was checked by default, that I UN-checked, and an option to proceed or exit from the offer to update. I exited.

Thanks again. Any feedback or insight about this is welcome.
5STARS is offline   Reply With Quote
Old 08-17-2015, 09:41 AM   #25
mbovenka
Wizard
mbovenka ought to be getting tired of karma fortunes by now.mbovenka ought to be getting tired of karma fortunes by now.mbovenka ought to be getting tired of karma fortunes by now.mbovenka ought to be getting tired of karma fortunes by now.mbovenka ought to be getting tired of karma fortunes by now.mbovenka ought to be getting tired of karma fortunes by now.mbovenka ought to be getting tired of karma fortunes by now.mbovenka ought to be getting tired of karma fortunes by now.mbovenka ought to be getting tired of karma fortunes by now.mbovenka ought to be getting tired of karma fortunes by now.mbovenka ought to be getting tired of karma fortunes by now.
 
Posts: 1,648
Karma: 6400817
Join Date: Oct 2007
Location: Almere, The Netherlands
Device: Kobo Aura ONE
Quote:
Originally Posted by 5STARS View Post
Well, out of sheer curiousity can someone please tell me how it is that Calibre can determine my compatibility in that respect (the .net issue) but it offered at the Ver 1.48 to update to 2.35.

Isn't there contradiction here ? ? It seems so.
There is no compatibility check there at all. It just saw you had and older version than the current one and offered you the upgrade to 2.35. Which wouldn't have worked for you because it needs the newer Qt (not .net). You can disable the check for a newer version in the settings.
mbovenka is offline   Reply With Quote
Old 08-17-2015, 12:05 PM   #26
oldyellr
Evangelist
oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.oldyellr is not intimidated by interfenestral monkeys.
 
Posts: 464
Karma: 26106
Join Date: Nov 2011
Location: Canada
Device: Kobo Vox
According to this post above,https://www.mobileread.com/forums/sho...3&postcount=20 the newer versions after v.2.0.0 apparently would refused to install on XP. I'm at v.2.0.0 now on my XP machine and it's working fine for me so far.
oldyellr is offline   Reply With Quote
Old 08-17-2015, 12:21 PM   #27
PeterT
Grand Sorcerer
PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.PeterT ought to be getting tired of karma fortunes by now.
 
PeterT's Avatar
 
Posts: 10,030
Karma: 58960723
Join Date: Nov 2007
Location: Toronto
Device: Wife: Touch, Arc, Vox Me: Nexus 7, Glo
It was only after the initial conversion of calibre to use QT5 that the extent of the issues with XP and QT5 became apparent. At that point Kovid decided to no longer support XP with any subsequent QT5 based builds, and that is why calibre 2.01 and beyond will not install on XP.
PeterT is offline   Reply With Quote
Old 08-17-2015, 04:35 PM   #28
BetterRed
null operator
BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.BetterRed ought to be getting tired of karma fortunes by now.
 
Posts: 9,094
Karma: 7214933
Join Date: Mar 2012
Location: Sydney Australia
Device: none
@5STARS - not sure if this is appropriate to your situation but FWIW . . .

Another, and arguably simpler, way to give yourself a Calibre 'test bed' is to install Calibre Portable alongside your installed version (64 or 32 bit), it's self contained and won't interfere with the installed version.

Also if you normally use 64 bit, then you can also install 32 bit. In this instance they will use the same data (configuration and libraries). This can be useful for checking the behaviour of earlier versions - i.e. the "I'm sure this used to work" scenario

BR
BetterRed is offline   Reply With Quote
Old 02-18-2016, 10:47 AM   #29
Dragon Laughs
Junior Member
Dragon Laughs began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Apr 2008
Device: notebook computer
I have an atom processor netbook - I could installl Win 7 on it, but it wouldn't "run" - at best, we're talking crawl. Works great with WinXP for everything I need to do. And I don't like the throwaway culture attitude of replace, replace, newer, faster, etc. So thank you eschwartz for the heads up on sticking with Calibre 1.48. I may try a linux distro as you suggest, but right now I just want to get stuff done and use my netbook as a tool without torturing myself about it.
Dragon Laughs is offline   Reply With Quote
Old 02-18-2016, 11:30 AM   #30
eschwartz
Ex-Helpdesk Junkie
eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.eschwartz ought to be getting tired of karma fortunes by now.
 
eschwartz's Avatar
 
Posts: 19,223
Karma: 83049275
Join Date: Nov 2012
Location: The Beaten Path, USA, Roundworld, This Side of Infinity
Device: Kindle Touch fw5.3.7 (Wifi only)
Happy to help, I write from my ~11-yr-old laptop running Arch Linux.
(Dell Inspiron B130, single-core Pentium M, self-upgraded 512MB ==> 2GB RAM, etc. etc.)
eschwartz is offline   Reply With Quote
Reply

Tags
calibre 2.x, qt5, windows xp

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Calibre install fails windows 8 rover176 Devices 3 05-06-2013 05:36 AM
Can't install Calibre on Windows Vista jo jo Devices 8 12-27-2012 02:44 PM
Cannot install Calibre 8.6 in Windows 7 polarbearx Calibre 5 07-26-2012 09:39 AM
Why can't I install Calibre on Windows 7 ? Joypeace3 Calibre 1 01-24-2012 12:50 PM
Cannot install calibre in windows 7 chirotor Calibre 20 12-18-2010 06:05 AM


All times are GMT -4. The time now is 09:52 AM.


MobileRead.com is a privately owned, operated and funded community.