Register Guidelines E-Books Search Today's Posts Mark Forums Read

Go Back   MobileRead Forums > E-Book Software > Calibre > Server

Notices

Reply
 
Thread Tools Search this Thread
Old 12-31-2018, 10:58 AM   #1
Irvin
Junior Member
Irvin began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Dec 2018
Device: Tolino, Kindle Paperwhite
calibredb does not work with content server running (content server is using --enable

Hi all,

I cannot use calibredb on ubuntu command line because of

"Another calibre program ... is running". But calibre-server is running with "--enable-local-write"

What I'm doing wrong?

How can I use calbredb at the same time, while calibre-server is running?

with best regards,
Irvin




Logs:

root@host1:~# calibredb --version
calibredb (calibre 3.7)
root@host1:~#
root@host1:~# calibre-server --version
calibre-server (calibre 3.7)
root@host1:~#



root@host1:~# uname -a
Linux host1 4.15.0-1021-aws #21-Ubuntu SMP Tue Aug 28 10:23:07 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

root@host1:~# ps -edalf | grep calibre | grep -v grep
4 S root 1 0 0 80 0 - 272788 poll_s 15:34 ? 00:00:01 /usr/bin/python2.7 /usr/bin/calibre-server /opt/calibre/library --enable-local-write

root@host1:~# calibredb list_categories --library-path /opt/calibre/library
Another calibre program such as calibre-server or the main calibre program is running. Having multiple programs that can make changes to a calibre library running at the same time is a bad idea. calibredb can connect directly to a running calibre content server, to make changes through it, instead. See the documentation of the --with-library option for details.

Last edited by Irvin; 12-31-2018 at 11:03 AM.
Irvin is offline   Reply With Quote
Old 12-31-2018, 09:24 PM   #2
kovidgoyal
creator of calibre
kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.kovidgoyal ought to be getting tired of karma fortunes by now.
 
kovidgoyal's Avatar
 
Posts: 34,883
Karma: 12571798
Join Date: Oct 2006
Location: Mumbai, India
Device: Various
You need to pass the URL of the server as --library-path, see https://manual.calibre-ebook.com/gen...calibredb.html
kovidgoyal is offline   Reply With Quote
Advert
Old 01-01-2019, 05:03 AM   #3
Irvin
Junior Member
Irvin began at the beginning.
 
Posts: 6
Karma: 10
Join Date: Dec 2018
Device: Tolino, Kindle Paperwhite
Ok. Thank you.

Last edited by Irvin; 01-01-2019 at 05:34 AM.
Irvin is offline   Reply With Quote
Old 01-08-2019, 02:47 AM   #4
kleedrac
Junior Member
kleedrac began at the beginning.
 
Posts: 1
Karma: 10
Join Date: Jan 2019
Device: Lenovo Tab A10
I'm having a similar issue. The server is running fine but I'm trying to make a script to auto-add books in a certain directory. If I invoke the command:

calibredb add --recurse --with-library="http://127.0.0.1:8080/#calibre" --username="kleedrac" --password=</home/kleedrac/pwd> "/home/kleedrac/calibre/toadd"

it returns "-bash: /home/kleedrac/calibre/toadd/: is a directory"

If I reword it to
calibredb add --with-library="http://127.0.0.1:8080/#calibre" --username="kleedrac" --password=</home/kleedrac/pwd> --recurse "/home/kleedrac/calibre/toadd/"

it says nothing in the terminal but creates a file called --recurse in the /home/kleedrac/calibre/toadd/ folder! What am I doing wrong? The server is invoked with both --enable-local-write and --enable-auth

EDIT: Apparently I didn't read the documentation closely enough and wasn't escaping the <> characters. The command as it worked was:

calibredb add /home/kleedrac/calibre/toadd/ --recurse --with-library="http://127.0.0.1:8080/#calibre" --username="kleedrac" --password="<f:/home/kleedrac/pwd>"

A smart man learns from his mistakes - a wise man learns from other's

Last edited by kleedrac; 01-08-2019 at 03:02 AM.
kleedrac is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How do you enable HTTPS on the content server? Inukami Server 12 12-05-2018 03:58 PM
Python error when accessing content server with calibredb drawson1 Library Management 1 06-19-2018 12:08 PM
calibredb to write to a remote content server? plo233 Calibre 7 10-05-2017 12:34 AM
calibredb cannot add with content server running apiontek Calibre 10 08-04-2017 04:50 AM
Content Server running on Android box? bthoven Devices 3 08-07-2011 03:31 AM


All times are GMT -4. The time now is 12:28 AM.


MobileRead.com is a privately owned, operated and funded community.